Bug Hunting Session
Bug 75937 - Galaxy icon set missing in 4.3
Summary: Galaxy icon set missing in 4.3
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: All All
: high minor
Assignee: Not Assigned
URL:
Whiteboard: confirmed:win7 target:4.4.0 target:4.3.0
Keywords: regression
Depends on:
Blocks: mab4.3 Icon-Theme-Galaxy
  Show dependency treegraph
 
Reported: 2014-03-09 02:31 UTC by Urmas
Modified: 2017-07-31 23:43 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2014-03-09 02:31:02 UTC
There is no Windows-appropriate icon theme available for LO since 4.2.1.

The only available options include 2 butt-ugly KDE themes and 1 Gnome theme.
Comment 1 tommy27 2014-03-09 07:32:50 UTC
actually available themes in 4.2.x are:
- Tango
- Galaxy
- Crystal
- Hi Contrast
- Oxygen
- Sifr

apart from Sifr that was introduced in 4.2.x all the other themes were already present in previous releases and were inherited from OOo, so what's exactly the problem with 4.2.1?

in the past the Classic theme was also available and it was based on Win98 icons.
it has been removed but you can enable it again manually, see Bug 38175
Comment 2 Urmas 2014-03-09 08:07:43 UTC
There is no Galaxy theme anymore.
Comment 3 tommy27 2014-03-09 08:13:54 UTC
I run the portable LibO 4.2.1 release from winPenPack under Win7x64 ( http://www.winpenpack.com/main/download.php?view.1354 ) and Galaxy is available under theme configuration options.
Comment 4 Adolfo Jayme 2014-03-10 03:28:06 UTC
Do not be silly. What does "proper" mean according to you? There was never a theme resembling XP/Vista icons in Star/Open/LibreOffice, if that is what you mean with "proper". Thus, this is NOT a regression in 4.2.1.
Comment 5 tommy27 2014-03-10 06:37:51 UTC
@Adolfo
the regression he was talking about is the loss of Galaxy theme in 4.2.1, which however I do not confirm since I see it on my PC.

reading his comment it seems that he only sees 3 themes in his installation ( comment 0 ), while I see that there are 6 themes like in previous releases.
Comment 6 Urmas 2014-03-10 10:32:23 UTC
Once again: Gnome/KDE icon sets do not belong on Windows platform.
Comment 7 Maxim Monastirsky 2014-03-10 11:44:48 UTC
@Urmas: You probably mean master (not 4.2), where I indeed can't see the Galaxy theme. If that's the case, please update the version field.
Comment 8 tommy27 2014-03-10 12:23:55 UTC
in master 4.3 available themes are:
- Tango
- Tango_testing
- Crystal
- Hi Contrast
- Oxygen
- Sifr

so, it looks like Galaxy has been removed from 4.3.x

anyway it seems that Urmas was talking of a 4.2.1 release with just 3 themes available... which is not the case with 4.3.x which has 5 themes and 1 variant of one of them

unless this has been definitively cleared I set status to NEEDINFO
Comment 9 Adolfo Jayme 2014-03-11 14:29:43 UTC
> so, it looks like Galaxy has been removed from 4.3.x

Can you please inform yourselves and take a look at the git repository before stating that? For you: http://cgit.freedesktop.org/libreoffice/core/tree/icon-themes/galaxy

Nobody can reproduce missing icon themes in 4.2, WFM
Comment 10 tommy27 2014-03-11 14:56:39 UTC
calm down Adolfo... I was talking about 4.3.x master where the Galaxy is not present, while the current report is about 4.2.x 

so we asked Urmas to specify which version he's talking about...
maybe he erroneously indicated 4.2.x
Comment 11 Regina Henschel 2014-03-23 21:16:33 UTC
I can confirm, that "Galaxy" is missing from the list in Tools > Options > LibreOffice > View. It is missing in
Version: 4.2.2.1
Build-ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
and in
Version: 4.3.0.0.alpha0+
Build ID: f839b5dd16c05c0eda21345ec36ec0cb024eb732
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-02-23_09:54:38
both on Windows 7.

The icons are still in share/config/images.zip, but not listed. If you change the file name to images_galaxy.zip, then they are listed, and can be chosen.

The error seems to be, that the icon-set with only "images" as name is no longer handled as "automatic" or "default".
Comment 12 pierre-yves samyn 2014-05-24 08:52:17 UTC
(In reply to comment #11)

Hello 

I confirm  that "Galaxy" is missing from the list in Tools > Options >
> LibreOffice > View on windows 7/64 with Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

> The icons are still in share/config/images.zip, but not listed. If you
> change the file name to images_galaxy.zip, then they are listed, and can be
> chosen.

I confirm that too

"Galaxy" is *not* missing on windows 7/64 Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

Regards
Pierre-Yves
Comment 13 pierre-yves samyn 2014-05-24 13:28:34 UTC
(In reply to comment #12)

> > The icons are still in share/config/images.zip, but not listed. If you
> > change the file name to images_galaxy.zip, then they are listed, and can be
> > chosen.
> 
> I confirm that too

I add that the Navigation buttons (moved to the find bar) have no icons when you force LibreOffice to use Galaxy like this (text "previous/next element" is displayed instead.)


Regards
Pierre-Yves
Comment 14 Shunesburg69 2014-05-28 21:22:11 UTC
Why the theme "Galaxy" is not present in 4.3 ?
Is it a mistake ?
Comment 15 pierre-yves samyn 2014-05-29 05:13:29 UTC
(In reply to comment #14)
> Why the theme "Galaxy" is not present in 4.3 ?
> Is it a mistake ?

Please not change the choices in the drop-down lists.
I restore initial values (OS & Version)
Comment 16 Shunesburg69 2014-05-31 18:23:28 UTC
(In reply to comment #15)
> Please not change the choices in the drop-down lists.
> I restore initial values (OS & Version)

Sorry
Comment 17 Regina Henschel 2014-06-19 21:52:29 UTC
(In reply to comment #13)
> (In reply to comment #12)
> 
> > > The icons are still in share/config/images.zip, but not listed. If you
> > > change the file name to images_galaxy.zip, then they are listed, and can be
> > > chosen.
> > 
> > I confirm that too
> 
> I add that the Navigation buttons (moved to the find bar) have no icons when
> you force LibreOffice to use Galaxy like this (text "previous/next element"
> is displayed instead.)
> 
> 
> Regards
> Pierre-Yves

The reason is, that the commands .uno:ScrollToPrevious and .unoScrollToNext are new and the corresponding icons were not added to the Galaxy theme. You can workaround it, when you copy the lc_navigateback.png to lc_scrolltoprevious.png, sc_navigateback.png to sc_scrolltoprevious.png, lc_navigateforward.png to lc_scrolltonext.png, and sc_navigateforward.png to sc_scrolltonext.png. Those icons, which belong to an uno command are located in folder cmd and follow the pattern lc_commandnameinlowercase. A new command .uno:MyNewTask will find an icon named lc_mynewtask, for example.

Nevertheless, it is a bug, that the Galaxy theme does not work out-of-the-box.
Comment 18 Regina Henschel 2014-06-19 22:06:47 UTC
Or copy the file links.txt from images_sifr to images_galaxy, then you need not copy the images themself.
Comment 19 pierre-yves samyn 2014-06-20 08:15:33 UTC
Hi

Bug still occurs on windows 7/64 & Version: 4.3.0.1
Build ID: 67f5430184326974072b65403ef1d9d934fc4481

I added the keyword Regression

Regards
Pierre-Yves
Comment 20 V Stuart Foote 2014-07-03 15:32:58 UTC
On Widnows 7 sp1, 64-bit en-US with
Version: 4.3.0.2
Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409

Following installation Galaxy icon set are built, but they is not being exposed from the Tools -> Options -> View Icon Size and Style drop down.

The icons are packaged with the install to:

C:\Program Files (x86)\LibreOffice 4\share\config\images.zip  

And, it seems to work correctly if that zipped archive is renamed images_galaxy.zip as suggested. But the install packaging should take care of this.

Unclear if the "links.txt" needs to still be adjusted as in comment 18

Nominating to MAB 4.3
Comment 21 Michael Meeks 2014-07-09 12:34:28 UTC
The code does:

    // Set known icon themes
    OUString sAutoStr( m_pIconStyleLB->GetEntry( 0 ) );
    m_pIconStyleLB->Clear();
    StyleSettings aStyleSettings = Application::GetSettings().GetStyleSettings();
    mInstalledIconThemes = aStyleSettings.GetInstalledIconThemes();

in cui/source/options/optgdlg.cxx

I suspect we just don't detect that Galaxy is installed for some reason (prolly the naming issue below) in GetInstalledIconThemes =)
Comment 22 Michael Meeks 2014-07-09 12:36:24 UTC
I guess a side-effect of Thomas' nice work here:

commit 076a7eacca48f203f0a8b9aa537e88fea9a88409
Author: Tobias Lippert <drtl@fastmail.fm>
Date:   Sun Feb 9 00:53:28 2014 +0100

    Bug #63962 Dynamically scan the config directory for icon themes
    
    The hard-coded icon themes have been replaced by a dynamic list
    which is filled by scanning the config directory
Comment 23 V Stuart Foote 2014-07-09 12:44:04 UTC
That looks to be the issue. Tobias says as much in https://bugs.freedesktop.org/show_bug.cgi?id=63962#c10
Comment 24 Commit Notification 2014-07-09 12:51:33 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=af433f404f14c5dbed77b5fb764cf24caca9631e

fdo#75937 - package galaxy theme in a form we like; cf. fdo#81103.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Michael Meeks 2014-07-09 12:54:15 UTC
Pushed fix to master, patches waiting in gerrit for 3.4.0 and 3.4.x - ideally we need some follow-up cf. fdo#81103.
Thanks for the report ! =)
Comment 26 Commit Notification 2014-07-10 14:27:37 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba771af1f126f2c3b45a89e2f18689babdb77c45&h=libreoffice-4-3

fdo#75937 - package galaxy theme in a form we like; cf. fdo#81103.


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2014-07-11 08:31:41 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d1ed906b4cf0ab46a975f3caab8dfd1b5c7f4118&h=libreoffice-4-3-0

fdo#75937 - package galaxy theme in a form we like; cf. fdo#81103.


It will be available already in LibreOffice 4.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 Jean-Baptiste Faure 2014-07-13 16:51:39 UTC
Verified fixed in Version: 4.3.1.0.0+
Build ID: 90939f2b5dfc8a7aafc255322f0fcb66f670241e under Ubuntu 14.04 x86-64 (build at home).

Thank you very much for the fix.
Best regards. JBF