Download it now!
Bug 81103 - cleanup 'default' icon theme ...
Summary: cleanup 'default' icon theme ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-09 12:49 UTC by Michael Meeks
Modified: 2015-10-20 16:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2014-07-09 12:49:07 UTC
It seems that we're a bit confused about the default icon theme in 4.3+.

It would be a great idea to drop images.zip - since the code doesn't use that - so that we always have a theme suffix. It'd be nice to drop the default.zip mentions across the code - we don't distribute that. bug#75937 adds the images_galaxy.zip which we want - though I think the real default should be images_tango.zip [ though ~no-one will really see that I think ].

Any chance of a cleanup there ? also the schema prolly needs galaxy adding to it:

officecfg/registry/schema/org/openoffice/Office/Common.xcs

as a value for the theme key =)

Thanks !
Comment 1 Michael Meeks 2014-07-09 12:52:01 UTC
It would also save some install size not duplicating the galaxy theme I guess =)
Comment 2 QA Administrators 2015-07-18 17:43:11 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 3 Yousuf Philips (jay) (retired) 2015-10-19 12:47:18 UTC
@Meeks: We no longer ship images.zip since 4.4, so i think the only thing missing here is to change officecfg/registry/schema/org/openoffice/Office/Common.xcs and replace

          <enumeration oor:value="default">
            <info>
              <desc>Default - the OpenOffice.org default theme</desc>
            </info>
          </enumeration>

with

          <enumeration oor:value="galaxy">
            <info>
              <desc>Galaxy - the OpenOffice.org default theme</desc>
            </info>
          </enumeration>

unless we need a 'default' entry, wherein we would add the galaxy entry.
Comment 4 Laurent BP 2015-10-19 17:42:14 UTC
(In reply to Yousuf (Jay) Philips from comment #3)
> @Meeks: We no longer ship images.zip since 4.4, so i think the only thing
> missing here is to change
> officecfg/registry/schema/org/openoffice/Office/Common.xcs and replace
Actually, it is what I proposed in this commit 
https://gerrit.libreoffice.org/17441
Comment 5 Yousuf Philips (jay) (retired) 2015-10-20 14:52:33 UTC
(In reply to Laurent BP from comment #4)
> Actually, it is what I proposed in this commit 
> https://gerrit.libreoffice.org/17441

Well it seems the change in Common.xcs wasnt useful (bug 92458 comment 9) as the entire section was removed here < http://cgit.freedesktop.org/libreoffice/core/commit/?id=5ab2bb87d9039e7c3f2dde87698df065967a731e >, so you can abandon your patch.
Comment 6 Laurent BP 2015-10-20 16:03:19 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> (In reply to Laurent BP from comment #4)
> > Actually, it is what I proposed in this commit 
> > https://gerrit.libreoffice.org/17441
> 
> Well it seems the change in Common.xcs wasnt useful (bug 92458 comment 9) as
> the entire section was removed here <
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=5ab2bb87d9039e7c3f2dde87698df065967a731e >,
Thanks for the link.

> so you can abandon your patch.
Done.