Bug Hunting Session
Bug 76598 - FILEOPEN: PPTX: text in shapes inverted
Summary: FILEOPEN: PPTX: text in shapes inverted
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-25 14:31 UTC by Timur
Modified: 2014-08-27 15:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LO Impress inverts text in object when importing pptx (67.55 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-03-25 14:31 UTC, Timur
Details
PDF as it should look (256.72 KB, application/x-pdf)
2014-03-25 14:34 UTC, Timur
Details
ODP exported from Microsoft Office (39.46 KB, application/vnd.oasis.opendocument.presentation)
2014-03-25 14:36 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2014-03-25 14:31:41 UTC
Created attachment 96369 [details]
LO Impress inverts text in object when importing pptx

Current LO Impress 4.1.5.3 and 4.2.3.1 don't correctly open attached PPTX with shapes. Text within is inverted. PPTX correctly shown in Microsoft Office and Kingsoft Office.  Attached also PDF and ODP from Microsoft Office. 

Tried with LO 3.5.7 and 3.6.5. They also didn't open this correctly, although a part was correct (slide 1, beneath "CIO Academy Future of the CIO"). 
Opening in newer versions is different from 4.0.5 and onwards (all text is wrong). So I put 4.0 as "Version".
Comment 1 Timur 2014-03-25 14:34:49 UTC
Created attachment 96370 [details]
PDF as it should look
Comment 2 Timur 2014-03-25 14:36:54 UTC
Created attachment 96371 [details]
ODP exported from Microsoft Office
Comment 3 Julien Nabet 2014-03-25 21:41:43 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.
Comment 4 Timur 2014-04-01 10:32:59 UTC
Following https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg I mark this bug as 'Major High' because of the inability to open a particular document
Comment 5 Timur 2014-08-27 15:53:19 UTC
Tested today with 4.2.6.2 and 4.3.0.3 and opens fine. 
Since I don't know exactly how it was fixed, I mark as Worksforme.