Bug 76735 - UI: Options below "Pivot Table -> More" not visable in 768pixel high GNOME (thus Pivot is useless)
Summary: UI: Options below "Pivot Table -> More" not visable in 768pixel high GNOME (t...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.1 rc
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: GnomeOnly target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-28 12:47 UTC by Kevin Suo
Modified: 2014-04-11 15:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Full-screen-shot (83.43 KB, image/png)
2014-03-28 12:52 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-03-28 12:47:01 UTC
Steps:
1. Data -> Pivot Table -> Current Selection;
2. Click "More" button of the Pivot Table window

Current Behaviour:
The window in step 2 can not be resized.
As a result, the contents below "More" are not shown completely and I can not choose the options. This causes Pivot Table function useless in my system.

May be a regression. May be other windows which can not be resized and users can not make selections.

OS: Fedora 20 (Gnome desktop)
LibreOffice 4.2.3.1, still reproducable in 4.2.3.2.
Comment 1 Kevin Suo 2014-03-28 12:52:42 UTC
Created attachment 96530 [details]
Full-screen-shot

This is a FULL screenshot. 

Please notice the bottom of the screen, some options are not visable, window can not be resized, so the options below can not be selected.
Comment 2 A (Andy) 2014-03-28 18:27:45 UTC
reproducible with LO 4.2.2.1 (Win 8.1)

Caolán and several other LO programmers are already very intensively working on converting the LO dialogs from the .src to .ui type (see Caolán's blog).
Afterwards, you have the option to resize the dialogs.  Thanks to Caolán and the others many dialogs are already converted.  This is a huge task and an impressive achievement. 
This reported dialog is probably one that is still missing, but will probably follow soon if not already done in the LO master.  But of course due to the many dialogs we need to have some patience.

Caolán: I put you in copy in case you still need this dialog for your To Do list.  Please correct my comment if I am not right.
Comment 3 Kevin Suo 2014-03-29 03:25:07 UTC
(In reply to comment #2)

The problem is not the "resize" issue only. My main concern is: Not all options of "Pivot Table -> More" are visable (in Gnome desktop), so pivot table is useless.

I tested in ubuntu 13.10 and Win 7, and see the options below "More" are visable.

So,
1. I am fine with the in-progress .src -> .ui convertion.
2. The "more" window is not completely visable (in Gnome desktop), because:
  * Calc does not auto detect the max window height of the OS (when "more" button is hit), so it draw a very large and long window which makes the bottom of the options out of the screen.
  * Even if it draw a large and long window, it should allow me to resize in order to see the rest of the window.
3. Changing the title, and set OS to linux-all, and whiteboard "GnomeOnly".
Comment 4 A (Andy) 2014-03-29 07:29:27 UTC
Thanks for your reply.  I agree with you that the in your point 2 (in comment 3) discussed issue should be resolved.
Comment 5 Tomaz Vajngerl 2014-03-29 18:31:31 UTC
Hi,

For LO master (to be 4.3) I am reimplementing the pivot table layout dialog (I will push it into master very soon) which has a more compact layout (and no custom widgets - just "plain old list boxes" :) ). Besides the pivot table options are above the "Selection from", "Results to", (Source, Destination). I am also considering to move Source, Destination out of this dialog into a new dialog later. 

So I wouldn't work on this issue too much - maybe just a quick fix for LO 4.2

Regards, Tomaž
Comment 7 Kohei Yoshida 2014-04-08 19:08:21 UTC
This is no longer an issue in 4.3.
Comment 8 Kevin Suo 2014-04-09 00:35:06 UTC
(In reply to comment #7)
> This is no longer an issue in 4.3.

This is no longer an issue in 4. 3/master because of Tomaz Vajngerl's commit in comment 6.  However, this is still an issue in 4. 2. 

Since 4. 3 is still far away and may take maybe a year to be stable, it's necessary to commit a patch to 4. 2. (not sure if this bug exists in 4. 1, but as 4.1 is approaching it's EOF a patch is not necessary, but will be appreciate if there is one.  )

Reopening.
Comment 9 Kohei Yoshida 2014-04-11 14:54:10 UTC
Closing it again.  We got far bigger issues to deal with than this. Unless you can work on this yourself, don't reopen this.
Comment 10 Tomaz Vajngerl 2014-04-11 14:58:38 UTC
And.. Caolán adapted it for LO 4.2.3 as he said in #6 so I don't understand why this was reopened...
Comment 11 Kevin Suo 2014-04-11 15:22:06 UTC
(In reply to comment #10)
> And.. Caolán adapted it for LO 4.2.3 as he said in #6 so I don't understand
> why this was reopened...

I thought it was fixed in 4.2.3, but:
in 4.2.3.3
Build ID: 6c3586f855673fa6a1576797f575b31ac6fa0ba3
It is still the same.

I am not sure where the change in comment 6 have gnone.

> We got far bigger issues to deal with than this. Unless you can work on this yourself, don't reopen this.

Maybe you dont use Gnome and you dont use Pivot Table, but there are many people using it. We know why this bug happen and know where the code is, but just tell those people using Gnome desktop that this bug WONTFIX? It really want to fix it myself but I dont know the code issue, I am not a developer, I am an accountant.

Yes I can wait maybe this be fixed in 4.3, but me and many other users are using libreoffice for productivity, not for testing and for dev work. It will take maybe a year for 4.3 to be stable.