Bug Hunting Session
Bug 77478 - FILESAVE: [regresssion] images arent being saved in .docx files
Summary: FILESAVE: [regresssion] images arent being saved in .docx files
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisectRequest, possibleRegression, regression
: 80102 80230 (view as bug list)
Depends on:
Blocks: DOCX-Images OOXML-2007
  Show dependency treegraph
 
Reported: 2014-04-15 09:46 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-27 01:51 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment has the original file and then that file save as a .docx file in both 4.1 and 4.2 (2.42 MB, application/zip)
2014-04-15 09:46 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-04-15 09:46:12 UTC
Created attachment 97386 [details]
attachment has the original file and then that file save as a .docx file in both 4.1 and 4.2

Problem description: 
images arent being saved in ooxml transitional .docx files since 4.2. this problem isnt there in 4.1.5 and is not doesnt happen if i save the file as a ooxml text .docx file in 4.2.3

Steps to reproduce:
1. download the file http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx
2. then save it as a ms office 2007 xml .docx file
3. open the saved file

Current behavior:
you see the outline of an image on the second page of the file and you see the outline of the image on page '18/302' with the error message 'Read-Error' in it

Expected behavior:
the images to have saved correctly and loaded correctly.

I had first noticed this error when reading a review at this link - http://netrunner-mag.com/libreoffice-vs-microsoft-office-part-deux/
              
Operating System: Ubuntu
Version: 4.2.3.3 rc
Last worked in: 4.1.5.3 release
Comment 1 Michael Meeks 2014-04-19 19:07:50 UTC
Hi Lubos; did the fix for this get cherry-picked to libreoffice-4-2 ? :-)
Comment 2 Luboš Luňák 2014-04-20 11:46:00 UTC
I cannot reproduce with current 4.2, so presumably this has been already fixed for 4.2.4.
Comment 3 Yousuf Philips (jay) (retired) 2014-04-20 20:18:19 UTC
just tried it on 4.2.4.1 and i seems to be fixed.
Comment 4 Yousuf Philips (jay) (retired) 2014-06-19 18:21:01 UTC
*** Bug 80102 has been marked as a duplicate of this bug. ***
Comment 5 Yousuf Philips (jay) (retired) 2014-06-19 22:18:24 UTC
*** Bug 80230 has been marked as a duplicate of this bug. ***
Comment 6 Yousuf Philips (jay) (retired) 2014-06-24 21:49:43 UTC Comment hidden (obsolete)
Comment 7 Robinson Tryon (qubit) 2015-12-15 22:07:34 UTC Comment hidden (obsolete)