Bug Hunting Session
Bug 77776 - regression: "could not start printer" when printing to remote cups server
Summary: regression: "could not start printer" when printing to remote cups server
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.5.2 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.4
Keywords: regression
: 78285 78446 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-22 19:36 UTC by Ryan Tandy
Modified: 2014-08-27 07:36 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot Error (14.89 KB, image/png)
2014-04-23 20:34 UTC, Samuel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Tandy 2014-04-22 19:36:55 UTC
Problem description: 

With LibreOffice 4.2.3, when printing to a remote cupsd over a TCP connection, the error message "Could not start printer. Please check your printer configuration." is displayed, but the document is still printed. This did not happen in 4.2.4. Verified with 4.2.3 on Ubuntu 12.04 and 14.04, and with 4.2.4 RC1 on Ubuntu 14.04.

I think this happens to the first job sent on a particular TCP connection. If I send two jobs in a row, I see the message on the first job but not the second. If I wait for the CUPS connection timeout to elapse (default 5 minutes) and send another job, I see the message again.

Steps to reproduce:

1. Configure CUPS to use a TCP connection: mkdir ~/.cups ; echo 'ServerName 127.0.0.1' >> ~/.cups/client.conf
2. Open LibreOffice and print a document.

Current behavior:

An error message is displayed. However,the document is still printed.

Expected behavior:

No error message should appear.
Comment 1 Samuel 2014-04-23 13:38:54 UTC
> With LibreOffice 4.2.3, when printing to a remote cupsd over a TCP
> connection, the error message "Could not start printer. Please check your
> printer configuration." is displayed, but the document is still printed.
> This did not happen in 4.2.4. Verified with 4.2.3 on Ubuntu 12.04 and 14.04,
> and with 4.2.4 RC1 on Ubuntu 14.04.

Can confirm on Debian 7.4 amd64 with LibreOffice 4.2.3.3 and CUPS (cups 1.5.3-5+deb7u1) network printer.

@ Ryan,
if it work now again with LibreOffice 4.2.4 RC1, did you know which commit fix this issue?
https://wiki.documentfoundation.org/Releases/4.2.4/RC1
Comment 2 Ryan Tandy 2014-04-23 15:19:00 UTC
(In reply to comment #1)
> @ Ryan,
> if it work now again with LibreOffice 4.2.4 RC1, did you know which commit
> fix this issue?

Sorry. I made a typo. It worked in 4.2.2. The bug exists in 4.2.3 and in 4.2.4 RC1.
Comment 3 Samuel 2014-04-23 20:15:08 UTC
(In reply to comment #2)
> Sorry. I made a typo. It worked in 4.2.2. The bug exists in 4.2.3 and in
> 4.2.4 RC1.

Maybe this is the underlying cause for this issue?

https://bugs.freedesktop.org/show_bug.cgi?id=41760
http://cgit.freedesktop.org/libreoffice/core/commit/?id=07f0566026db8f5ec048297785f82a43e73a14f6&h=libreoffice-4-2
Comment 4 Samuel 2014-04-23 20:34:12 UTC
Created attachment 97833 [details]
Screenshot Error
Comment 5 Barto 2014-04-24 06:10:50 UTC
I confirm the bug,

but the bug occurs also on a USB printer ( a cups printer, Canon lasershot LBP 3000 ), no need to print over a tcp connection, the bug will occur with a direct connection ( USB ) to a printer,

I use archlinux 64 bits, libreoffice 4.2.3,

the first attempt I get an error message "Could no start printer,please check your printer configuration", but the document is still printed despite the error message,

th second attempt: no error message,

so this error message happens on a first attempt of printing in libreoffice,

it's probably easy to correct this bug
Comment 6 mal 2014-04-24 08:38:53 UTC
On openSUSE 13.1 with 4.2.3 from Factory
The first print is OK, after that it's about
every other print job gives the error.

This is openSUSE with CUPS 1.7.1 not the 'out
of the box' version

M
Comment 7 Nicola Tiana 2014-04-24 09:01:56 UTC
I can confirm this on Xubuntu 12.04 (both 32 and 64 bit) with LO 4.2.3.3 with two Ricoh networked printer configured on CUPS as lpd://ipaddr/PASSTHRU.
Documents, despite error are printed.

Nicola
Comment 8 Ryan Tandy 2014-04-24 16:55:23 UTC
(In reply to comment #5)
> but the bug occurs also on a USB printer ( a cups printer, Canon lasershot
> LBP 3000 ), no need to print over a tcp connection, the bug will occur with
> a direct connection ( USB ) to a printer,

By "TCP connection" I meant that the client (libcups) is talking to cupsd over TCP (probably on port 631) and not over a Unix socket (/var/run/cups/cups.sock or similar). I have not seen this happen when the Unix socket is used, but maybe someone else has. The connection from cupsd to the printer doesn't matter.

(In reply to comment #3)
> Maybe this is the underlying cause for this issue?
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=41760
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=07f0566026db8f5ec048297785f82a43e73a14f6&h=libreoffice-4-2

Probably. I am trying to build 4.3 from git to check whether the bug is still there, and then I'll try 4.2 with that change reverted.
Comment 9 rosgnilk 2014-04-28 08:47:05 UTC
can confirm the bug on ubuntu 14.04 with LO 4.2.3.3
Comment 10 Marco Menardi 2014-04-30 19:21:06 UTC
Confirmed with kubuntu 12.04 and libo 4.2.3.3, this badly hurts LTSP installations fat clients since they see printers this way triggering the bug. I hear lot of schools start screaming...
Comment 11 Alkis Georgopoulos 2014-05-01 15:43:58 UTC
I'm gettings this too in Ubuntu 14.04 / LibreOffice 1:4.2.3~rc3-0ubuntu2,
both on USB printers and on network printers,
usually not the first time I print, but from the second time and on.
Comment 12 Marco Menardi 2014-05-01 15:50:59 UTC
I've done some further tests.
I've tried to bibisect, but latest bibisect build is 4.2.0.0alpha1 and of course has not the bug.
I've compiled 4.3 from source (Alpha1), and the bug seems NOT there (I've used autogen.sh --enable-kde4 --without-java hope is not java related).
Hope the fix will be backported in 4.2 soon or the fix reverted
Comment 13 Samuel 2014-05-02 11:45:19 UTC
@ Michael,

i add you to the cc list, maybe this commit ist the underlying cause for this issue in 4.2.
http://cgit.freedesktop.org/libreoffice/core/commit/?id=07f0566026db8f5ec048297785f82a43e73a14f6&h=libreoffice-4-2
Comment 14 Michael Stahl (CIB) 2014-05-02 12:20:02 UTC
this sounds like the sort of problem that would be fixed by 8c0d051a0e719fe51fdc5cab1b01afbf721e5e75

can you please test if it is fixed already in 4.2.4.2 ?
Comment 15 Samuel 2014-05-02 12:27:09 UTC
> can you please test if it is fixed already in 4.2.4.2 ?

Yes as soon a download of 4.2.4.2 is available.

https://wiki.documentfoundation.org/Releases/4.2.4/RC2
Comment 16 Heinz Repp 2014-05-05 07:37:03 UTC
Usually I omit simple "me too" posts, but to confirm this sequence occurring with LibreOffice 1:4.2.3~rc3-0ubuntu2~precise1:

first print is ok, following prints throw this "could not start printer"

System ist Ubuntu 12.04.3 LTS

Printer is a HP G85 connected through USB with cups 1.5.3-0ubuntu8.2 and hplip 3.12.2-1ubuntu3.4
Comment 17 Samuel 2014-05-06 09:55:59 UTC
> can you please test if it is fixed already in 4.2.4.2 ?

Confirm it is fixed in Version: 4.2.4.2 (Build-ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f)
Comment 18 Nicola Tiana 2014-05-08 06:33:34 UTC
Xubuntu 12.04 Lts 32: tested with Version: 4.2.4.2 (RC2). The customer reported that the problem has solved. Going to make further tests on my own.

Nicola
Comment 19 mal 2014-05-08 07:36:02 UTC
Seems OK on openSUSE ( 4.2.4.2 from factory )

M
Comment 20 Michael Stahl (CIB) 2014-05-08 08:53:34 UTC
thanks for feedback, setting to VERIFIED
Comment 21 Jorendc 2014-05-16 20:10:05 UTC
*** Bug 78446 has been marked as a duplicate of this bug. ***
Comment 22 Jorendc 2014-05-16 20:12:42 UTC
*** Bug 78285 has been marked as a duplicate of this bug. ***
Comment 23 Ed Emmons 2014-05-17 19:20:08 UTC
The 4.2.4.2 (RC?) update/upgrade from the launchpad.net/libreoffice (testing?) PPA did not fix the inability to print on my Ubuntu 14.04 LTS system. 

The HP C4210 printer still prints perfectly from the LibreOffice suite on the Windows 8.1 computer (that the printer is physically connected to) as it does from every other program on either system.

The LibreOffice suite on the Ubuntu system does not bring up an authentication pop-up dialogue after you have clicked on the "Print" icon (as do all of the other applications on the Ubuntu system). Obviously, the Windows host computer requires no such authentication dialogue in order to enable printing.

Of far greater concern to me, after the installation of this PPA, I am now getting a triangular warning notification in the Panel that when clicked upon reads....as follows.

"The update information is outdated. This may be caused by network problems or by a repository that is no longer available. Please update manually by selecting 'Show updates' from the indicator menu, and watching for any failing repositories.
 
Show updates
Show notifications
Preferences"
Comment 24 Parinya Teerakasemsuk 2014-05-19 08:28:20 UTC
I am still experiencing this issue. I'm on Ubuntu 14.04 LTS 64-bit, updated to the latest version. I'm using LibreOffice 4.2.4.2 from LibreOffice 4.2 PPA. I can't print to my local wifi printer with LibreOffice.

My workaround is that, I have to export my documents in LibreOffice as PDF, and print those documents with PDF viewer in Ubuntu.

I'm a little bit wondering that this bug marked as FIXED.
Comment 25 Samuel 2014-05-20 14:28:25 UTC
(In reply to comment #24)
> I am still experiencing this issue. I'm on Ubuntu 14.04 LTS 64-bit, updated
> to the latest version. I'm using LibreOffice 4.2.4.2 from LibreOffice 4.2
> PPA. I can't print to my local wifi printer with LibreOffice.
> 
> My workaround is that, I have to export my documents in LibreOffice as PDF,
> and print those documents with PDF viewer in Ubuntu.

You was always able to print with this bug, there was only a wrong error message.
Not the issue of this bug report, create a new one.
Comment 26 Parinya Teerakasemsuk 2014-05-20 14:31:44 UTC
(In reply to comment #25)
> (In reply to comment #24)
> > I am still experiencing this issue. I'm on Ubuntu 14.04 LTS 64-bit, updated
> > to the latest version. I'm using LibreOffice 4.2.4.2 from LibreOffice 4.2
> > PPA. I can't print to my local wifi printer with LibreOffice.
> > 
> > My workaround is that, I have to export my documents in LibreOffice as PDF,
> > and print those documents with PDF viewer in Ubuntu.
> 
> You was always able to print with this bug, there was only a wrong error
> message.
> Not the issue of this bug report, create a new one.

I created a new bug report here.

https://bugs.freedesktop.org/show_bug.cgi?id=78964
Comment 27 Carl Revine 2014-06-19 20:19:50 UTC
I am also experiencing this problem as of 6/19/2014, is there a fix?
Comment 28 Carl Revine 2014-06-19 21:21:46 UTC
Why can't Libre Version: 4.2.5.2 Build ID: 420m0(Build:2) print in Ubuntu 14.04lts Intel® Pentium(R) CPU B960 @ 2.20GHz × 2 ? I can print from everything else, I removed and reinstalled Libre upgrade but still same result. Libre reports "Could not start printer.Please check your printer configuration.". I updated everything but I have seen reference to this problem: https://bugs.freedesktop.org/show_bug.cgi?id=77776 but no solution??
Comment 29 Parinya Teerakasemsuk 2014-06-20 02:57:25 UTC
If you want to print in LibreOffice, you will have to choose Postscript instead of PDF in the priter setting menu inside LibreOffice. At least, that's how I managed to print via my local wifi printer.