Bug 41760 - adding new cups printer requires restart
Summary: adding new cups printer requires restart
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0 target:4.2.3
Keywords:
: 44452 50027 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-13 13:25 UTC by Oleg
Modified: 2014-04-23 21:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg 2011-10-13 13:25:24 UTC
1. Start LibreOffice Writer
2. Add new printer in Cups
3. Open the print dialog

EXPECTED:
You can see the newly added printer

OBSERVED:
Printer is not there. You need to colse Writer and open it again for it to notice the printer.

P.S. OpenOffice didn't have this problem, I could even start/stop cups and Writer would update printing dialog correspondingly.
Comment 1 Björn Michaelsen 2011-12-23 12:32:39 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Oleg 2011-12-24 12:23:28 UTC
I've tested this issue on 3.5beta2
It does get reproduced
Comment 3 David Tardon 2012-01-05 03:52:43 UTC
*** Bug 44452 has been marked as a duplicate of this bug. ***
Comment 4 Björn Michaelsen 2012-03-02 05:51:20 UTC
possibly related: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/943881
Comment 5 Björn Michaelsen 2012-03-02 05:53:32 UTC
possibly related:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/892712
Comment 6 Joel Madero 2012-10-30 19:20:11 UTC
*** Bug 50027 has been marked as a duplicate of this bug. ***
Comment 7 Michael Stahl (CIB) 2014-02-18 21:16:38 UTC
should be fixed by:

commit 02efbed152a3a9e364cdb73628af0aed0f5d6f7a
Author:     Caolán McNamara <caolanm@redhat.com>
AuthorDate: Wed Dec 4 16:48:08 2013 +0000

    Resolves: rhbz#1038189 refresh printer list when print dialog launched
Comment 8 Commit Notification 2014-02-18 22:19:32 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=07f0566026db8f5ec048297785f82a43e73a14f6&h=libreoffice-4-2

fdo#41760 rhbz#1038189 refresh printer list when print dialog launched


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 mal 2014-04-22 13:35:49 UTC
Print dialog error message:-

If I use the LO print dialogs every other time
I print I get a message

Could not start printer
Please check your printer configuration

It still prints, is this related to this bugs fix

If I use the system dialogs I don't get the message

This is openSuse 13.1, LO 4.2.3 from factory and KDE 4.12.4
Comment 10 retired 2014-04-22 16:59:56 UTC
mal, please create a new bug. this is years old and has been fixed. if you think what you are seeing is related, add this bug here to the "see also:" section.
Comment 11 mal 2014-04-22 17:32:41 UTC
The bug is really old but the fix is only 2 months old and the fixer said test and give feedback?

Regards

Mal
Comment 12 mal 2014-04-23 21:32:31 UTC
Someone has reported this already as a regression 
Added to 'See Also'