Download it now!
Bug 77899 - Can't launch Fax, Agenda or Letter wizard
Summary: Can't launch Fax, Agenda or Letter wizard
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.4.1 rc
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.5
Keywords: regression
: 77748 78800 79076 79089 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-04-24 16:24 UTC by vulcain
Modified: 2014-06-02 20:26 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2014-04-24 16:24:30 UTC
On Ubuntu 12.04.4 x86_64 with LibreOffice  4.2.4.1 [Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515]

We could not launch Wizard for Agenda, Fax or Letter, it work well for presentation's wizard

Step:
1) Launch LibreOffice
2) File > Wizards > Letter (or Fax or Agenda)
3) Nothing 

Expected: Launch Wizard like with LibreOffice 4.2.3 


If launch in terminal, i have :
" 
 $ /opt/libreoffice4.2/program/soffice
Traceback (most recent call last):
  File "/opt/libreoffice4.2/program/wizards/agenda/AgendaWizardDialogImpl.py", line 86, in startWizard
    self.initializePaths()
  File "/opt/libreoffice4.2/program/wizards/ui/WizardDialog.py", line 118, in initializePaths
    xPropertySet.getPropertyValue("Template_user")[0]
IndexError: tuple index out of range
Traceback (most recent call last):
  File "/opt/libreoffice4.2/program/wizards/letter/LetterWizardDialogImpl.py", line 105, in startWizard
    self.initializePaths()
  File "/opt/libreoffice4.2/program/wizards/ui/WizardDialog.py", line 118, in initializePaths
    xPropertySet.getPropertyValue("Template_user")[0]
IndexError: tuple index out of range
Traceback (most recent call last):
  File "/opt/libreoffice4.2/program/wizards/fax/FaxWizardDialogImpl.py", line 100, in startWizard
    self.initializePaths()
  File "/opt/libreoffice4.2/program/wizards/ui/WizardDialog.py", line 118, in initializePaths
    xPropertySet.getPropertyValue("Template_user")[0]
IndexError: tuple index out of range
Comment 1 Joel Madero 2014-04-24 16:33:36 UTC
Please don't add your own bugs to the MAB list - this wasn't done correctly so I am removing
Comment 2 Cor Nouws 2014-04-24 18:53:20 UTC
Hi vulcain,

thanks for the report. I can confirm the behaviour.

Is OK in 423rc3 > regression.

I think this applies for MAB ?
Comment 3 Joel Madero 2014-04-24 18:56:10 UTC
Yes now that it's been independently confirmed I think MAB is fine - please feel free to add it but make sure to comment on the MAB to say what this issue is
Comment 4 Cor Nouws 2014-04-24 19:07:38 UTC
@joel: OK, thanks.

@vulcain: when I start with the userprofile from an older version, the wizards do work... Can you pls check that?
Comment 5 vulcain 2014-04-24 19:37:13 UTC
(In reply to comment #4)
> @vulcain: when I start with the userprofile from an older version, the
> wizards do work... Can you pls check that?

@Cor Nouws: I found an old userprofile which i delet 7 April 2014 (i don't remenber the version's number). But i can't launch wizards with it.
Comment 6 pierre-yves samyn 2014-04-25 08:53:31 UTC
Hello

I reproduce on windows 7/64 & Version: 4.2.4.1
Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515

File > Wizards > Letter (or Fax or Agenda) do not start
(tested with old and new profile)

I change the platform form Linux to All

Regards
Pierre-Yves
Comment 7 Julien Nabet 2014-04-26 06:29:27 UTC
On pc Debian x86-64 with master sources updated today, I can't reproduce this thanks to these 2 commits:
- http://cgit.freedesktop.org/libreoffice/core/commit/?id=97822e3cbc63d3bd110bc3c654b3fbb4d4d1904c
- http://cgit.freedesktop.org/libreoffice/core/commit/?id=5fa18dc21644f2a719bf39ec948a586fa8837b6a

Caolán/Stephan: I cherry-picked these on 4.2 sources + resolved a conflict but don't know how to merge all this properly.
Any idea?
Comment 8 Jean-Baptiste Faure 2014-04-26 09:27:49 UTC
I do not reproduce the problem with my own build of LibreOffice 4.2.5.0.0+ under Ubuntu 14.04 x86-64. Each wizard, even Euro converter, starts as expected.

Best regards. JBF
Comment 9 Julien Nabet 2014-04-26 09:38:37 UTC
Joren: hopefully there are people like you to double check the mistakes made by people like me! :-)
Indeed:
http://cgit.freedesktop.org/libreoffice/core/log/?h=libreoffice-4-2&qt=range&q=%0997822e3cbc63d3bd110bc3c654b3fbb4d4d1904c
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-2&id=5fa18dc21644f2a719bf39ec948a586fa8837b6a

Sorry for the noise! I'll try to check on the 4.2 branch next time.
Comment 10 ribotb 2014-04-26 12:42:33 UTC
Hi,

I don't reproduce under Windows 7 / x86 with :
Version: 4.2.4.1
Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515 

All assistants start.

I specify that (like in comment#4) I use the profile from an older version (4.1.5).

Bernard
Comment 11 sophie 2014-04-29 15:44:42 UTC
*** Bug 77748 has been marked as a duplicate of this bug. ***
Comment 12 Cor Nouws 2014-05-04 16:27:19 UTC
*** Bug 78256 has been marked as a duplicate of this bug. ***
Comment 13 Jean-Baptiste Faure 2014-05-04 19:53:40 UTC
I am sorry but I must reopen this bug report. When I try to launch the Letter wizard in LibreOffice 4.2.5.0.0+ under Ubuntu 14.04, I get the following error messages:
Traceback (most recent call last):
  File "/opt/libreoffice4.2/program/wizards/common/FileAccess.py", line 156, in getFolderTitles
    nameList = xInterface.getFolderContents(FolderName, False)
wizards.common.FileAccess.com.sun.star.ucb.InteractiveAugmentedIOException: an error occurred during opening a directory
Traceback (most recent call last):
  File "/opt/libreoffice4.2/program/wizards/common/FileAccess.py", line 156, in getFolderTitles
    nameList = xInterface.getFolderContents(FolderName, False)
wizards.common.FileAccess.com.sun.star.ucb.InteractiveAugmentedIOException: an error occurred during opening a directory
Traceback (most recent call last):
  File "/opt/libreoffice4.2/program/wizards/common/FileAccess.py", line 156, in getFolderTitles
    nameList = xInterface.getFolderContents(FolderName, False)
wizards.common.FileAccess.com.sun.star.ucb.InteractiveAugmentedIOException: an error occurred during opening a directory
Traceback (most recent call last):
  File "/opt/libreoffice4.2/program/wizards/letter/LetterWizardDialogImpl.py", line 114, in startWizard
    self.initializeTemplates(xMSF)
  File "/opt/libreoffice4.2/program/wizards/letter/LetterWizardDialogImpl.py", line 787, in initializeTemplates
    tuple(self.BusinessFiles[0])
IndexError: list index out of range

Same error for Fax and Agenda wizards. This problem does not affect the master.

Best regards. JBF
Comment 14 Julien Nabet 2014-05-04 20:09:00 UTC
On pc Debian x86-64 with 4.2 sources updated 1 week ago (1cd3e2038010cb37bda82d38dd058b793b7eec26), I can reproduce this indeed.
Comment 15 Jean-Baptiste Faure 2014-05-04 20:18:31 UTC
There is something strange with this bug: between my comments #8 and #13 I reinitialized my user LO profile. Now, if I restore my old user profile, I can launch the wizards Letter, Fax and Agenda.

Best regards. JBF
Comment 16 Julien Nabet 2014-05-04 20:25:34 UTC
It seems my comment 9 was wrong, gitk wizards/com/sun/star/wizards/ui/WizardDialog.py on local 4.2 LO repo doesn't show the commits quoted.
So https://bugs.freedesktop.org/show_bug.cgi?id=77899#c7 is still relevant.
Comment 17 vulcain 2014-05-06 07:22:58 UTC
Bug still here with a new profil with LibreOffice 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

In termianl, we can read:

~$ /opt/libreoffice4.2/program/soffice
Traceback (most recent call last):
  File "/opt/libreoffice4.2/program/wizards/letter/LetterWizardDialogImpl.py", line 105, in startWizard
    self.initializePaths()
  File "/opt/libreoffice4.2/program/wizards/ui/WizardDialog.py", line 118, in initializePaths
    xPropertySet.getPropertyValue("Template_user")[0]
IndexError: tuple index out of range
Comment 18 Caolán McNamara 2014-05-07 12:29:46 UTC
now submitted as https://gerrit.libreoffice.org/#/c/9270/
Comment 19 Commit Notification 2014-05-07 12:48:40 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bf355f47f49eb352985c129544c60c27814f450b&h=libreoffice-4-2

Resolves: fdo#77899 fax etc wizards don't start


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Lantyukhov Sergey Yevgen'yevich 2014-05-07 18:11:14 UTC
(In reply to comment #0)
This is because in "service \ parameters \ path" were given the wrong path where the desired data.
Comment 21 Jean-Baptiste Faure 2014-05-07 18:53:51 UTC
Verified fixed in LO 4.2.5.0.0+ build on Ubuntu 14.04 x86-64 from sources updated today. Thank you very much.

Best regards. JBF
Comment 22 Julien Nabet 2014-05-18 20:03:41 UTC
*** Bug 78800 has been marked as a duplicate of this bug. ***
Comment 23 Linda 2014-05-19 21:39:32 UTC
(In reply to comment #21)
> Verified fixed in LO 4.2.5.0.0+ build on Ubuntu 14.04 x86-64 from sources
> updated today. Thank you very much.
> 
> Best regards. JBF

Greetings,
I am a not-tech-savvy user.  As you know, the Wizards (writer, fax, agenda) were not working on 4.2.4, which I downloaded yesterday because they were not working on 4.1 that I previously had.
I have used the fax wizard in the past, so I know these work somewhere.
I am unable to discern from the comments how to get my Wizards working again.  Thank you so much.
Linda
Comment 24 Joel Madero 2014-05-19 21:42:07 UTC
When 4.2.5 is released you will see the fix. We verified on a pre-release daily that is not suitable for daily use
Comment 25 Julien Nabet 2014-05-22 18:09:55 UTC
*** Bug 79076 has been marked as a duplicate of this bug. ***
Comment 26 Julien Nabet 2014-05-22 22:21:08 UTC
*** Bug 79089 has been marked as a duplicate of this bug. ***
Comment 27 vulcain 2014-06-02 20:26:53 UTC
I confirm that this bug is fixed on 4.2.5.1 Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de on Ubuntu 12.04 x86_64

Thanks for your job