Download it now!
Bug 78789 - Other: can not edit date field in form with windows date format chinese (simplified, VR china)
Summary: Other: can not edit date field in form with windows date format chinese (simp...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.4.0
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2014-05-16 17:05 UTC by juergen.wurzer
Modified: 2014-12-03 09:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
a simple database to test my problem (11.18 KB, application/vnd.sun.xml.base)
2014-05-16 17:05 UTC, juergen.wurzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description juergen.wurzer 2014-05-16 17:05:16 UTC
Created attachment 99165 [details]
a simple database to test my problem

Problem description: 
I use Win 7 and Libreoffice 4.1.5.3 (in 4.2.x.x it is the same error). I build a form with a date field and it works. But if i change in Windows 7 the format of the date to chinese (simplified, VR China) and open it again i can not enter the correct date in my field.
Here is a link for german developers http://www.libreoffice-forum.de/viewtopic.php?f=10&t=13127

Steps to reproduce:
1. Start the Database open the form "user" and add some data. All should work.
2. close Libreoffice
3. Go to your windows system configuration. Choose the "region(/area) and language". then choose tab "format". Now you change the format language to "chinese (simplified, VR China)" (in the german Win 7 Version it is the last one of chinese languages). Only the format of the date will be changed and not the language of the system!!
4. Now Start the Database again and try to add users or change the date of existing users. It does not work! It shows the wrong date. 


Current behavior:

not able to edit date

Expected behavior:

edit date with the standard date fieldtype
              
Operating System: Windows 7
Version: 4.1.5.3 release
Comment 1 Buovjaga 2014-11-13 10:12:18 UTC
I have no problems changing the date or adding new users with the Windows simplified Chinese format.

Please test with 4.3.x. Change to UNCONFIRMED, if the problem still exists for you.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-12_00:19:18
Comment 2 juergen.wurzer 2014-12-01 11:46:32 UTC
I tested the datefile with Libreoffice Version: 4.3.4.1. 
The Problem is still there. Have you changed the Date in the table or in the Form? You have to change it in the form.
If i Change or add a date it does not have the correct value. It is only an old date or the actual date.

Maybe you choose an false date format in Windows 

Version: 4.3.4.1
Build-ID: bc356b2f991740509f321d70e4512a6a54c5f243
win 7 home Premium 64Bit
Comment 3 juergen.wurzer 2014-12-01 11:52:44 UTC
Now i installed 4.4.0.0 beta1 and it works. 
I will try to find something in the releasenotes why it works in this beta version.
Comment 4 Kevin Suo 2014-12-03 09:05:03 UTC
(In reply to juergen.wurzer from comment #3)
If it works in other locales, but don't work in Simplifed Chinese before version 4.4.0 beta1, then it must be related to my improvements to zh-CN locale data as discussed in bug 84087 and bug 85954.

In the fix of bug 84087, I changed the default date separater from "/" to "/". I see in your database form that in version before 4.4.0 it shows "14/01/12" and does not work if you change the date; while in version 4.4.0 it shows "14/01/12" and works if you change the date.

To reproduce the bug behaviour, you don't have to change your system locale settings. All you need to do is to change the locale settings in "Tools - Options - Language Settings - Languages - Locales" to "Simplified Chinese" in version before 4.4.0.

I don't know why the date saparater "/" and "/" issue matters here, but it fixes this.
Comment 5 Kevin Suo 2014-12-03 09:06:56 UTC
(In reply to Kevin Suo from comment #4)
By saying bug 84087, I mean bug 84961.