Bug 79345 - FILEOPEN: DOCX - Loading without illustration index
Summary: FILEOPEN: DOCX - Loading without illustration index
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-TableofContents
  Show dependency treegraph
 
Reported: 2014-05-28 05:22 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-07 09:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-28 05:22:06 UTC
This is the second part of bug 79292. With attachment 86189 [details], if you open it in LibO 4.2.4 and save it as a docx, and then reopen the saved docx in 4.2.4, the index table on page 3 is missing. Opening the saved 4.2.4 docx in 4.3 beta or word 2013 shows the table, so thats why this is a fileopen issue.

attachment 99927 [details] shows how it looks in 4.2 and 4.3 beta.
Comment 1 Kevin Suo 2014-05-29 10:26:36 UTC
I can reproduce this with 4.2.5.1, windows XP SP3.
But I can not reproduce this with 4.3.0 beta 1 (as the bug reporter has already stated)

Steps to reproduce:
1. Open attachment 86189 [details] with LibreOffice;
2. Save as DOCX;
3. Reopen the resaved DOCX.

Current behaviour:
TOC contents on page 3 is missing.

When right-click in the TOC and select "Edit Index/Table", I notice the following:
Create From: Captions: Category -> Illustration.
When change it to "Figure", the TOC content is shown, despite the fact  that "Figure 1 This is a women falling down" should be "Figure 2 ...".

Set to NEW.
Comment 2 Jorendc 2015-05-16 17:58:01 UTC
It looks like it is okay from 4.3+, I retested it using Version: 5.0.0.0.alpha1+
Build ID: de1977fe7df350b3354f67ab64bf81d3c1e95b22
Locale: nl-BE (nl_BE.UTF-8) and it is indeed correct -> so lets mark it as RESOLVED WORKSFORME.