Bug 80036 - FILEOPEN: EPS picture doesn't appear in slides
Summary: FILEOPEN: EPS picture doesn't appear in slides
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 124005 (view as bug list)
Depends on:
Blocks: Images-EPS
  Show dependency treegraph
 
Reported: 2014-06-14 21:26 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-03-11 18:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How it looks in edit mode in LibO 4.3 beta 2 and master (141.82 KB, image/jpeg)
2014-06-14 21:26 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-14 21:26:33 UTC
Created attachment 101066 [details]
How it looks in edit mode in LibO 4.3 beta 2 and master

When investigating attachment 87970 [details] for bug 70751 on Windows, i see that the EPS image doesnt show in edit or slideshow modes. It begins by attempting to process the image and then fails. Tested on Windows 7 on 3.3.0, 4.2.4, 4.2.6, 4.3 beta 2 and 4.4 alpha.
Comment 1 tommy27 2014-06-15 06:50:48 UTC
confirmed under Win7x64 using 4.2.4.2
Comment 2 V Stuart Foote 2014-08-15 23:31:39 UTC
@Jay, @Tommy27, *,

See bug 62051 c#8--this is a Windows only issue for handling EPS. Setting as such.

For Windows to render EPS you need several helper programs established on system PATH.  Ghostscript (gswin32c.exe), pstoedit (pstoedit.exe) and alternatively ImageMagick (convert.exe)

Without those present as 32-bit helpers, LibreOffice on Windows will not process EPS as vector or bitmap previews and you will get the box with meta data shown. 

This will need to be solved with LibreOffice native EPS handling as in the bug 67464 enhancement.  Until then, the helpers are needed--or perform external conversion to EMF/WMF for placement of vector images.
Comment 3 V Stuart Foote 2014-09-16 18:47:33 UTC
Setting resolved not a bug.  Windows users need to install the appropriate helper programs.

ghostscript (v9.14)
http://downloads.ghostscript.com/public/

pstoedit (v3.62)
http://sourceforge.net/projects/pstoedit/

Imagemagick (v6.8.9-7)
http://www.imagemagick.org/download/
Comment 4 V Stuart Foote 2019-03-11 18:30:39 UTC
*** Bug 124005 has been marked as a duplicate of this bug. ***