Download it now!
Bug 80291 - VIEWING: Black elements not visible in embedded SVG
Summary: VIEWING: Black elements not visible in embedded SVG
Status: RESOLVED DUPLICATE of bug 78554
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-06-20 14:36 UTC by M. Schmitt
Modified: 2015-12-17 08:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document with image not displayed correctly (72.42 KB, application/vnd.oasis.opendocument.text)
2014-06-20 14:36 UTC, M. Schmitt
Details
LibO 4.2.3 VS 4.2.5 (83.34 KB, image/png)
2014-06-21 04:36 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M. Schmitt 2014-06-20 14:36:36 UTC
Created attachment 101436 [details]
Example document with image not displayed correctly

I have an SVG based image in my document, which does display correctly in LibreOffice 4.2.3 and does not work starting from Version 4.2.4.
If I export the image from the ODT document in SVG format and open it in Firefox, I can see the image correctly. The data seems to be ok. It is just not displayed correctly.
Open the attached document in LibreOffice 4.2.3 and LibreOffice 4.2.5 and you will see what I am talking about.
Operating System: Mac OS X
Version: 4.2.4.2 release
Last worked in: 4.2.3.3 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-21 04:04:24 UTC
Confirmed that it works fine on Linux in 4.2.3 and not in 4.2.4. Basically, all black text is not being rendered in the SVG.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-21 04:36:33 UTC
Created attachment 101465 [details]
LibO 4.2.3 VS 4.2.5

Confirmed it also effects 4.2.5, 4.3 beta 2 and 4.4 alpha.
Comment 3 Joel Madero 2014-06-21 16:53:28 UTC
0acca754077bf74469c3e1a3c7eabbc3da795266 is the first bad commit
commit 0acca754077bf74469c3e1a3c7eabbc3da795266
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon May 12 12:04:53 2014 +0000

    source-hash-5e651d4084df7662b56ea980934c0428ba31b062
    
    commit 5e651d4084df7662b56ea980934c0428ba31b062
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Tue Apr 15 21:08:13 2014 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Wed Apr 16 11:23:13 2014 +0100
    
        coverity#1202948 Uninitialized pointer field
    
        Change-Id: I2764b1f9c3d50cf7ff7bd2c552a3dec93509b245

:100644 100644 42123dfbed90154f94f2f1dc8eacf21ed9bf155e 0d2db29f9ae8626eca4aa470157737cc2fffcde0 M	autogen.log
:100644 100644 0c1402c4f181927b2de7b580b596a19c454ff44b 76dfad2a19c6025ab1ff32510e73930f97ae063f M	ccache.log
:100644 100644 3c2e4c5380217c309eb8ca87b2e009760a2e4e9c c60fabab11f976674ac5611f37cba9ef49405589 M	commitmsg
:100644 100644 3b4121c32f82a582e7375c90656c26d59b1d9e61 645384f6ca01eb832351e51b21a3e68e798177f0 M	make.log
:040000 040000 e411e8188872ccf6a50816da7de0ce184071ca16 c66ac4ae3cd31ba3fa723f1ef8376310723747ec M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# good: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect good a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [e80660c5a1d812cd04586dae1f22767fc3778c4a] source-hash-07c60c8ee2d1465544a6a39e57bc06b3690b8dfb
git bisect skip e80660c5a1d812cd04586dae1f22767fc3778c4a
# good: [df9bcaed2faa2a8d11b19f877cdff3a12a887278] source-hash-6ba9692d8bbe3e3c245aca9a7c928e81178d05f1
git bisect good df9bcaed2faa2a8d11b19f877cdff3a12a887278
# bad: [741197a13a361480f59eeb3bd1401f984f49f1c0] source-hash-9a61470eb1fa161cba70f2e9c4ea8817dc7f617e
git bisect bad 741197a13a361480f59eeb3bd1401f984f49f1c0
# skip: [60da347518798811f7adbfbf1eb07d59cd9f08bf] source-hash-28fc951233a58fb4d8515ed4380140aaee0afd32
git bisect skip 60da347518798811f7adbfbf1eb07d59cd9f08bf
# bad: [0acca754077bf74469c3e1a3c7eabbc3da795266] source-hash-5e651d4084df7662b56ea980934c0428ba31b062
git bisect bad 0acca754077bf74469c3e1a3c7eabbc3da795266
# good: [465e2be02951f9645beb3024506a5212907caf5f] source-hash-674801eb4af21c9ae83c122499f15fa4f4785b0f
git bisect good 465e2be02951f9645beb3024506a5212907caf5f
# first bad commit: [0acca754077bf74469c3e1a3c7eabbc3da795266] source-hash-5e651d4084df7662b56ea980934c0428ba31b062
Comment 4 Yousuf Philips (jay) (retired) 2014-06-21 18:41:26 UTC
(In reply to comment #1)
> Basically, all black text is not being rendered in the SVG.

To be more acturate, its not only black text, but also the black man figure in the logo. I see the same black text disappearing can be found in attachment 101498 [details], though it didnt effect the black curved squares.
Comment 5 Yousuf Philips (jay) (retired) 2014-06-22 16:07:39 UTC

*** This bug has been marked as a duplicate of bug 78554 ***
Comment 6 Robinson Tryon (qubit) 2015-12-17 08:24:10 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]