Download it now!
Bug 80882 - Calc: Hit F1 on "Data - Validity - Criteria" dialog goes to online help page which has no content
Summary: Calc: Hit F1 on "Data - Validity - Criteria" dialog goes to online help page ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.2 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-04 02:02 UTC by Kevin Suo
Modified: 2014-10-29 09:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-07-04 02:02:10 UTC
In calc, "Data - Validity - Criteria" dialog, when you hit F1 to open the online help, it goes to the page:
https://help.libreoffice.org/scalc/modules/scalc/ui/validationcriteriapage/allow?Language=zh-CN&System=WIN&Version=4.3

That help page has no content.

In fact, we do have help content for "Data - Validity - Criteria" here:
https://help.libreoffice.org/Calc/Criteria

Windows XP SP3
LibreOffice 4.3.0.2.
Comment 1 Yousuf Philips (jay) (retired) 2014-07-04 02:06:43 UTC
Confirmed on Linux Mint with 4.3.
Comment 2 Kevin Suo 2014-07-04 02:13:09 UTC
Just for info, this does not affect offline-help.
When offline-help is installed, it opens the correct dialog.
Comment 3 Stanislav Horacek 2014-07-04 14:16:53 UTC
That's probably because the online help has not been updated for 4.3 yet. (And the Criteria dialog was converted to .ui, so the link to the help page has changed.)
I think this bug can be closed (maybe as invalid).
Comment 4 Kevin Suo 2014-07-04 14:34:27 UTC
(In reply to comment #3)
> I think this bug can be closed (maybe as invalid).
Thanks. I am fine to close it as invalid.
There are many other help pages which do not exist. And there are other similar bug reports. I will try to close them to.
Comment 5 Kevin Suo 2014-08-04 19:07:24 UTC
Still no content. NEW.
Comment 6 Stanislav Horacek 2014-08-04 19:22:09 UTC
Yes, still no update of wikihelp.
Maybe it would be worth to report out-of-date wikihelp as a general bug, since final 4.3 is now released?
Comment 7 Stanislav Horacek 2014-10-29 09:38:32 UTC
Online wikihelp is up-to-date now and the criteria page shows correctly when pressing F1 in the Criteria dialog (checked in 4.3.3.1 and the latest master).
Closing as worksforme - feel free to reopen it if you still see this issue.