Bug 76488 - UI: Missing Online Helps
Summary: UI: Missing Online Helps
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.0.2
Keywords:
: 84297 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-22 19:10 UTC by A (Andy)
Modified: 2017-09-11 08:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2014-03-22 19:10:41 UTC
US English User Interface in LO 4.2.2.1, Win 8.1:

Issue 1:
Go to INSERT -> BOOKMARK
Observation: No help button

Issue 2:
Go to INSERT -> INDEXES AND TABLES -> INDEXES AND TABLES
Observation: Help button leads to an empty page

Issue 3:
Go to INSERT -> OBJECT -> OLE OBJECT
Observation: Help button leads to an empty page

Issue 4:
Go to INSERT -> OBJECT -> PLUG IN
Observation: Help button leads to an empty page

Issue 5:
Go to INSERT -> FLOATING FRAME
Observation: Help button leads to an empty page

Issue 6:
Go to FORMAT -> PAGE -> tab FOOTNOTE
Observation: Help button leads to an empty page

Issue 7:
Go to FORMAT -> PARAGRAPH -> tab OUTLINE & NUMBERING
Observation: Help button leads to an empty page

Issue 8:
Go to FORMAT -> TITLE PAGE
Observation: Help button leads to an empty page

Issue 9:
Go to FORMAT -> STYLES AND FORMATTING
Observation: No help button

Issue 10:
Go to FORMAT -> AUTOCORRECT -> AUTOCORRECT OPTIONS
Observation: Help button leads to an empty page

Issue 11:
Go to TABLE -> INSERT -> ROWS
Observation: Help button leads to an empty page

Issue 12:
Go to TABLE -> INSERT -> COLUMNS
Observation: Help button leads to an empty page

Issue 13:
Go to TABLE -> SPLIT TABLE
Observation: Help button leads to an empty page

Issue 14:
Go to TABLE -> NUMBER FORMAT
Observation: Help button leads to an empty page

Issue 15:
Go to TABLE -> TABLE PROPERTIES
Observation: Help button leads to an empty page

Issue 16:
Go to TOOLS -> SPELLING AND GRAMMAR
Observation: Help button leads to an empty page

Issue 17:
Go to TOOLS -> GALLERY
Observation: No help button

Issue 18:
Go to TOOLS -> MAIL MERGE WIZARD
Observation: Help button leads to an empty page

Issue 19:
Go to TOOLS -> MACROS -> ORGANIZE DIALOGS -> any tab
Observation: No help buttons

Issue 20:
Go to TOOLS -> MACROS -> ORGANIZE MACROS -> BEANSHELL
Observation: Help button leads to an empty page

Issue 21:
Go to TOOLS -> MACROS -> ORGANIZE MACROS -> PYTHON
Observation: Help button leads to an empty page

Issue 22:
Go to TOOLS -> EXTENSION MANAGER
Observation: Help button leads to an empty page

Issue 23:
Go to FILE -> PRINTER SETTINGS
Observation: Help button leads to an empty page

Issue 24:
Go to FILE -> PROPERTIES -> any tab
Observation: Help buttons lead to an empty page

Issue 25:
Go to FILE -> TEMPLATES -> MANAGE -> any tab
Observation: No help buttons
Comment 1 sophie 2014-04-03 15:38:29 UTC
Thanks a lot Andy for your work on this, set as New - Sophie
Comment 2 Kevin Suo 2014-07-04 15:09:39 UTC
Andy:

For almost all the "leads to an empty page" part, it now works for 4.3.0.2 (and may work for other versions as well).
The reason maybe that wiki help website was not updated in time. See Stanislav Horacek's comment in bug 80882.

For the "no help button" part, it still exists in 4.3.0.2.

Thanks!
Comment 3 Stanislav Horacek 2014-07-05 09:54:53 UTC
Just to be precise, in March 2014 the wiki help probably was up-to-date for 4.2. However, there were another help fixes between 4.2 and 4.3 which could solve these problems.
Comment 4 A (Andy) 2014-09-27 21:52:30 UTC
*** Bug 84297 has been marked as a duplicate of this bug. ***
Comment 5 A (Andy) 2014-09-27 22:04:48 UTC
by 27 September 2014 the following cases had been resolved:
Issues: 10, 13, 15, tab DESCRIPTION in 24

The others are still prevailing.
Comment 6 A (Andy) 2014-09-27 22:14:09 UTC
Addition to Comment 5: 
The used version is LO 4.3.2.2 (Win 8.1).
Comment 7 QA Administrators 2015-12-20 16:19:29 UTC Comment hidden (obsolete)
Comment 8 A (Andy) 2015-12-26 22:06:55 UTC
Partly still reproducible with LO 5.1.0.1, Win 8.1

Current status of still missing helps:

Issue 1:
Go to INSERT -> BOOKMARK
Observation: No help button

Issue 6:
Go to FORMAT -> PAGE -> tab FOOTNOTE
Observation: Help button leads to an empty page

Issue 7:
Go to FORMAT -> PARAGRAPH -> tab OUTLINE & NUMBERING
Observation: Help button leads to an empty page

Issue 8:
Go to FORMAT -> TITLE PAGE
Observation: Help button leads to an empty page

Issue 18:
Go to TOOLS -> MAIL MERGE WIZARD
Observation: Help button leads to an empty page

Issue 20:
Go to TOOLS -> MACROS -> ORGANIZE MACROS -> BEANSHELL
Observation: Help button leads to an empty page

Issue 21:
Go to TOOLS -> MACROS -> ORGANIZE MACROS -> PYTHON
Observation: Help button leads to an empty page

Issue 23:
Go to FILE -> PRINTER SETTINGS
Observation: Help button leads to an empty page

Issue 24:
Go to FILE -> PROPERTIES -> tabs CMIS PROPERTIES and FONT 
Observation: Help buttons lead to an empty page

Issue 25:
Go to FILE -> TEMPLATES -> MANAGE -> any tab
Observation: No help buttons
Comment 9 Commit Notification 2016-12-11 17:28:05 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=0b50898fdae10df8a54b60bbb77e68031e63cfb3

tdf#76488 Fix HIDs for Properties - Font tab
Comment 10 Commit Notification 2016-12-11 17:37:30 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=992226ad77e2790074d1f718523dc55d4201c045

tdf#76488 (partial) Reconnect Printer Setup window and help
Comment 11 Gabor Kelemen 2016-12-14 23:13:50 UTC
A quick review of what's still relevant: 

Issue 1:
Go to INSERT -> BOOKMARK
- fixed in bug #90855

Issue 6:
Go to FORMAT -> PAGE -> tab FOOTNOTE
- just submitted a patch for this

Issue 7:
Go to FORMAT -> PARAGRAPH -> tab OUTLINE & NUMBERING
- this was just fixed in bug #93299

Issue 8:
Go to FORMAT -> TITLE PAGE
- fixed in bug #80590

Issue 18:
Go to TOOLS -> MAIL MERGE WIZARD
Observation: Help button leads to an empty page
- still valid, should be fixed in bug #102930 (and bug #52986 is also about this)

Issue 20:
Go to TOOLS -> MACROS -> ORGANIZE MACROS -> BEANSHELL
Observation: Help button leads to an empty page
- still valid 

Issue 21:
Go to TOOLS -> MACROS -> ORGANIZE MACROS -> PYTHON
Observation: Help button leads to an empty page
- still valid, also for JavaScript too.

Issue 23:
Go to FILE -> PRINTER SETTINGS
Observation: Help button leads to an empty page
- should be fixed now.

Issue 24:
Go to FILE -> PROPERTIES -> tabs CMIS PROPERTIES and FONT 
Observation: Help buttons lead to an empty page
- the Font page should be fixed now, CMIS properties still valid

Issue 25:
Go to FILE -> TEMPLATES -> MANAGE -> any tab
Observation: No help buttons
- There is now a Help button since the redesign this year, but still no fresh content yet. bug #94454 is tracking that.
Comment 12 Commit Notification 2016-12-15 13:54:53 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=7d62908799da6b9ec1f4c2749fbbef9d7093effd

tdf#76488 (partial) Update footnote properties page
Comment 13 Commit Notification 2016-12-23 08:50:24 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=f71f2e44e8dbd9b026755152568e7c0f32f47fe9

tdf#76488 (partial) Reconnect the script organizer dialog and UI
Comment 14 Commit Notification 2016-12-24 23:31:02 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=76de84f0a256db661f3a10d6a77644189f456aeb&h=libreoffice-5-3

tdf#76488 Fix HIDs for Properties - Font tab
Comment 15 Commit Notification 2016-12-24 23:31:07 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=af6e22a489989a42c83a37b333d57540bf366cdf&h=libreoffice-5-3

tdf#76488 (partial) Reconnect Printer Setup window and help
Comment 16 Commit Notification 2016-12-24 23:33:00 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=b7da65258ab0875f5db91d3dd0fecf11ccf3fd42&h=libreoffice-5-3

tdf#76488 (partial) Update footnote properties page
Comment 17 Xisco Faulí 2017-03-01 11:08:01 UTC
Hello Gabor,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 18 Xisco Faulí 2017-09-11 08:45:27 UTC
Dear developer,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.