Bug 81759 - Mac OS X dictation doesn't work anymore in LibO [Bisected: 179334dd4, see Comment#32]
Summary: Mac OS X dictation doesn't work anymore in LibO [Bisected: 179334dd4, see Com...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.3 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, bibisected, bisected, regression
: 93035 96144 (view as bug list)
Depends on:
Blocks: MacOS-Wishlist a11y-macOS 83153
  Show dependency treegraph
 
Reported: 2014-07-25 20:01 UTC by detlefscloud
Modified: 2016-05-14 17:43 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
Preferences and Application Support (5.91 MB, application/zip)
2016-05-14 17:08 UTC, Benoît RIVET
Details

Note You need to log in before you can comment on or make changes to this bug.
Description detlefscloud 2014-07-25 20:01:13 UTC
Libreoffice 4.3.0.3 is blocking the launch of Siri of Mac OS 10.9.4.
I can't edit a dictation anymore.
Comment 1 Uwe Altmann 2014-07-26 08:07:07 UTC
Seems the keyboard strokes to start Siri (which is a double "fn" key by default, but others don't work either) is not passed to the OS?
This is new in 4.3 - 4.2.5 works like it should.
Comment 2 Robinson Tryon (qubit) 2014-09-10 21:00:58 UTC
Looks like we have a 4.2 - 4.3 bibisect repo for the Mac:
https://wiki.documentfoundation.org/Bibisect#Versions

Uwe -- Have you tried bibisecting before? I'd be happy to help you set up the repo and get started :-)
Comment 3 Uwe Altmann 2014-09-11 06:30:54 UTC
I'n not a coder so this won't bring us far :-)
Comment 4 retired 2014-09-11 14:57:53 UTC
Hi Uwe and Detlef,

can we please have exact reproduce steps? The bug provides much too little info to make anything useful of it.

There is NO siri on OSX. That thing is called "Dictation". So we should not call it Siri. Siri is on iOS.

Next, testing: From what I see, dictation is not supported in LO. I press the keyboard command I've set in System prefs > Dictation and get the "negative" audio bump notice.

In word I get the "positive" audio bump and can dictate and hit "done"  when finished.

So setting this to ENHANCEMENT.
Comment 5 detlefscloud 2014-09-11 21:55:57 UTC
Hi,
please excuse my english. It is difficult for me to talk sophisticated and exact. And I don't want to offend anybody and I only want announce a bug. 

Bug 81759 talks about speech Editor you can use with MAC OS 10.9.4. I called the speech editor  "Siri", because it is the same speech editor you have in IOS.

On time being, it seems Apple does not opens all the backgrounds of Siri. 

To demonstrate how this speech editor works  please look in "you tube" where David A. Cox "pages 5 full tutorial" from minutes 7:50 to minutes 8:12

In some ways you may be right you can work with this function of OS X 10.9.4 only, if you enables this feature in preferences  / dictation. 

By default (Germany) you have to stroke "fn" twice. After that: a tone is to hear and a microphone shows up on the screen. You get a signal to start the speech editor (dictation) and you can stop the speech editor (dictation) by mouse click on the microphone.

This may be it with the MAC OS  X 10.9.4. in principal, savvy.

No about Libreoffice (LO).  

We work with LO 4.2.6.3 on our Apple devices for the time being, because the speech editor is working fine with LO like David demonstrated it with pages of appleoffice.

The speech editor does not work any more with LO Version since LO 4.3. I hear a tone but the Microphone does not show up on the screen anymore.

I run also the version LO 4.3.1.2 on windows 7 (Microsoft) over VM-ware "parallels" on my MAC. And "Siri" works fine.

It seems the Mac version of LO 4.3 has an regression.

yours sincerily

Detlef



Am 11.09.2014 um 16:58 schrieb bugzilla-daemon@freedesktop.org:

> foss changed bug 81759 
> What	Removed	Added
> CC	  	foss@openmailbox.org            
> 
> You are receiving this mail because:
> You reported the bug.
Comment 6 retired 2014-09-12 06:52:10 UTC
Detlef, thanks a lot for taking the time to properly describe this problem. Your english is perfect. Please only reply online (and not via mail).

So if you say it is working in 4.2, I can confirm it is not working in 4.3.1.2 which I have installed. Never used this with 4.2 so didn't know it did once indeed work.

Nightly from today also does not work with OSX dictation.
Version: 4.4.0.0.alpha0+
Build ID: 4d3c88805d1917932ee88a0f22ae93c43e8e389a
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-09-11_11:22:41

Adding "regression" Keyword and confirming. Now let's wait for someone to bibisect this (OSX instructions seem to be missing?) and then the dev team to fix this.
Comment 7 Alex Thurgood 2014-09-26 11:46:10 UTC
This may be related to the crappy media support we now have in LO on OSX (or not).
Comment 8 Uwe Altmann 2014-09-26 12:17:36 UTC
Not necessary, as reported here it worked well until 4.2.5 and 4.2.6. btw: this bug reporting tool is by no means meant for bashing "the developers" or someone else, so keep calm.

In 4.3.2 at least the double "fn" keypress ist recognized by the OS - but results in a "sad" sound (system error sound). It is the same sound as when you try to start a dictation where no text entry is possible (e. g. Console). So maybe dictation can not recognise writer as a receiver for text typing?
Comment 9 Alex Thurgood 2014-09-26 15:52:17 UTC
(In reply to comment #8)

At least LO doesn't crash, unlike the poor guy using Dragon Dictate on OSX ;-)

My cooment in relation to media support is that we moved from the old deprecated media framework API in 4.2 to the new AVMedia API in 4.3 and perhaps this has had an impact on media input support ?
Comment 10 detlefscloud 2014-10-07 16:36:29 UTC
(in reply to comment 9)

Alex you are running my bug report down. I am not amused over your talk about SIRI. You are forgetting handicapped persons. Even if this handicap lasts only a short time. And I do not wish you broken fingers. In this case you would be happy over a working SIRI. So please go on working to solve that problem.
sincerely Detlef
Comment 11 Alex Thurgood 2014-10-07 17:00:49 UTC
Setting component to LibreOffice, not quite sure why it was set to Basic
Comment 12 Alex Thurgood 2014-10-07 17:08:39 UTC
(In reply to detlefscloud from comment #10)
> (in reply to comment 9)

Detlef,

> 
> Alex you are running my bug report down. I am not amused over your talk
> about SIRI. You are forgetting handicapped persons. Even if this handicap
> lasts only a short time. And I do not wish you broken fingers. In this case
> you would be happy over a working SIRI. So please go on working to solve

I have a professional interest in being able to dictate into LibreOffice, so please don't tell me I'm forgetting others.

My point is : changes occurred during 4.2.x to 4.3 in the code that related both to accessibility and the media framework. Some of these changes could be responsible for VoiceOver no longer working in 4.3, but I don't know whether VoiceOver relies on the newly implemented AVFoundation code that we now use for our media support.
Comment 13 detlefscloud 2014-10-19 21:14:24 UTC
Hi Alex
thank you for your last comment. Now I made new trials and want to give a hint. 

I can start LO Version: 4.3.2.2 on my iMac (now OS X 10.10) over the VM ware Parallels with windows 7. And if I do so  Siri is working. The question is, how is para working. Is the newly implemented AVFoundation code for Mac-Version and Windows-Version the same code? Are there distinctions?
cheers
Detlef
Comment 14 Alex Thurgood 2014-10-20 06:59:17 UTC
(In reply to detlefscloud from comment #13)


> I can start LO Version: 4.3.2.2 on my iMac (now OS X 10.10) over the VM ware
> Parallels with windows 7. And if I do so  Siri is working. The question is,
> how is para working. Is the newly implemented AVFoundation code for
> Mac-Version and Windows-Version the same code? Are there distinctions?



Unfortunately, I have no idea.
Comment 15 Uwe Altmann 2014-11-02 20:44:46 UTC
The new 4.2.7 version also shows ths misbehaviour. So the last LO version with working dictation is 4.2.6.
Maybe this eases the pin down of the code concerned?
Comment 16 Uwe Altmann 2014-12-12 10:41:50 UTC
Just installed 4.2.8 - everything works perfect again! Hope this finds its way into 4.3 also.
Thanks a lot to whoever fixed that :-)
Comment 17 retired 2014-12-12 12:22:48 UTC
dictation functionality is basic and important functionality. raising importance. also very interesting it is working in 4.2.8 and was restored for the 4.2 branch without any specific commit. would be great to move this forward.
Comment 18 retired 2014-12-12 12:49:54 UTC
Correcting Uwe's observation:

4.2.8: working
4.2.7: working as well
Version: 4.2.7.2
Build ID: 933c0aa564ec4f8883ed5732c866db48dca4dac5
Comment 19 Robinson Tryon (qubit) 2014-12-12 13:12:00 UTC
(In reply to Uwe Altmann from comment #15)
> The new 4.2.7 version also shows ths misbehaviour. So the last LO version
> with working dictation is 4.2.6.

(In reply to foss from comment #18)
> Correcting Uwe's observation:
> 
> 4.2.8: working
> [4.2.7.2]: working as well

So I see a couple possibilities here:
1) Uwe is in error and 4.2.7 is working properly
2) 4.2.7 is working on foss' machine, but not on Uwe's
3) Inconsistency of repro steps

Foss: What version of OS X are you using to test?
Comment 20 Alex Thurgood 2014-12-12 13:36:57 UTC
So I have just tried this with LO 4341 on OSX 10.10.1 and dictation in a Writer document works for me.
Comment 21 Alex Thurgood 2014-12-12 13:37:56 UTC
Seems like this bug, if still present, is limited to OSX 10.9
Comment 22 Alex Thurgood 2014-12-12 13:41:58 UTC
@Uwe: please try with LO 4341 and report back. Setting to needinfo until we hear back from OP, otherwise I'll change title to indicate that osx 10.9 only or set to wfm
Comment 23 Alex Thurgood 2014-12-12 13:43:10 UTC
Sorry, I meant Detlef.
Comment 24 retired 2014-12-12 14:22:56 UTC
This is NEW since it is reproducible for me under 10.10.1 with 4.4b2 and 4.5 nightly.

Thus also not 10.9 only.
Comment 25 Uwe Altmann 2014-12-12 16:05:16 UTC
Sorry, I was wrong on 4.2.7 - it's also working well. So it is restricted to 4.3 series only.
I'm using MacOS 10.9.5
Comment 26 Alex Thurgood 2014-12-12 16:36:32 UTC
Confirming on OSX 10.9.5 MBPro 2011

For me, this is only reproducible on OSX 10.9.x
Comment 27 detlefscloud 2014-12-12 17:13:41 UTC
Thank you Alex for your work on bug 81759!

I am using: LO Version: 4.3.4.1
Build-ID: bc356b2f991740509f321d70e4512a6a54c5f243
and

OS X Yosemite Version 10.10.1

I have no success using dictation as so far.

As Uwe lastly reported dictation works with the same OS X 10.1 and LO 4.2 series on the iMac of my wife. Therefor she is still using LO 4.2.7

sincerely Detlef
Comment 28 Robinson Tryon (qubit) 2014-12-12 17:48:39 UTC
Repro Steps:

- Enable Dictation
 (Apple) -> System Preferences -> Dictation & Speech -> Dictation: On

- Use Enhanced Dictation (requires ~800MB download)

- Start LibreOffice Writer and try to start dictation
  (Press 'Fn' key twice (or whatever keystroke you've set up))

RESULT:
- LO 4.2.8.2 works correctly 
- Bug CONFIRMED with LO 4.4.0.0.beta2 -- I only hear the 'ding' prompt

Testing on OSX 10.9.4
Comment 29 Robinson Tryon (qubit) 2014-12-12 18:22:13 UTC
(In reply to detlefscloud from comment #0)
> Libreoffice 4.3.0.3 is blocking the launch of Siri of Mac OS 10.9.4.
> I can't edit a dictation anymore.

Testing on OSX 10.9.4:

- NOREPRO with 4.3.0.0.beta1
- CONFIRMED with 4.3.0.3

There are only 610 commits between the tags for libreoffice-4.3.0.0.beta1..libreoffice-4.3.0.3

Foss: it sounds like you see the same behavior. We can narrow the # of commits down by bisecting using the handful of builds between the two:
http://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 30 Matthew Francis 2014-12-20 14:26:52 UTC
I get working dictation at both ends of the existing OSX bibisect repo, so unfortunately this is not bibisectable

-> Whiteboard:notBibisectable
Comment 31 Matthew Francis 2014-12-20 14:59:25 UTC
From scanning the commits in the above range, I think this one is a strong candidate - NSTextInputClient is directly related to dictation


commit 179334dd45828d02e4e323cbdda435963fa3f4a5
Author: Tor Lillqvist <tml@collabora.com>
Date:   Tue Jun 3 09:04:45 2014 +0300

    Initial attempt at implementing NSTextInputClient instead of NSTextInput
    
    NSTextInput was deprecated in 10.6.
    
    Change-Id: I6bce9e91a68014a6ca28bff6a820c27817f9baaf
Comment 32 Matthew Francis 2014-12-20 15:12:28 UTC
Manually reverting 179334dd45828d02e4e323cbdda435963fa3f4a5 gives working dictation again on current master. Obviously that's not an actual solution because the commit removed the use of a long deprecated API

Adding Cc: to tml@iki.fi
Comment 33 lookmomnohands 2015-02-12 12:55:38 UTC
I can confirm this is still an issue to at least the general public who would probably download from just the main installer link. I also had the issue on 4.3.5.2. My current install is Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Running on OSX 10.10.2 on a MacBook Pro (Retina, 15-inch, Late 2013)
I'd be happy to work through a bibisect if desired, but I've never done that before. Only a hobbyist as far as code goes.
Comment 34 Matthew Francis 2015-02-13 15:21:08 UTC
Adjusting Whiteboard and Keywords to indicate that the commit in question has already been identified (in comment 31)
Comment 35 Uwe Altmann 2015-02-26 13:50:27 UTC
Still not working in LO 4.4.1 in Mac OS 10.10.2 :-(
Comment 36 Robinson Tryon (qubit) 2015-03-26 18:33:33 UTC
(In reply to Matthew Francis from comment #34)
> Adjusting Whiteboard and Keywords to indicate that the commit in question
> has already been identified (in comment 31)

Adding bisected commit to Summary so that QA can see at a glance
Comment 37 Martin Srebotnjak 2015-05-24 17:54:03 UTC
OSX system Dictation still not working on 5.0b1 on OS X 10.10.3 (as well as not on 4.4.3.1 on same system).
Comment 38 MarjaE 2015-07-07 20:51:11 UTC
Last time I tried, it was working fairly well in Writer.  Most of the problems seemed to be with Dictation itself rather than with its interface with LibreOffice.
Comment 39 steve -_- 2015-07-08 08:44:52 UTC
Nope. Still broken.
Version: 5.1.0.0.alpha1+
Build ID: 799cc41b53a59c543408fa5370e107c2c57a2904
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-07-08_05:50:48
Locale: de-DE (de.UTF-8)
OSX 10.10.4

Just hearing the low "ping" to indicate dictation did not start. When doing the same in MS Word, hearing the high ping and dication starts and works as expected.
Comment 40 Martin Srebotnjak 2015-07-30 23:48:54 UTC
*** Bug 93035 has been marked as a duplicate of this bug. ***
Comment 41 Martin Srebotnjak 2015-07-30 23:50:15 UTC
Still not working on LO50RC4 on OSX.

Is this the only possiblity that LO changed? Maybe something within the Apple Dictation system changed and requires change of LO code?
Comment 42 tommy27 2015-07-31 04:09:54 UTC
shortened summary notes. you already have version field and regression keyword to tell which is the earlies version affected
Comment 43 Uwe Altmann 2015-10-13 11:18:22 UTC
Working as expected with LO 5.0.1.2 under OS 10.11 aka El Capitan. Don't ask why :-/
Comment 44 steve -_- 2015-10-13 20:55:58 UTC
Most interesting. Verified this is working with
OSX 10.11
LO Version: 5.1.0.0.alpha1+
Build ID: f99743efece35bf1024a833ad0220a723b33256e
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-10-10_05:30:25
Locale: de-DE (de.UTF-8)
Comment 45 V Stuart Foote 2015-11-29 22:28:14 UTC
*** Bug 96144 has been marked as a duplicate of this bug. ***
Comment 46 V Stuart Foote 2015-11-29 22:39:52 UTC
I know we are have set this Resolved WFM, and Verified it. 

But, could folks please take a moment and recheck use of OS X Dictation (online and enhanced). Where are things with the 5.0.3.2 release and current 5.1.0beta?

Is the NSTextInputClient support solid for folks on 10.10.5 Yosemite and 10.11.1 El Capitan--and what of the 10.9.5 Mavericks users is anyone functional with Dictation?
Comment 47 Greg 2015-11-29 23:28:10 UTC
I sent in a ticket a long with a video showing the use of both, still not working in 5.3
Comment 48 V Stuart Foote 2015-11-30 01:47:33 UTC
(In reply to Greg from comment #47)
> I sent in a ticket a long with a video showing the use of both, still not
> working in 5.3

Yes that was bug 96144, where @Greg reports he is on Mavericks 10.9.4 and no functional Apple Dictation capability with LO 5.0.3.2 --neither on-line nor enhanced local.
Comment 49 Robinson Tryon (qubit) 2015-12-17 08:28:42 UTC
Migrating Whiteboard tags to Keywords: (bibisected, a11y -> accessibility)
[NinjaEdit]
Comment 50 Benoît RIVET 2016-05-05 15:05:10 UTC
Mac OS X Dictation doesn't work for me, either with the latest LibreOffice Stable 5.0.6 or with LibreOffice Evolution 5.1.3 and the latest Mac OS X version 10.11.4 (El Capitan). For what it's worth, my language is set to french, but I tested both LibreOffice before and after applying the langage pack, to no effect.

However, Dictation works like a charm with Apache OpenOffice 4.1.2 (same computer). I did not realize that OpenOffice was still in development : this nasty bug made me reconsider using Apache OpenOffice and dumping LibreOffice.
Comment 51 Tor Lillqvist 2016-05-05 15:20:56 UTC
If you are happy with Apache OpenOffice, good for you! We don't get offended if you use it.
Comment 52 V Stuart Foote 2016-05-05 15:52:27 UTC
(In reply to Benoît RIVET from comment #50)
> However, Dictation works like a charm with Apache OpenOffice 4.1.2 (same
> computer). I did not realize that OpenOffice was still in development : this
> nasty bug made me reconsider using Apache OpenOffice and dumping LibreOffice.

Well we won't debate if it is in development, but Apache OpenOffice is certainly still using the deprecated NSTextInput API that was deprecated at OS X 10.6 That it works there is an Apple issue. Good luck.

This issue though was resolved fixed as working for a large number of folks on OS X 10.11.1 (El Capitan).  No reports of support for OS X 10.9 (Mavericks), and not clear if things were OK for OS X 10.10 (Yosemite) builds.

Sure we could have some new or unresolved issues with implementation of NSTextInputClient done in June 2014--but more likely it is changes in OS X.

If folks that have had it working on OS X 10.11.(1+) start reporting it is now broken that is a new bug and we really need full details.
Comment 53 Uwe Altmann 2016-05-05 17:22:02 UTC
Unsing El Capitan 10.11.4
Just tested dictation for 5.1.2 again - working like expected. 4.4.7 is fine as is 4.3.7. So for me it's resolved since 4.3.2.something.
Comment 54 Buovjaga 2016-05-06 05:51:38 UTC
We still don't know the fixing commit, so WFM :)
Comment 55 steve -_- 2016-05-06 09:54:26 UTC
To avoid confusion: this feature works as expected in 10.11.4 and
Version: 5.2.0.0.alpha1+
Build ID: ee5850893e15acda1d7ce7cf17da7c80f2fa810a
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-05-06_00:59:44
Locale: de-DE (de.UTF-8)
Comment 56 Benoît RIVET 2016-05-14 17:08:38 UTC
Created attachment 125045 [details]
Preferences and Application Support

After trashing these Preferences and Application support files, Dictation started working for me (whereas it did not before...).

zip file of the ~/Library files trashed, recovered with Time Machine.
Comment 57 Benoît RIVET 2016-05-14 17:21:30 UTC
(In reply to Benoît RIVET from comment #56)
> Created attachment 125045 [details]
> Preferences and Application Support
> 
> After trashing these Preferences and Application support files, Dictation
> started working for me (whereas it did not before...).
> 
> zip file of the ~/Library files trashed, recovered with Time Machine.

I forgot to thank you for taking time to work on this nasty bug : I was really pissed off when I discovered that Dictation would not work on my computer (and on another laptop of mine), and I could not understand why you claimed it worked for you. After I reopened the bug, since you answered me that everything was fine for you, I decided I should give it another try... and Dictation finally worked after I trashed the aforementioned files.

Maybe this workaround should be explained somewhere in the LibreOffice FAQ (including how to access ~/Library files...)

Anyway, thank you for wishing me good luck with Apache OpenOffice ;-)
Comment 58 steve -_- 2016-05-14 17:43:18 UTC
Benoit: welcome to add this as known issue to the wiki. that is open for anybody to edit.