Bug 96144 - Apple's Dictate doesn't work in Libre Office 5.3
Summary: Apple's Dictate doesn't work in Libre Office 5.3
Status: RESOLVED DUPLICATE of bug 81759
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-29 20:00 UTC by Greg
Modified: 2015-11-30 01:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg 2015-11-29 20:00:51 UTC
I've been told numerous times that Apple's dictation works with LibreOffice's new version 5.3. Here's a video showing that it is not working for me. 

https://www.dropbox.com/s/v83svmryxawhpd4/Libre%20Office%20Issues.mp4?dl=0
Comment 1 V Stuart Foote 2015-11-29 22:28:14 UTC
From screen cast, OP is on OS X 10.9.4 using LO 5.0.3.2

Setting as duplicate of bug 81759

LibreOffice replaced NSTextInput with NSTextInputClient with
http://cgit.freedesktop.org/libreoffice/core/commit/?id=179334dd45828d02e4e323cbdda435963fa3f4a5

NSTextInput was deprecated at OS X 10.6, and while there is likely more to be done numerous user report the NSTextInputClient based support works for them--except on OS X 10.9 builds.

Unfortunately, for OP it is probably past time to update OS X version.

OP had previously posted issue as bug 93035 for LO 4.4.4, that also was dupped to tdf#81759

*** This bug has been marked as a duplicate of bug 81759 ***
Comment 2 Greg 2015-11-29 23:30:22 UTC
So, what you're saying is i need to update my OS in order for the feature to work?
Comment 3 V Stuart Foote 2015-11-30 01:45:00 UTC
While the LO implementation of NSTextInputClient probably needs improvement/completion, the issue is on the OS X side--assuming the findings of 81759 hold true.

So since Apple will not do anything for Mavericks 10.9.5, your best bet is to look at 10.11.1 El Capitan--so, yes. 

You need to update.