Bug 82248 - Other: Changing or resetting shortcuts doesn't work
Summary: Other: Changing or resetting shortcuts doesn't work
Status: RESOLVED DUPLICATE of bug 35030
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 118892 (view as bug list)
Depends on:
Blocks: Customize-Dialog-Keyboard Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2014-08-06 13:11 UTC by Dakov
Modified: 2022-03-07 16:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video (zipped) showing how changes are forgotten. (1.66 MB, application/x-zip-compressed)
2014-08-06 13:14 UTC, Dakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dakov 2014-08-06 13:11:00 UTC
Problem description:
If you change more than one shortcut and click OK LibreOffice often only registers the last shortcut you changed - or none.


Steps to reproduce:
1. .... Open customize
2. .... Change Undo to Ctrl+Y
3. .... Now change Redo to Ctrl+Shift+Y
4. .... Perhaps Switch to LibreOffice shortcuts isntead of Writer
5. .... Do more shortcut changes (that you remember)
6. .... Click OK
7. .... Re-open Customize and notice that most of none weren't changed.

Current behavior:
Customized shortcuts are often forgotten (this issue has been in OpenOffice for as long as I can remember - 10 years?)


Expected behavior:
ALL shortcuts changed in Writer and generally in the LibreOffice shortcut list should be remembers and saved even if you click OK only once after changing both the Writer and LibreOffice list.
              
Operating System: Windows 8
Version: 4.3.0.4 release
Comment 1 Dakov 2014-08-06 13:14:29 UTC
Created attachment 104150 [details]
Video (zipped) showing how changes are forgotten.
Comment 2 Dakov 2014-08-06 13:15:54 UTC
Please see the attached video.
Comment 3 Buovjaga 2014-11-05 13:33:19 UTC
Confirmed -> NEW.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: b7d8a58ff2698ffc6e22943f64aa97c5ea253bd9
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-05_00:40:38
Comment 4 QA Administrators 2015-12-20 16:16:09 UTC Comment hidden (obsolete)
Comment 5 Thomas Lendo 2018-03-11 22:51:49 UTC
Still reproducible with Version: 6.1.0.0.alpha0+
Build ID: adc6ba2ad502f095dde8f36242fda9aaa6c276fd
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Build from today
Comment 6 Alex Thurgood 2018-08-06 07:35:24 UTC
*** Bug 118892 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2019-08-07 04:45:50 UTC Comment hidden (obsolete)
Comment 8 sdc.blanco 2022-03-07 16:47:29 UTC

*** This bug has been marked as a duplicate of bug 35030 ***