Bug 82430 - LO 4.3.0 for Windows crashes on CPUs that do not support SSE2: Application Error soffice.bin, version 4.3.0.4, module sal3.dll, version 4.3.0.4, address 0x000268d5.
Summary: LO 4.3.0 for Windows crashes on CPUs that do not support SSE2: Application Er...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86 (IA32) Windows (All)
: high blocker
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard: target:4.4.0 target:4.3.1 target:4.3....
Keywords: regression
: 84316 88374 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-10 20:49 UTC by Ivan
Modified: 2015-10-28 01:53 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
error (35.41 KB, image/jpeg)
2014-08-10 20:49 UTC, Ivan
Details
message after run libo-43~2014-08-25_08.45.25_LibreOfficeDev_4.3.2.0.0 (401.48 KB, text/plain)
2014-08-26 14:57 UTC, JCE
Details
Backtrace from WinXP, Libo 4.4.2.2, opening .xls file (13.31 KB, text/plain)
2015-04-18 16:44 UTC, Buovjaga
Details
Crash after closing file 1 (21.42 KB, image/jpeg)
2015-10-26 21:27 UTC, Reinhard Mühlbauer
Details
crash after closin file 2 (21.36 KB, image/jpeg)
2015-10-26 21:40 UTC, Reinhard Mühlbauer
Details
crash after closing file 3 (21.41 KB, image/jpeg)
2015-10-26 21:41 UTC, Reinhard Mühlbauer
Details
crash after closing file 4 (20.45 KB, image/jpeg)
2015-10-26 21:43 UTC, Reinhard Mühlbauer
Details
crash after closin file 5 (22.07 KB, image/jpeg)
2015-10-26 21:44 UTC, Reinhard Mühlbauer
Details
crash after closing file 6 (21.06 KB, image/jpeg)
2015-10-26 21:47 UTC, Reinhard Mühlbauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan 2014-08-10 20:49:47 UTC
Created attachment 104393 [details]
error

After update from 4.2.5.2 to 4.3.0.4

Application Error soffice.bin, version 4.3.0.4, module sal3.dll, version 4.3.0.4, address 0x000268d5.

LО doesn't start (

Ошибка приложения soffice.bin, версия 4.3.0.4, модуль sal3.dll, версия 4.3.0.4, адрес 0x000268d5.
Comment 1 Jean-Baptiste Faure 2014-08-11 04:52:41 UTC
Something like this problem:
http://go.mail-archive.com/5fqF79Qe7kgmiSzrxL7OYteZQy4= ?

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 2 Ivan 2014-08-11 10:01:16 UTC
Hi, JBF!

Yes, I think it's the same error.
problems are present: LibreOffice 4.3.1.1
Can you fix it?

Thank you!

Computer	
Operating System	Microsoft Windows XP Professional
OS Service Pack	Service Pack 3
Internet Explorer	8.0.6001.18702
	
Motherboard	
CPU Type	AMD Athlon XP, 1746 MHz 2100+
Motherboard Name	Abit NF7(-S) v2.0  (5 PCI, 1 AGP, 3 DIMM, Audio, LAN)
Motherboard Chipset	nVIDIA nForce2 Ultra 400
System Memory	2304 MB
BIOS Type	Award (11/22/04)

CPUID Properties	
CPUID Manufacturer	AuthenticAMD
CPUID CPU Name	AMD Sempron(tm) 2500+
CPUID Revision	0681h
Extended CPUID Revision	0781h
Platform ID	CBh (Socket A)
IA CPU Serial Number	Unknown
	
Instruction Set	
AMD 3DNow!	Supported
AMD 3DNow! Professional	Supported
AMD Enhanced 3DNow!	Supported
AMD Extended MMX	Supported
AMD64	Not Supported
Cyrix Extended MMX	Not Supported
IA-64	Not Supported
IA MMX	Supported
IA SSE	Supported
IA SSE 2	Not Supported
IA SSE 3	Not Supported
CLFLUSH Instruction	Not Supported
CMPXCHG8B Instruction	Supported
Conditional Move Instruction	Supported
MONITOR / MWAIT Instruction	Not Supported
	
CPUID Features	
36-bit Page Size Extension	Supported
Automatic Clock Control	Not Supported
CPL Qualified Debug Store	Not Supported
Debug Trace Store	Not Supported
Debugging Extension	Supported
Enhanced SpeedStep Technology	Not Supported
Fast Save & Restore	Supported
Fast System Call	Supported
Hyper-Threading Technology	Not Supported
L1 Context ID	Not Supported
Local APIC On Chip	Supported
LongRun	Not Supported
LongRun Table Interface	Not Supported
Machine-Check Architecture	Supported
Machine-Check Exception	Supported
Memory Type Range Registers	Supported
Model Specific Registers	Supported
Page Attribute Table	Supported
Page Global Extension	Supported
Page Size Extension	Supported
Pending Break Event	Not Supported
Physical Address Extension	Supported
Processor Duty Cycle Control	Not Supported
Processor Serial Number	Not Supported
Self-Snoop	Not Supported
Thermal Monitor	Not Supported
Thermal Monitor 2	Not Supported
Time Stamp Counter	Supported
Virtual Mode Extension	Supported
	
Enhanced Power Management	
Frequency ID Control	Not Supported
Software Thermal Control	Not Supported
Temperature Sensing Diode	Supported
Thermal Monitoring	Not Supported
Thermal Trip	Not Supported
Voltage ID Control	Not Supported
Comment 3 JCE 2014-08-12 08:11:29 UTC
Same problem with update from 4.2.5.2 to 4.3.0.4
Update to 4.3.0.4 Ok
the programm does not run 

using
XP SP3 processeur AMD Athlon XP1800 SSE

I see that in 4.3 Release Notes that compilation is made of 4.3 on Windows Server 2012R2 with Visual Studio 2012 and it seems that the default build with VS 2012 is for SSE2 ?

Processor 1			ID = 0
	Number of cores		1 (max 1)
	Number of threads	1 (max 1)
	Name			AMD Athlon XP
	Codename		Thoroughbred
	Specification		AMD Athlon(tm) 
	Package 		Socket A (462)
	CPUID			6.8.0
	Extended CPUID		7.8
	Core Stepping		A0
	Technology		0.13 um
	Core Speed		1152.9 MHz
	Multiplier x FSB	11.5 x 100.3 MHz
	Rated Bus speed		200.5 MHz
	Instructions sets	MMX (+), 3DNow! (+), SSE
Mainboard Model		MS-6380E (0x000001E3 - 0x00BE1AEA)
Memory 2x 512 MBytes
Comment 4 Jean-Baptiste Faure 2014-08-13 04:50:34 UTC
So confirmed.
See also the discussion on the developer list:
http://nabble.documentfoundation.org/v4-3-0-4-not-working-on-SSE1-CPUs-anymore-tp4118212.html

Best regards. JBF
Comment 5 Michael Stahl 2014-08-13 09:50:45 UTC
potential patch for this is here, don't have hardware to test it though
and also nobody knows what sort of performance impact will
result from not using SSE2:
https://gerrit.libreoffice.org/#/c/10838/
Comment 6 Michael Meeks 2014-08-13 14:49:33 UTC
Most of our performance problems are not at the micro level wrt. SSE2 optimization but crazy big algorithmic issues that SSE2 won't help for ;-) so I'd say - go for it ...
Comment 7 JCE 2014-08-14 13:08:10 UTC
Hi,

Is there a link to test a build with this new patch SSE ?
Thanks
Comment 8 Commit Notification 2014-08-14 17:01:36 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8bd6bf93b7711a7ac7c5cbd7c3bb980481570ebd

fdo#82430: configure: MSVC build: avoid using SSE2 instructions



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-08-15 10:39:05 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36ce22f41a754fa405804434899a08a23081e721

fdo#82430: MSVC 2010 refuses both -clr and -arch in the same command



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-08-18 10:26:42 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a18ff3d5c75c2b468c48bd19439dee0689d24d67

fdo#82430: gcc-wrappers: don't stop if REAL_CXX_FLAGS is empty



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Michael Stahl 2014-08-19 12:54:55 UTC
do the latest daily builds from here run on the old CPUs?

http://dev-builds.libreoffice.org/daily/master/Win-x86@42/
Comment 12 JCE 2014-08-19 16:04:28 UTC
Hi,
>do the latest daily builds from here run on the old CPUs?

download the 
libo-master~2014-08-19_05.34.52_LibreOfficeDev_4.4.0.0.alpha0_Win_x86.msi

install on XP SP3 processeur AMD Athlon XP1800 SSE
Install OK
Run the program, the scren "LibreOffice" appears then a warning box 
"The application cannot be stared..."
see http://postimg.org/image/llm4q0od5/
Try Repair warning box idem
Try Modify uncheck Windows Explorer Extension ans Extensions warning box idem
Comment 13 Commit Notification 2014-08-25 20:19:01 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f83c7358964cf9f265f21e7dfa72e82a26923b3e&h=libreoffice-4-3

fdo#82430: configure: MSVC build: avoid using SSE2 instructions


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2014-08-26 04:04:37 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31c1ceaf50f911b5ea22a1f7770b961343483230&h=libreoffice-4-3-1

fdo#82430: configure: MSVC build: avoid using SSE2 instructions


It will be available already in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 JCE 2014-08-26 14:57:16 UTC
Created attachment 105285 [details]
message after run libo-43~2014-08-25_08.45.25_LibreOfficeDev_4.3.2.0.0

libo-43~2014-08-25_08.45.25_LibreOfficeDev_4.3.2.0.0_Win_x86.msi
test install and run from XP SP3 processeur AMD Athlon XP1800 SSE
Comment 16 JCE 2014-08-26 14:58:37 UTC
>It will be available in LibreOffice 4.3.2.

download the  
libo-43~2014-08-25_08.45.25_LibreOfficeDev_4.3.2.0.0_Win_x86.msi

install on XP SP3 processeur AMD Athlon XP1800 SSE
Install OK
Run the program, and an alert dialog "libreoffice a cessé de fonctionner"
see file 469f_appcompat.txt
Comment 17 Michael Stahl 2014-08-26 15:10:03 UTC
(In reply to comment #15)
> libo-43~2014-08-25_08.45.25_LibreOfficeDev_4.3.2.0.0_Win_x86.msi
> test install and run from XP SP3 processeur AMD Athlon XP1800 SSE

thanks for testing, but i think this build is too old and does not
contain the commit yet; i hope today's build (08-26) should have it.
Comment 18 JCE 2014-08-26 16:01:38 UTC
>i hope today's build (08-26) should have it

I download the
libo-43~2014-08-26_10.56.01_LibreOfficeDev_4.3.2.0.0_Win_x86.msi

install on XP SP3 processeur AMD Athlon XP1800 SSE
Install OK
Run the program, the screen "LibreOffice" appears, but stop with a warning box 
LibreOfficeDec 4.3 - Fatal Error
"The application cannot be started Extension Manager: exception during enabledExtension"
It is idem the Comment 12
Try Repair : warning box idem
Try Modify and uncheck all the components : warning box idem

Now I cannot test before 16 September, I tomorrow goes on vacation ;)
Comment 19 Michael Stahl 2014-08-26 16:21:20 UTC
"Extension Manager: exception during enabledExtension"

that is unfortunate, something is caught in desktop/source/deployment/manager/dp_extensionmanager.cxx which is not a regular UNO exception.

maybe some of our bundled external libraries are not compiled with the -arch:SSE?
Comment 20 JCE 2014-09-16 14:21:34 UTC
Hi,

I download the
http://dev-builds.libreoffice.org/pre-releases/win/x86/LibreOffice_4.3.2.1_Win_x86.msi

install on XP SP3 processeur AMD Athlon XP1800 SSE
Install OK
Run the program, the screen "LibreOffice" appears, but stop with a warning box 
 Fatal Error
"The application cannot be started Extension Manager: exception during enabledExtension"
It is idem the Comment 12 and Comment 18

So Go back tho the version 4.2.6.2

This bug is NOT solved ;)
Comment 21 Ivan 2014-09-16 14:58:37 UTC
hi2all

Yes.
LibreOffice_4.3.1_Win_x86.msi
Run the program, the screen "LibreOffice" appears, but stop with a warning box 
 Fatal Error
"The application cannot be started Extension Manager: exception during enabledExtension"

This bug isn't solved.
Comment 22 JCE 2014-09-23 12:29:03 UTC
I download the lastest 
daily/libreoffice-4-3/Win-x86@42/current
libo-43~2014-09-22_07.54.32_LibreOfficeDev_4.3.3.0.0_Win_x86.msi

install on XP SP3 processeur AMD Athlon XP1800 SSE
Install OK
Run the program, the screen "LibreOffice" appears, but stop with a warning box 
 Fatal Error
"The application cannot be started Extension Manager: exception during enabledExtension"
It is idem the Comment 12 and Comment 18 and  20

is there a solution to have a working version 4.3 on XP SSE  ?
Comment 23 tommy27 2014-09-25 18:37:55 UTC
do you think Bug 84316 is a duplicate of this one?
Comment 24 Michael Stahl 2014-10-02 15:28:01 UTC
sorry was occupied with other tasks for the last weeks...

there's a script that can determine instructions used:
http://dev.gentoo.org/~solar/misc/analyse-x86.pl

based on that i've just tweaked the most important external libraries,
let's hope this will help to at least start soffice successfully:


Disassembling ./URE/bin/libxml2.dll, please wait...
i486:    0 i586:    0 ppro:    0 mmx:  570 sse:  204 sse2:  690
./URE/bin/libxml2.dll will run on Pentium IV (pentium4) or higher processor.
Checking vendor_id string...GenuineIntel
Disassembling ./URE/bin/icuuc53.dll, please wait...
i486:    0 i586:    0 ppro:    0 mmx:    1 sse:   14 sse2:  173
./URE/bin/icuuc53.dll will run on Pentium IV (pentium4) or higher processor.

Disassembling ./program/libxslt.dll, please wait...
i486:    0 i586:    4 ppro:    0 mmx:   55 sse:   61 sse2:  258

This binary was found to contain the cpuid instruction.
It may be able to conditionally execute instructions if
they are supported on the host (i586+).

./program/libxslt.dll will run on Pentium IV (pentium4) or higher processor.
Checking vendor_id string...GenuineIntel
Disassembling ./program/libexslt.dll, please wait...
i486:    0 i586:    0 ppro:    0 mmx:  111 sse:   24 sse2:  482
./program/libexslt.dll will run on Pentium IV (pentium4) or higher processor.
Checking vendor_id string...GenuineIntel
Disassembling ./program/libxmlsec.dll, please wait...
i486:    0 i586:    0 ppro:    0 mmx:   71 sse:   26 sse2:    4
./program/libxmlsec.dll will run on Pentium IV (pentium4) or higher processor.
Disassembling ./program/icuin53.dll, please wait...
i486:    0 i586:    4 ppro:    2 mmx:    1 sse:    2 sse2: 3676

This binary was found to contain the cpuid instruction.
It may be able to conditionally execute instructions if
they are supported on the host (i586+).

./program/icuin53.dll will run on Pentium IV (pentium4) or higher processor.
Disassembling ./program/nssckbi.dll, please wait...
i486:    0 i586:    0 ppro:    0 mmx:   52 sse:    1 sse2:   14
./program/nssckbi.dll will run on Pentium IV (pentium4) or higher processor.
Disassembling ./program/nspr4.dll, please wait...
i486:    3 i586:    0 ppro:    2 mmx:  206 sse:   38 sse2:  274
./program/nspr4.dll will run on Pentium IV (pentium4) or higher processor.
Disassembling ./program/ssl3.dll, please wait...
i486:    0 i586:    0 ppro:    0 mmx:  376 sse:   13 sse2:    7
./program/ssl3.dll will run on Pentium IV (pentium4) or higher processor.
Disassembling ./program/sqlite3.dll, please wait...
i486:    0 i586:    4 ppro:    1 mmx:  650 sse:  159 sse2:  682

This binary was found to contain the cpuid instruction.
It may be able to conditionally execute instructions if
they are supported on the host (i586+).

./program/sqlite3.dll will run on Pentium IV (pentium4) or higher processor.
Disassembling ./program/python3.dll, please wait...
i486:    0 i586:    4 ppro:    0 mmx:   10 sse:    0 sse2:   60

This binary was found to contain the cpuid instruction.
It may be able to conditionally execute instructions if
they are supported on the host (i586+).

./program/python3.dll will run on Pentium IV (pentium4) or higher processor.
Disassembling ./program/lcms2.dll, please wait...
i486:    0 i586:    4 ppro:    0 mmx:  635 sse: 1163 sse2: 5897

This binary was found to contain the cpuid instruction.
It may be able to conditionally execute instructions if
they are supported on the host (i586+).

./program/lcms2.dll will run on Pentium IV (pentium4) or higher processor.
Checking vendor_id string...GenuineIntel
Disassembling ./program/avmediaogl.dll, please wait...
i486:    0 i586:    0 ppro:    6 mmx:  706 sse: 4327 sse2:  554
./program/avmediaogl.dll will run on Pentium IV (pentium4) or higher processor.
Comment 25 Christian Lohmaier 2014-10-06 09:44:33 UTC
installsets with the latest patch https://gerrit.libreoffice.org/#/c/11769/ have been provided here: http://dev-builds.libreoffice.org/tmp/fdo_82430/

please give them a quick test.
Comment 26 Julien Nabet 2014-10-07 07:56:06 UTC
*** Bug 84316 has been marked as a duplicate of this bug. ***
Comment 27 JCE 2014-10-07 08:23:48 UTC
(In reply to Christian Lohmaier from comment #25)
> installsets with the latest patch https://gerrit.libreoffice.org/#/c/11769/
> have been provided here: http://dev-builds.libreoffice.org/tmp/fdo_82430/

Thanks
Download LibreOfficeDev_4.3.3.0.0_Win_x86_en-US_de_ar_ja_qtz.msi
Install on XP SP3 processeur AMD Athlon XP1800 SSE
Install OK
Run the program,start ok see http://postimg.org/image/c0ptn0wi7/
test some files ods, odt, rtf loading is Ok 
but sometimes LibreOffice crash just by clicking on the page
 see message http://postimg.org/image/dikk6x1hn/
Test export PDF same message
Comment 28 Jean-Baptiste Faure 2014-10-11 08:27:47 UTC
Could be possible that bug 83277 is a duplicate of this one ?

Best regards. JBF
Comment 29 JCE 2014-10-26 10:27:19 UTC
Hi,

is the version LibreOffice_4.3.3.2_Win_x86.msi 23-Oct-2014 21:01 from http://dev-builds.libreoffice.org/pre-releases/win/x86/ fixes this bug?
Comment 30 Commit Notification 2014-11-03 22:29:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c79d2dbe3a75e3376a5997444b6a3a5f947da107

fdo#82430: MSVC build: disable a few more cases of SSE2 in externals

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 31 Michael Stahl 2014-11-03 22:47:56 UTC
did a little more investigation... found that in the last patch
i've unfortunately only adjusted ICU's CFLAGS and not CXXFLAGS
so the majority of ICU code was still compiled for SSE2;
this most likely causes lots of crashes in spell checking,
word counting etc.

this should be fixed on master now.

there are still 3 kinds of externals that the analyze-x86.pl script
complains about: 1. firebird and 2. coinmp are not so important because
they are new experimental features anyway; also we patch horrible
things into coinmp's build system which needs cleaning up...

the 3. is basically "everything built with gcc-wrapper",
i.e. mostly the more obscure import filters,
and i have no idea how to fix that, evidently the -arch:SSE is
passed to cl.exe; i *hope* it's a false positive from the analyze-x86.pl.

* * * 

there is apparently a tool from Intel called "Software Development Emulator"
that can emulate various x86 CPUs in a fast way with dynamic translation,
so i thought it should be possible to use it for testing...

unfortunately it turns out to be severely under-documented and i couldn't
get it to run soffice, it was always aborting on a SSE2 instruction in
MSVCR110.DLL which indicates that the CPUID still claims SSE2 support,
despite setting it to Pentium3 (the -cpuid-in parameter is undocumented).


/home/sde-external-7.8.0-2014-10-02-win/sde.exe -chip-check PENTIUM3 -cpuid-in c:/cygwin/home/ms/sde-external-7.8.0-2014-10-02-win/misc/cpuid/pentium3/cpuid.def  -- instdir/program/soffice
Comment 32 Commit Notification 2014-11-06 09:50:54 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0fae44a2c9c17d6e3325c7ca2d56d4f90ad539c9&h=libreoffice-4-3

fdo#82430: MSVC build: disable a few more cases of SSE2 in externals

It will be available in 4.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 JCE 2014-11-10 09:48:28 UTC
download the file libo-43~2014-11-09_07.56.38_LibreOfficeDev_4.3.4.0.0_Win_x86.msi
on http://dev-builds.libreoffice.org/daily/libreoffice-4-3/Win-x86@42/
Install it
Run it and LBO run well on XP SP3 processeur AMD Athlon XP1800 SSE
Version: 4.3.4.0.0+
Build ID: ce807b9143baa7a686ab9b2a95899f2c1817a715
Well ... thanks and "Bravo to super" Michael Stahl ;)
Now tests :
- test open files ods, odt, doc, .ppt OK
- test open files xls -> message Read-error. Internal import error

Waiting for the results of other feedback
Comment 34 JCE 2014-11-11 11:33:37 UTC
(In reply to JCE from comment #33)
> download the file
> libo-43~2014-11-09_07.56.38_LibreOfficeDev_4.3.4.0.0_Win_x86.msi
> on http://dev-builds.libreoffice.org/daily/libreoffice-4-3/Win-x86@42/
> Install it
> Run it and LBO run well on XP SP3 processeur AMD Athlon XP1800 SSE
> Now tests :
> - test open files ods, odt, doc, .ppt OK
> - test open files xls -> message Read-error. Internal import error

Test an open file spreadsheet: Predim4.ods an try to save it on Excel 97 .XLS
message : Error saving the document Predim4: Read-Error.
Internal import error.
Comment 35 Björn Michaelsen 2014-11-28 09:42:12 UTC Comment hidden (obsolete)
Comment 36 JCE 2015-02-06 10:16:17 UTC
download the file libo-44~2015-02-02_15.42.43_LibreOfficeDev_4.4.1.0.0_Win_x86.msi
Install it : OK
Run it and LBO run well on XP SP3 processeur AMD Athlon XP1800 SSE
same problem as reported
Comment 37 Michael Stahl 2015-02-06 13:25:51 UTC
*** Bug 88374 has been marked as a duplicate of this bug. ***
Comment 38 drmmedia 2015-02-09 22:26:04 UTC
I've just spent the better part of a day trying to install LibreOffice on an old PC with a clean Windows 7 installation and I couldn't figure out why it wouldn't work.
My other Athlon XP CPU is running v4.2 without issue.

Anyway, Athlon XP 2800+ (no SSE2 of course), Windows 7 x86:
Loading .XLS documents generates Read Error: Internal Import Error.
Loading .PPS hangs the program.
I'm sure there are other issues, but it was enough for me to uninstall LO.

v4.2 is fine.

This is a lightweight program, it should run on light weight systems.
This bug was reported almost 6 months ago, can we please elevate it?
Not running at all is a SERIOUS bug, not minor.
Comment 39 Michael Stahl 2015-02-09 22:39:28 UTC
it's not obvious where the remaining problem is, none of the developers has such old hardware, and to have any hope of making progress we would need to locate the faulting instructions with a stack trace from windbg or VisualStudio.

for windbg there are some instructions on this here, but i don't
know if it stops automatically when an invalid instruction is executed
or if that needs some special commands...

https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg

in Visual Studio there is a dialog in "Debug->Exceptions" with
a lot of checkboxes about which should stop the execution,
there is under "Win32 exceptions" the "0xc0000001d Illegal Instruction"
which i guess should be enabled.
Comment 40 drmmedia 2015-02-09 23:24:38 UTC
(In reply to Michael Stahl from comment #39)
> it's not obvious where the remaining problem is, none of the developers has
> such old hardware, and to have any hope of making progress we would need to
> locate the faulting instructions with a stack trace from windbg or
> VisualStudio.
> 
> for windbg there are some instructions on this here, but i don't
> know if it stops automatically when an invalid instruction is executed
> or if that needs some special commands...
> 
> https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
> 
> in Visual Studio there is a dialog in "Debug->Exceptions" with
> a lot of checkboxes about which should stop the execution,
> there is under "Win32 exceptions" the "0xc0000001d Illegal Instruction"
> which i guess should be enabled.

I will admit I know little about debugging.  Typically in cases where SSE2 is the issue it is because the compiler was set to use that instruction set and a rebuild clearing that option can fix it.

Sorry, but I was just a big put off that I spent a log of time bouncing against this bug and the tone of this thread makes it appear that fixing it is a low priority.

It should be pointed out that System Requirements say: "Pentium-compatible PC (Pentium III, Athlon or more-recent system recommended);"  The P3 was an non-SSE2 processor.  I wonder how many people assume LO should work because of this, and then when it doesn't they just move on to a different program.
Comment 41 Tor Lillqvist 2015-04-16 12:14:22 UTC
Maybe the real bug is in the System Requirements then?
Comment 42 Buovjaga 2015-04-17 16:02:12 UTC
(In reply to drmmedia from comment #38)
> I've just spent the better part of a day trying to install LibreOffice on an
> old PC with a clean Windows 7 installation and I couldn't figure out why it
> wouldn't work.
> My other Athlon XP CPU is running v4.2 without issue.
> 
> Anyway, Athlon XP 2800+ (no SSE2 of course), Windows 7 x86:
> Loading .XLS documents generates Read Error: Internal Import Error.
> Loading .PPS hangs the program.
> I'm sure there are other issues, but it was enough for me to uninstall LO.

Tried today on a Pentium III processor.
Could not reproduce hang with this .pps: http://www.reading.ac.uk/web/files/www_File_Library/example.pps

Please attach a .PPS that hangs in your setup.

Could reproduce .xls read error. Debugging will continue tomorrow.
Comment 43 Buovjaga 2015-04-18 16:44:45 UTC
Created attachment 114883 [details]
Backtrace from WinXP, Libo 4.4.2.2, opening .xls file

In Windbg I did Debug - Event filters - enabled Illegal instruction. Then it breaked out when opening the .xls threw an illegal instruction and I could analyze.
Thanks to Michael Stahl for tips.
Comment 44 Commit Notification 2015-04-18 22:08:07 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c4a267215c10647ff281e9e629faa0a8a201f4b4

tdf#82430: gcc-wrappers: command line *must* start with a space

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 45 Michael Stahl 2015-04-18 22:11:13 UTC
thanks Beluga, very useful stack trace, found the issue

hopefully this should fix everything in 4.3 that isn't experimetal
Comment 46 Commit Notification 2015-04-19 08:22:56 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0dac335acbcd382fff422e50058d8aa21646a364&h=libreoffice-4-4

tdf#82430: gcc-wrappers: command line *must* start with a space

It will be available in 4.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 47 Commit Notification 2015-04-19 08:24:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c3f7421d550b6ae8c6bfdcde709dfba57aa1d3a&h=libreoffice-4-3

tdf#82430: gcc-wrappers: command line *must* start with a space

It will be available in 4.3.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 48 Commit Notification 2015-04-20 10:08:18 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-7":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b2c9319c508b340694017b1458ab5feb4d948585&h=libreoffice-4-3-7

tdf#82430: gcc-wrappers: command line *must* start with a space

It will be available in 4.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 49 Commit Notification 2015-04-21 12:24:28 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eccbf9df2e08d78b96b01b891e801fc8ef9b1f88&h=libreoffice-4-4-3

tdf#82430: gcc-wrappers: command line *must* start with a space

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 50 JCE 2015-04-22 08:17:42 UTC
Thanks to Michael Stahl
download the file :
libo-44~2015-04-21_07.17.34_LibreOfficeDev_4.4.4.0.0_Win_x86.msi
Install it : OK 
Run it and LBO run well on XP SP3 processeur AMD Athlon XP1800 SSE
Test open files *.xls, *.doc, *.ppt, odt, *.ods, *svg
export as PDF is OK also
I will test with version 4.3.8 libo-43~2015-04-21xxx (not available today)
So now need to tests with other testers
Comment 51 Buovjaga 2015-04-22 16:41:49 UTC
No problem opening .xls with 4.3.8.

5.0 from 21.4. did not launch, first complained about missing MSVCR120.dll and after I added it, said "The procedure entry point InetNtopW could not be located in the dynamic link library WS2_32.dll".

Version: 4.3.8.0.0+
Build ID: 589f7cbe3789224a8836f3cd4705f067be6789c5
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2015-04-20_12:02:51
Comment 52 Michael Stahl 2015-04-22 19:07:07 UTC
guess i should mention this: 5.0 will be built with a different toolchain,
and if it's configured with the 8.x SDK it will flat out not run on Windows XP.

if you have any issue with 5.0 releases please file a new bug, don't re-open this one.
Comment 53 Buovjaga 2015-04-22 19:17:11 UTC
(In reply to Michael Stahl from comment #52)
> guess i should mention this: 5.0 will be built with a different toolchain,
> and if it's configured with the 8.x SDK it will flat out not run on Windows
> XP.
> 
> if you have any issue with 5.0 releases please file a new bug, don't re-open
> this one.

Cloph told me my issue with 5.0 was because I used SI-GUI to do a parallel install :)
I'm not at the machine so can't test, but here is a workaround: https://wiki.documentfoundation.org/Development/msvc-x86_64#MS_Visual_Studio_C.2B.2B_2013_runtimes

I'll set this to VERIFIED.
Comment 54 JCE 2015-04-23 08:30:49 UTC
download the file : 4.3.8
libo-43~2015-04-20_12.02.51_LibreOfficeDev_4.3.8.0.0_Win_x86.msi
Install it : OK 
Run it and LBO run well on XP SP3 processeur AMD Athlon XP1800 SSE
Test open files *.xls, *.doc, *.ppt, odt, *.ods, *svg
export as PDF is OK also
So now I need to test the last full version testing LibreOffice_4.3.x.x_Win_x86.msi
Comment 55 JCE 2015-04-26 13:02:30 UTC
Test with LibreOffice_4.3.7.2_Win_x86.msi
Version: 4.3.7.2 Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba
All is OK
on XP SP3 processeur AMD Athlon XP1800 SSE
Comment 56 JCE 2015-08-09 07:48:08 UTC
Test on version 4.5.5.2
All is OK non problem
on XP SP3 processeur AMD Athlon XP1800 SSE

So delete on https://wiki.documentfoundation.org/ReleaseNotes/4.4
"Platform compatibility / Windows 
Known Issue: there are problems with running the Windows release on older CPUs that lack support for SSE2 instructions.."
Comment 57 Pierre C 2015-09-20 20:34:22 UTC
Has the performance drop been evaluated ? (with or without sse2 optimisation)

Is there any stat on how many computers are still running with such an old processor ?

IMHO, it's quite crazy to hardly work to improve LO perf (using OOpenCL, OpenGL, and other perf opt), and at the same time dropping SSE2 optimisation.

Maybe someone can consider it's time to forget old processors. Why not starting with LO5 Branch ?

Of course, if 20 % of LO users are using non sse2 processor, it's a good thing, but what if it is 0,0000 1 % ? Surely, this number decreases months after months
Comment 58 Reinhard Mühlbauer 2015-10-26 21:27:09 UTC
Created attachment 119977 [details]
Crash after closing file 1
Comment 59 Reinhard Mühlbauer 2015-10-26 21:40:03 UTC
Created attachment 119978 [details]
crash after closin file 2
Comment 60 Reinhard Mühlbauer 2015-10-26 21:41:20 UTC
Created attachment 119979 [details]
crash after closing file 3
Comment 61 Reinhard Mühlbauer 2015-10-26 21:43:48 UTC
Created attachment 119980 [details]
crash after closing file 4
Comment 62 Reinhard Mühlbauer 2015-10-26 21:44:48 UTC
Created attachment 119981 [details]
crash after closin file 5
Comment 63 Reinhard Mühlbauer 2015-10-26 21:47:43 UTC
Created attachment 119982 [details]
crash after closing file 6

all files are opened with a double-click and closed again without doing anything else.
Comment 64 Reinhard Mühlbauer 2015-10-26 21:56:41 UTC
old computers in use:
PC1: Win98SE / IDT WinChip C6 200 MHz (MMX)
PC2: XPproSP3 / Intel Celeron 600 MHz (MMX; SSE)
PC3: Win98SE / AMD Athlon 800 MHz (MMX+; 3DNow!+)
PC4: XPSP3 / Intel Pentioum III E (MMX; SSE)
PC5: Win7 / AMD Athlon XP2600+ (MMX; 3DNow!+; SSE)
PC6: XPproSP3 / AMD Athlon XP3000+ (MMX+; 3DNow!+; SSE)
Comment 65 Jean-Baptiste Faure 2015-10-27 05:41:34 UTC
Pleas, do not change the version number which is intended to reflect to oldest version in which the issue has been seen.

Best regards. JBF
Comment 66 Reinhard Mühlbauer 2015-10-27 08:56:16 UTC
Sorry, I have some problems with the bugzilla comment system.
Can anybody correct my mistakes and bring the messages to the proper location?
Thank you !