Download it now!
Bug 82693 - EDITING: segfault when switch type to GL3D
Summary: EDITING: segfault when switch type to GL3D
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: haveBacktrace
: 85753 88229 91423 (view as bug list)
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2014-08-16 07:32 UTC by Bugcruncher
Modified: 2018-10-11 11:29 UTC (History)
9 users (show)

See Also:
Crash report or crash signature: ["epoxy.dll"]


Attachments
Sample Document (16.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-16 07:32 UTC, Bugcruncher
Details
terminal output from master (5.09 KB, text/plain)
2014-08-16 14:22 UTC, Terrence Enger
Details
backtrace from the core file, master 692878e (11.81 KB, text/plain)
2014-08-16 14:24 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bugcruncher 2014-08-16 07:32:37 UTC
Created attachment 104712 [details]
Sample Document

Steps to reproduce:
1. Open attachment "sample30"
2. Double click Chart
3. RightClick Chart  ► Chart Type = GL3D 
   » LibreOffice becomes unresponding, if you click around
     on cells and chart after few clicks you will get 
     crash message "Runtime Error! .... R6025 - 
     Pure virtual function call"

Generally working with GL3D Charts causes significant processor load on changing Processor Cores for me, but LibreOffice keeps working and responding 
          
Operating System: Windows 7
Version: 4.4.0.0.alpha0+ Master
Comment 1 Terrence Enger 2014-08-16 14:19:14 UTC
I see the segmentaion fault in LibreOffice 4.3.0.1 and in master
commit 6928f8e, fetched 2014-08-13, configured:

    --enable-option-checking=fatal --enable-dbgutil --enable-crashdump
    --without-system-postgresql --without-myspell-dicts
    --with-extra-buildid --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src

built and running on debian-wheezy 64-bit.
Comment 2 Terrence Enger 2014-08-16 14:22:16 UTC
Created attachment 104736 [details]
terminal output from master
Comment 3 Terrence Enger 2014-08-16 14:24:04 UTC
Created attachment 104737 [details]
backtrace from the core file, master 692878e

Frame #0 shows program counter = 0x0.  Caller is
chart::opengl3D::OpenGL3DRenderer::init
Comment 4 Julien Nabet 2014-11-02 12:54:32 UTC
*** Bug 85753 has been marked as a duplicate of this bug. ***
Comment 5 Julien Nabet 2014-11-02 13:02:54 UTC
Markus: I  noticed this thread http://lists.freedesktop.org/archives/libreoffice-qa/2014-May/007186.html, so should this feature be removed or put experimental?
Comment 6 Matthew Francis 2015-04-02 14:09:31 UTC
This has occurred since the series of patches which contains

commit dfb2ab0cee2ba04ce8816580447e7db8160ffac4
Author: Markus Mohrhard <markus.mohrhard@collabora.co.uk>
Date:   Mon Mar 31 00:28:14 2014 +0200

    add initial code for creating 3D bar shapes
    
    Change-Id: I55489fad8723f204003fe502eea5e02de4c8d6ef


So not a regression as such, but a bug in a new feature
Comment 7 baffclan 2015-05-21 10:51:37 UTC
*** Bug 91423 has been marked as a duplicate of this bug. ***
Comment 8 Julien Nabet 2015-10-28 20:28:21 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
Here a part of bt:
#0  0x0000000000000000 in  ()
#1  0x00002aaadb2ddf92 in chart::opengl3D::OpenGL3DRenderer::init() (this=0x7bb5e70)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/view/main/GL3DRenderer.cxx:385
#2  0x00002aaadb1ff572 in chart::GL3DBarChart::GL3DBarChart(com::sun::star::uno::Reference<com::sun::star::chart2::XChartType> const&, OpenGLWindow*) (this=0x71f8100, xChartType=uno::Reference to (chart::GL3DBarChartType *) 0x795dd30, pWindow=0x7161c20)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/view/charttypes/GL3DBarChart.cxx:575
#3  0x00002aaadb2b4af7 in chart::ChartView::createShapes3D() (this=0x30c1b90) at /home/julien/compile-libreoffice/libreoffice/chart2/source/view/main/ChartView.cxx:3392
#4  0x00002aaadb2b084a in chart::ChartView::createShapes() (this=0x30c1b90) at /home/julien/compile-libreoffice/libreoffice/chart2/source/view/main/ChartView.cxx:2660
#5  0x00002aaadb2b0dfe in chart::ChartView::impl_updateView(bool) (this=0x30c1b90, bCheckLockedCtrler=true)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/view/main/ChartView.cxx:2745

with some console logs just before:
warn:sfx.sidebar:3753:1:sfx2/source/sidebar/SidebarController.cxx:804: Cannot create panel private:resource/toolpanel/ChartPanelFactory/CharacterPanel: unsatisfied query for interface of type com.sun.star.ui.XUIElement!
warn:legacy.osl:3753:1:chart2/source/tools/ChartTypeHelper.cxx:349: unknown charttype
warn:legacy.osl:3753:1:chart2/source/tools/ChartTypeHelper.cxx:623: unknown charttype
Comment 9 Julien Nabet 2015-11-09 20:23:33 UTC
*** Bug 88229 has been marked as a duplicate of this bug. ***
Comment 10 Julien Nabet 2015-11-09 20:25:01 UTC
Markus: if interested, I retrieved some OpenGL logs here https://bugs.documentfoundation.org/attachment.cgi?id=120426
I hadn't tested first with different SAL_USE_VCLPLUGIN values.
Comment 11 QA Administrators 2017-01-03 19:36:51 UTC Comment hidden (obsolete)
Comment 12 baffclan 2017-01-04 01:30:53 UTC
LibO 5.3.0.1 (x64) are no-crash.

LibODev 5.4.0.0.alpha0+ (x64) are crash in "epoxy.dll".
br-3549d4c5-5b0e-4b84-8d78-99f3ad8c8ab4

Version: 5.3.0.1 (x64)
Build ID: 3b800451b1d0c48045de03b5b3c7bbbac87f20d9
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-US (ja_JP); Calc: group

Version: 5.4.0.0.alpha0+ (x64)
Build ID: 654b86cf3425d7a49b13a97e4b11223d43b9e86e
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-12-20_22:52:05
Locale: ja-JP (ja_JP); Calc: group
Comment 13 Aron Budea 2017-01-26 15:30:51 UTC
Baffclan, what are the exact steps you've followed?

I don't see chart type GL3D, only a 3D Look checkbox.
Comment 14 Aron Budea 2017-01-26 15:51:16 UTC
I learned chart type GL3D Bar was made experimental since, and isn't maintained.
Comment 15 baffclan 2017-01-27 11:46:16 UTC
(In reply to Aron Budea from comment #13)
> I don't see chart type GL3D, only a 3D Look checkbox.
What is the version you are using?

Certainly there is no GL3D in the new 5.4.0.0.alpha0+.

Version: 5.4.0.0.alpha0+
Build ID: ac2105e77795970e9131092caae78fd42c86f6d9
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2017-01-16_23:47:13
Locale: ja-JP (ja_JP); Calc: group
Comment 16 Aron Budea 2017-01-28 20:24:10 UTC
(In reply to baffclan from comment #15)
> Certainly there is no GL3D in the new 5.4.0.0.alpha0+.

How do you get the epoxy-related crash? Since it's unrelated, it could be useful to open a new bug report on it.
Comment 17 Gabor Kelemen 2018-10-11 10:47:07 UTC
GL3D charts were recently removed in:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=026e2623f7f498432e6dc970fb06145dfc77dc45

Probably this is now a wontfix?
Comment 18 Xisco Faulí 2018-10-11 11:29:38 UTC
(In reply to Gabor Kelemen from comment #17)
> GL3D charts were recently removed in:
> 
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=026e2623f7f498432e6dc970fb06145dfc77dc45
> 
> Probably this is now a wontfix?

Indeed!
Closing as RESOLVED WONTFIX