Bug 83054 - Add "Go to Page" Entry in Edit Menu
Summary: Add "Go to Page" Entry in Edit Menu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Akshay Deep
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on: 104510
Blocks: UNO-Command Writer-Menus Go-To-Page
  Show dependency treegraph
 
Reported: 2014-08-25 11:34 UTC by Yousuf Philips (jay)
Modified: 2017-09-18 16:56 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Goto Page Dialog in Okular, Adobe Reader, Abiword and WPS Writer (62.47 KB, image/png)
2014-08-25 11:34 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-08-25 11:34:20 UTC
Created attachment 105230 [details]
Goto Page Dialog in Okular, Adobe Reader, Abiword and WPS Writer

One of the most common means of navigation is a simple goto feature. Most text editors have a go to line feature (Kate, Gedit, Notepad++, Geany) and most word processors and document viewers have a go to page feature (MS Word, Kingsoft/WPS Writer, WordPerfect, Abiword, Adobe Reader, Okular). So i'd like to suggest that a simple dialog appear, asking for the user to enter in a number for LibO to jump to.

Going to a particular page is possible in the navigator dialog, but i believe that basic users will be overwhelmed with the amount of features shown in the dialog, and the dialog doesnt have any text indication that that the goto page functionality is in the dialog.

I'd like to suggest that a menu entry be added for the feature in the Edit menu and that Ctrl+G be its shortcut key. Below is the menu and shortcut keys used by other mentioned apps.

Notepad++    - Search > Go to...      (Ctrl + G)
Geany        - Search > Go to Line... (Ctrl + L)
Gedit        - Search > Go to Line... (Ctrl + I)
Kate         - Edit > Go to Line...   (Ctrl + G)

MS Word      - Edit > Go To...        (Ctrl + G)
WPS Writer   - Edit > Go To...        (Ctrl + G)
Abiword      - Edit > Go To...        (Ctrl + G)
WordPerfect  - Edit > Go To...        (Ctrl + G)

Adobe Reader - View > Go To > Page... (Ctrl + N)
Okular       - Go > Go to Page...     (Ctrl + G)
Comment 1 tommy27 2014-08-25 13:39:27 UTC
valuable enhancement request.
status NEW. updated version to first LO release ever.
Comment 2 Cor Nouws 2014-08-25 21:49:45 UTC
Ctrl+Shft+F5  but indeed, you need to know ;)
Comment 3 Yousuf Philips (jay) 2014-08-25 22:19:08 UTC
Ctrl+Shift+F5 open navigator for me on Linux and that the same as just pressing F5, as stated in the View menu. Or am i missing something. :)
Comment 4 Adolfo Jayme 2014-08-27 14:49:06 UTC
Jay, when you press Ctrl+Shift+F5 the Navigator is open because it contains the functionality you're looking for, of course. It even focuses it.

Also, note that a different "Go to Line" window exists in LibreOffice Basic.
Comment 5 Yousuf Philips (jay) 2014-08-27 15:13:00 UTC
(In reply to comment #4)
> Jay, when you press Ctrl+Shift+F5 the Navigator is open because it contains
> the functionality you're looking for, of course. It even focuses it.

Adolfo, yes i see now that pressing Ctrl+Shift+F5 opens Navigator and focuses on the page control but unfortunately this isnt in any menu entry for it showing that shortcut key that a user would know that it was available. But the main point here is that the navigator dialog has alot of functionality in it beyond what an average user would need when all he wants to do is jump to a particular page.

> Also, note that a different "Go to Line" window exists in LibreOffice Basic.

Glad to hear that its in the text editor portion of the LibreOffice for programmers, now all we need is a duplicate of that same dialog for Go to page.
Comment 6 Cor Nouws 2014-08-27 21:07:57 UTC
(In reply to comment #5)

> available. But the main point here is that the navigator dialog has alot of
> functionality in it beyond what an average user would need when all he wants
> to do is jump to a particular page.

I beg to disagree here :) !
From all my training classes, nearly all people are delighted to learn the navigator.
Comment 7 Yousuf Philips (jay) 2014-08-27 23:02:19 UTC
(In reply to comment #6)
> I beg to disagree here :) !
> From all my training classes, nearly all people are delighted to learn the
> navigator.

Yes i believe that if you went to a training class to learn how to use a software that use of styles and navigator would definitely be part of the menu, but for the average user, the navigator will be a puzzle.
Comment 8 sophie 2014-10-28 18:54:06 UTC
Hi Jay, I don't think that hiding our most interesting and unique features will add value to our suite. If we want to look like others, just remove the stylist, the navigator and so on. Then LibreOffice will have exactly no benefit over others while we have features to sell. 
So please find a way to highlight the Navigator use instead of hiding it. Cheers - Sophie
Comment 9 Yousuf Philips (jay) 2016-03-04 17:35:29 UTC
Something as simple as how it looks in Adobe Reader (attachment 105230 [details]) is sufficient.

Once created, it should be assigned to Ctrl + G shortcut key and current 'Go to Page' entry in the menus should be replaced.

http://opengrok.libreoffice.org/xref/core/sw/uiconfig/swriter/menubar/menubar.xml#102
Comment 10 Heiko Tietze 2016-06-24 14:29:08 UTC
We should not implement dialogs for each and every single function. Rather push the (awesome) navigator, as Cor suggests in comment 6.
Comment 11 Cor Nouws 2016-06-24 14:48:20 UTC
(In reply to Heiko Tietze from comment #10)
> We should not implement dialogs for each and every single function. Rather
> push the (awesome) navigator, as Cor suggests in comment 6.

You could have Edit > Go to page, but then do the same as Ctrl+Shift+F5

(Plus that Ctrl+Shift+F5 should have the page number selected;
 Plus that when one the Navigator is closed when starting with Ctrl+Shift+F5, 
 after entering the page number and hitting Enter, the Navigator is again closed.
 - but those should be in a separate issue :) )
Comment 12 sophie 2016-06-27 10:25:50 UTC
Hi, just an idea: when you click on the page number on the status bar, it opens the navigator. Currently the focus is on heading, maybe putting the focus in the page number field, so you only have to enter the page number would do? Sophie
Comment 13 Yousuf Philips (jay) 2016-06-27 15:33:07 UTC
(In reply to Heiko Tietze from comment #10)
> We should not implement dialogs for each and every single function. Rather
> push the (awesome) navigator, as Cor suggests in comment 6.

As previously stated, navigator is fine for Eve, but over complicated for Benjamin (as well as being badly organized - bug 89566), especially with the limited scope of jumping to a particular page. This dialog is a basic feature of all word processors, document viewers, and text editor.
Comment 14 Heiko Tietze 2016-06-27 18:55:30 UTC
(In reply to Yousuf (Jay) Philips from comment #13)
> As previously stated, navigator is fine for Eve, but over complicated for
> Benjamin (as well as being badly organized - bug 89566), especially with the
> limited scope of jumping to a particular page. This dialog is a basic
> feature of all word processors, document viewers, and text editor.

Having a bad implementation is not a good reason to implement another half-baked. While it sounds not so bad what Sopie suggest, a light-weight overlay to enter the page number, it will feel oddly to have a heavy dialog that pops up for the page number. My point is: keep the menu clean and promote the navigator.

(UX-eval makes sense for all enhancements)
Comment 15 Regina Henschel 2016-06-27 19:14:52 UTC
(In reply to Yousuf (Jay) Philips from comment #3)
> Ctrl+Shift+F5 open navigator for me on Linux and that the same as just
> pressing F5, as stated in the View menu. Or am i missing something. :)

The difference is, where the cursor is. Pressing Ctrl+Shift+F5 the cursor is already in the number field and you can immediately change it. It could be made better, as Cor Nouws mentioned, when it would be selected in this case.
Comment 16 V Stuart Foote 2016-06-27 21:49:08 UTC
For something more lightweight than the full Navigator dialog, why not add a context menu to the Page field?

Left mouse opens the Navigator already. Right mouse context with a input box to enter the page?
Comment 17 V Stuart Foote 2016-06-27 21:50:17 UTC
(In reply to V Stuart Foote from comment #16)
> For something more lightweight than the full Navigator dialog, why not add a
> context menu to the Page field?
> 
> Left mouse opens the Navigator already. Right mouse context with a input box
> to enter the page?

Sorry, the Page field is on the left of the Status bar.
Comment 18 Regina Henschel 2016-06-27 23:14:25 UTC
(In reply to V Stuart Foote from comment #16)
> 
> Left mouse opens the Navigator already. Right mouse context with a input box
> to enter the page?

Right mouse click opens the list of bookmarks.
Comment 19 V Stuart Foote 2016-06-27 23:46:54 UTC
(In reply to Regina Henschel from comment #18)
> (In reply to V Stuart Foote from comment #16)
> > 
> > Left mouse opens the Navigator already. Right mouse context with a input box
> > to enter the page?
> 
> Right mouse click opens the list of bookmarks.

Oops you're right had forgotten that--don't show until a bookmark is set. Still might be able to split the button and squeeze a page entry there.
Comment 20 sophie 2016-06-28 09:30:39 UTC
(In reply to V Stuart Foote from comment #19)
> (In reply to Regina Henschel from comment #18)
> > (In reply to V Stuart Foote from comment #16)
> > > 
> > > Left mouse opens the Navigator already. Right mouse context with a input box
> > > to enter the page?
> > 
> > Right mouse click opens the list of bookmarks.
> 
> Oops you're right had forgotten that--don't show until a bookmark is set.
> Still might be able to split the button and squeeze a page entry there.

I think it's a good idea, bookmarks are not so much used and it's a nice 'go to' split :) Sophie
Comment 21 Heiko Tietze 2016-06-28 10:47:56 UTC
Not a good usability to execute functions on both left and right. And hiding an uncommon feature is even worse. Split buttons add complexity too, and it would be a very uncommon control in the statusbar. I suggest a menu on right click where you can choose the type of left click interaction. The shown information must be set accordingly.

(We are moving away from the topic.)
Comment 22 V Stuart Foote 2016-06-28 12:44:20 UTC
(In reply to Heiko Tietze from comment #21)
> Not a good usability to execute functions on both left and right. And hiding
> an uncommon feature is even worse. Split buttons add complexity too, and it
> would be a very uncommon control in the statusbar. I suggest a menu on right
> click where you can choose the type of left click interaction. The shown
> information must be set accordingly.
> 
> (We are moving away from the topic.)

Not at all, discussion was about adding a simple way to establish page navigation without use of the full Navigator.

The Status bar has numerous buttons that perform different actions with left mouse or right mouse selection.  Left mouse on the Page button already opens the Navigator -- so perfectly logical and consistent with GUI to have the right mouse action control go-to page (and retain the bookmarks).

Solve the use case with simple change to the existing structure--no NEED to implement a new dialog alien to the Navigator.
Comment 23 Regina Henschel 2016-06-28 14:43:11 UTC
We have already a simple navigation in the Preview, it is the command ".uno:JumpToSpecificPage" and is an input field in the toolbar. If any new solution for Writer is planed, shouldn't it be similar to the same feature already available in the preview?
Comment 24 Yousuf Philips (jay) 2016-07-01 08:29:35 UTC
(In reply to Heiko Tietze from comment #14)
> Having a bad implementation is not a good reason to implement another
> half-baked.

It isnt a half-baked implementation when all other apps use the same dialog, and we do as well in the Basic IDE.

> My point is: keep the menu clean and promote the navigator.

According to the HIG, the menus have all commands in them, and the menu is where most users who use this option will be going to find it, if not using the shortcut key. I looked for this feature in the menu and it was the reason i opened this enhancement.

(In reply to Regina Henschel from comment #15)
> The difference is, where the cursor is. Pressing Ctrl+Shift+F5 the cursor is
> already in the number field and you can immediately change it.

Yes adolfo mentioned this in comment 4. :D

> It could be
> made better, as Cor Nouws mentioned, when it would be selected in this case.

Yes definitely a good enhancement to have.

(In reply to V Stuart Foote from comment #16)
> Left mouse opens the Navigator already. Right mouse context with a input box
> to enter the page?

Regarding the page number statusbar entry, i've opened a separate bug report (bug 100716) for that and their isnt a means of including an input box in a context menu that i'm aware of, and doubt it would be a good UI.

(In reply to Regina Henschel from comment #23)
> We have already a simple navigation in the Preview, it is the command
> ".uno:JumpToSpecificPage" and is an input field in the toolbar. If any new
> solution for Writer is planed, shouldn't it be similar to the same feature
> already available in the preview?

Yes Akshay is working on this and Samuel mentioned that he should likely use that uno command for it.

https://gerrit.libreoffice.org/#/c/25949/
Comment 25 Akshay Deep 2016-07-08 11:06:04 UTC
> Yes Akshay is working on this and Samuel mentioned that he should likely use
> that uno command for it.
> 
> https://gerrit.libreoffice.org/#/c/25949/

(In reply to Regina Henschel from comment #23)
> We have already a simple navigation in the Preview, it is the command
> ".uno:JumpToSpecificPage" and is an input field in the toolbar.

Well.. the slot SID_JUMP_TO_SPECIFIC_PAGE cannot be used as it's defined for print view only. I have created a uno command .uno:GotoPage which provides for opening a dialog and changes the page according to the text input after clicking ok.
Comment 26 Commit Notification 2016-07-08 14:06:17 UTC
Akshay Deep committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c39db584f9f1877a9fa5ce00e8d19dd997d8078

tdf#83054 Writer: Add "Go to Page" Entry in Edit Menu

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Samuel Mehrbrodt (CIB) 2016-07-08 14:09:34 UTC
(In reply to Commit Notification from comment #26)
> Akshay Deep committed a patch related to this issue.

Good job, Akshay!
Would you please add a note with screenshot to the release notes, please?
Comment 28 Yousuf Philips (jay) 2016-07-12 03:20:54 UTC
Sent in patch to have Ctrl + G open the dialog.
https://gerrit.libreoffice.org/27132
Comment 29 Cor Nouws 2016-07-12 10:21:38 UTC
Hi Akshay,

(In reply to Commit Notification from comment #26)
> Akshay Deep committed a patch related to this issue.
> It has been pushed to "master":

It would be nice if on opening of the dialog the page number is selected. Would that be possible?

Thanks,
Comment 30 Cor Nouws 2016-07-12 10:24:45 UTC
Hi Jay,

(In reply to Yousuf (Jay) Philips from comment #28)
> Sent in patch to have Ctrl + G open the dialog.
> https://gerrit.libreoffice.org/27132

This removes the shortcut for repeat search.
Has this been discussed? Why not use Ctrl+Shft+G for the new dialog?
And why is it different for MacOS?

Ciao - Cor
Comment 31 Yousuf Philips (jay) 2016-07-13 04:12:14 UTC
(In reply to Cor Nouws from comment #30)
> Hi Jay,

Hi Cor,

> This removes the shortcut for repeat search.

Yes i'm the one who recently set Ctrl + G for repeat search primarily to improve Gnome, but then it also affects windows and kde.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=418982797f9bd2b2e9e5e47f81ba5041c91d6a0c

> Has this been discussed? Why not use Ctrl+Shft+G for the new dialog?

Most apps use Ctrl + G for the dialog on windows and linux, so that is why it is being assigned.

> And why is it different for MacOS?

Mac HIG has Ctrl + G for repeat search so we are respecting that (bug 98290).
Comment 32 Commit Notification 2016-07-15 18:04:21 UTC
Akshay Deep committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7e70b938618a49c4130502421d6909a2a3871579

tdf#83054 Preselect current page number in the text entry

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 33 Akshay Deep 2016-07-15 18:25:46 UTC
(In reply to Cor Nouws from comment #29)
> Hi Akshay,
> 
> (In reply to Commit Notification from comment #26)
> > Akshay Deep committed a patch related to this issue.
> > It has been pushed to "master":
> 
> It would be nice if on opening of the dialog the page number is selected.
> Would that be possible?
> 
> Thanks,

Hi.. Yes.. it's possible. I did it in the patch above.
Comment 34 Mike Kaganski 2016-07-22 01:20:10 UTC
Oh, that's sad.
IMO, it would be much better to not have a new dialog, but a "collapsed" state of our Navigator, with only page number edit control, *and* a button to expand it to normal view. That would both make a "familiar" UI, *and* promote Navigator...
Comment 35 Cor Nouws 2016-07-29 10:40:20 UTC
(In reply to Mike Kaganski from comment #34)
> Oh, that's sad.
> IMO, it would be much better to not have a new dialog, but a "collapsed"
> state of our Navigator, with only page number edit control, *and* a button
> to expand it to normal view.

unless the Navigator is docked (not the default state)

> That would both make a "familiar" UI, *and* promote Navigator...

Yep - OTHO, the new dialog behaves fine and is neat, so definitely an improvement!
Comment 36 Commit Notification 2016-08-13 12:50:54 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e7d6f952f136d11451969dcf1da417fe5e0e88f9

tdf#83054 Ctrl + G opens Go To Page dialog in writer

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 37 Commit Notification 2016-08-13 19:37:32 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=96e1588c1a176e0751cf72b27f099ef3a1a544c0

tdf#83054 Remove help button from go to page dialog

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 38 Commit Notification 2016-08-15 05:35:59 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=61da48e0b589ae4a660c9e8d858aa2e72d83645f

tdf#83054 Small tango icon for go to page

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 39 tommy27 2016-11-09 05:41:48 UTC
just tested LibIO 5.3.2.3

when I click the "Edit -> Go to Page" menu item the navigator floating window pops out. this panel has the Go to Page buttons but a lot of other stuff.

What should I do to enable the minimal "Go to Page" dialog that I see featured in the Release Notes here at: http://bit.ly/2ek502l  ?
Comment 40 Yousuf Philips (jay) 2016-11-09 12:22:34 UTC
(In reply to tommy27 from comment #39)
> just tested LibIO 5.3.2.3

I'm assuming you mean 5.2.2.3, as that version doesnt have the new dialog which is in 5.3.
Comment 41 tommy27 2016-11-09 13:20:44 UTC
thanks Jay...
I was puzzled by release numbers...
you are right... that dialog will come in 5.3.0.