Bug Hunting Session
Bug 83618 - SIDEBAR: Paragraph dialog and SideBar Paragraph Content Panel -- using different source for their Line spacing values
Summary: SIDEBAR: Paragraph dialog and SideBar Paragraph Content Panel -- using differ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other All
: medium normal
Assignee: Jim Raykowski
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords:
: 117965 127943 (view as bug list)
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2014-09-08 15:40 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-10-08 09:20 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
showing paragraph dialog and sidebar line spacing values (163.66 KB, image/png)
2014-09-08 15:40 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-08 15:40:19 UTC
Created attachment 105896 [details]
showing paragraph dialog and sidebar line spacing values

Steps:
1) Open writer
2) Goto paragraph dialog and set line spacing value for either at least, leading or fixed.
3) In the sidebar, open the line spacing drop down and it will have a different value than what is set

Tested in 4.2.6 and master on linux. This problem also happens if you set it in the sidebar, it will have a different value when you open the paragraph dialog.
Comment 1 V Stuart Foote 2014-09-08 16:18:07 UTC
Jay, *,

I don't believe there are necessarily linkages between the SVX controls of the Paragraph dialog, and the UI controls of the Paragraph Content Panel active in the SideBar deck.
  
There is some common use of widgets and buttons, but they do not always draw settings from the same configuration.  Suspect that is what is happening here.

Probably another SideBar wart that should be corrected.

The Dialog elements are here
http://opengrok.libreoffice.org/xref/core/cui/source/tabpages/paragrph.cxx

but not sure where the SideBar Paragraph Content Panel is pulling its settings from.
Comment 2 V Stuart Foote 2014-12-10 14:42:22 UTC
@Kendy, believe you tackled this with the commits Nov 4th.

http://cgit.freedesktop.org/libreoffice/core/log/?id=5929a87b8137bf6326adfd4ddfd8075e585ae15c&qt=range&q=5929a87b8137bf6326adfd4ddfd8075e585ae15c..eca6f3056de43b2a74108f96df3b55633a486d0b

Other than the keyboard navigation in the dropdown (bug 87120), its good.

OK to close?
Comment 3 Yousuf Philips (jay) (retired) 2014-12-10 20:57:38 UTC
Unfortunately the problem is still not resolved. In the dialog, i set it to at least 1cm and then toolbar drop down shows at least 0.57cm.

Version: 4.5.0.0.alpha0+
Build ID: 6163291b25d2dac74ac353c3879fdc520bee747e
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-12-09_01:35:51
Comment 4 V Stuart Foote 2014-12-10 22:46:42 UTC
(In reply to Jay Philips from comment #3)
> Unfortunately the problem is still not resolved. In the dialog, i set it to
> at least 1cm and then toolbar drop down shows at least 0.57cm.
> 
> Version: 4.5.0.0.alpha0+
> Build ID: 6163291b25d2dac74ac353c3879fdc520bee747e
> TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-12-09_01:35:51

@Jay, crud, you're right.  

@Kendy, did you miss a piece during conversion?

The Formating toolbar Line spacing split button drop down matches the sidebar Paragraph Content panel Line spacing--both done with the ref'd commits.

But the Format -> Paragraph Dialog Line Spacing .UI stanza is using different code--which seems disjoint from the toolbar/sidebar widget.

Different list of line spaces to select and the units seem to be disconnected between the two .UI configurations. Notable on the 4.4.0 Beta builds where spacing units are in pt. rather than the inches set in sidebar (en-US defaults). Or even if changed to mm units.

http://opengrok.libreoffice.org/xref/core/cui/uiconfig/ui/paraindentspacing.ui for the dialog (Format -> Paragraph) vs.
http://opengrok.libreoffice.org/xref/core/svx/uiconfig/ui/paralinespacingcontrol.ui for the buttons (toolbar & sidebar).
Comment 5 QA Administrators 2015-12-20 16:13:52 UTC Comment hidden (obsolete)
Comment 6 RGB 2016-10-02 08:52:36 UTC
The bug is still present on 5.1, 5.2 and master (5.3 alpha)

How to reproduce the problem:

1- on a Writer document, right click on a paragraph → Paragraph → Indents and spacing tab → set the Line spacing as "Fixed" → set the value to, say, 0.6cm

2- go to the sidebar → Properties tab → Paragraph deck → open the "Line spacing" drop down menu → you'll see under "custom value" 0.34cm

The paragraph formatting is right, but the sidebar is completely wrong.
Comment 7 RGB 2016-10-02 09:04:32 UTC
Forgot to mention: the "Set Line Spacing" button on the Format toolbar shows the same problem.
Comment 8 RGB 2016-10-20 21:15:37 UTC
Considering how bad the behaviour is (they show roughly the 57% of the real value), I think that *disabling* both, the sidebar and the toolbar line spacing button should be considered, at least until this problem get fixed.
Comment 9 Xisco Faulí 2017-07-13 11:18:41 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 10 V Stuart Foote 2018-06-02 01:38:32 UTC
*** Bug 117965 has been marked as a duplicate of this bug. ***
Comment 11 QA Administrators 2019-06-03 02:49:05 UTC Comment hidden (obsolete)
Comment 12 V Stuart Foote 2019-06-03 12:45:47 UTC
This remains an issue on current master/6.4.0alpha0

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 88f48b51f3cf25c78db278499d46d4913ab442ed
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

All of the indent and paragraph spacing values in the Sidebar look to have some rounding issues for the value being shown. 

But the line spacing when set "Fixed" seems to have the wrong conversion formula, as was reported in the dupe bug 117965

Seems worse if you change to a measuring unit diff from locale, and using Points to measure makes it obvious.

@Jim R. its old, but you might find this of interest.
Comment 13 Jim Raykowski 2019-06-09 19:32:18 UTC
Hi all, here is a patch that seems to fix this bug -

https://gerrit.libreoffice.org/#/c/73737/
Comment 14 Commit Notification 2019-07-05 03:53:56 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/849b837d1a3b185a8dd893a8f6eaed53605bcab1%5E%21

tdf#83618 Make line spacing values agree

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 V Stuart Foote 2019-10-04 23:10:32 UTC
*** Bug 127943 has been marked as a duplicate of this bug. ***
Comment 16 V Stuart Foote 2019-10-04 23:12:22 UTC
@Jim, any chance of a backport to 6.3?
Comment 17 Jim Raykowski 2019-10-05 06:19:51 UTC
(In reply to V Stuart Foote from comment #16)
> @Jim, any chance of a backport to 6.3?

Hi Stuart,
I'm not very knowledgeable about backporting. I think Xisco is the expert with that.
Comment 18 Xisco Faulí 2019-10-06 10:35:18 UTC
(In reply to Jim Raykowski from comment #17)
> (In reply to V Stuart Foote from comment #16)
> > @Jim, any chance of a backport to 6.3?
> 
> Hi Stuart,
> I'm not very knowledgeable about backporting. I think Xisco is the expert
> with that.

Done -> https://gerrit.libreoffice.org/#/c/80314/
Comment 19 Commit Notification 2019-10-08 09:20:47 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/fe3c08b5905a837cb63f57cefc8e43787c96b9c6

tdf#83618 Make line spacing values agree

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.