Download it now!
Bug 83712 - EDITING: FEATURE-REQUEST: down-arrow on last line should move to end of line
Summary: EDITING: FEATURE-REQUEST: down-arrow on last line should move to end of line
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 132295 (view as bug list)
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2014-09-10 12:54 UTC by Eyolf Østrem
Modified: 2020-04-29 14:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyolf Østrem 2014-09-10 12:54:50 UTC
Problem description: 
When the cursor is on the last line of a document, down-arrow should move it to the end of the line, and correspondingly up-arrow to the beginning of the line on the first line of the document.
This is how many(/most?) other editors work, and it is a good feature. I cannot think of a situation where that behaviour would be a disadvantage, and even though one can get there with end/home, it is more practical to have it on the same key, especially since the home/end keys are far removed from the arrow keys on some keyboards.

Operating System: All
Version: 4.3.1.2 release
Comment 1 Cor Nouws 2014-09-10 14:10:41 UTC
Hi Eyolf,

Thanks for the issue - I see no objection 
(but for me, no advantage too, to be honest).

> New & cheers,
Cor
Comment 2 Eyolf Østrem 2014-09-10 14:15:50 UTC
It's purely for convenience - but if one spends a lot of time in front of a Writer window, it's those little conveniences that matter. 
I might also add that a similar bug/feature re[port|quest] that I filed with KDE's editor Kate in 2006 has now finally been implemented! Even before that, I filed the same issue with OpenOffice, and never heard a word, other than "That's a silly request!"
So thanks for the positive reception!
Comment 3 Dieter 2020-04-28 06:51:20 UTC
*** Bug 132295 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2020-04-28 12:46:00 UTC
This is actually a rather bad idea--a special movement detecting 'last line of last paragraph'.

Modifying the <Down> cursor's current action, uno:goDown (labeled "To line below"), with additional logic when positioned on the last line of the document, would require it be checked on each usage.

IMHO unnecessary as the <End> key already is assigned the uno:goToEndOfLine action and functions on any line of document.

Also, we provide a specific uno:goToParagraphEnd "To Paragraph End", that while unassigned can be user customized for use as a keyboard shortcut--as a movement applicable within any paragraph, not just the last line of the last paragraph.

=> WF
Comment 5 Dan 2020-04-28 12:51:44 UTC Comment hidden (no-value)
Comment 6 V Stuart Foote 2020-04-28 12:59:41 UTC Comment hidden (no-value)
Comment 7 Heiko Tietze 2020-04-29 14:40:32 UTC
True, editors do this. But for what reason? And I don't see any use case like "I want to select the full paragraph" (which is solved by the extra command). So cuncur with Stuart's WF.