Bug Hunting Session
Bug 83922 - Frames not transparent
Summary: Frames not transparent
Status: RESOLVED DUPLICATE of bug 84294
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-16 10:05 UTC by mic.courriel
Modified: 2014-11-11 12:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mic.courriel 2014-09-16 10:05:08 UTC
- lors de l'utilisation de cadre, le fond (background) reste blanc et non-transparent quand "aucun remplissage" est selectionné.

- Quand une couleur est selectionnée en background avec une transparence à 100%, le cadre est transparent à l'écran, mais devient non-transparent lors de la création d'un PDF.
(Quand une couleur est selectionnée avec une tranparence (99% par exemple),
le cadre est transparent à 99%, à l'écran et à l'export pdf)
Comment 1 Julien Nabet 2014-09-16 21:01:43 UTC
reporter: bugs must be described in English.

Quick translation:
During frame using, the background stays white and non transparent when "no filling" is selected.

When a color is selected for background with a transparency to 100%, the frame is transparent at the screen display, but becomes non transparent when exporting to PDF
(When a color is selected with a transparency (eg 99%), the frame is transparent at 99% at the screen display and during export).
Comment 2 Julien Nabet 2014-09-16 21:02:39 UTC
mic: Just to be sure, the transparency disappear during export processing or when you open the created pdf?
Comment 3 mic.courriel 2014-09-17 12:39:54 UTC
- When 'no color' is selected, there is no transparency (white background) at display and at the opening of the pdf (acrobat 10 and pdfXchange Viewer)
- When a color is selected with 100% transparency, the screen display the frame with 100% transparency but at the pdf opening there is no transparency
- When 90% of transparency is selected,
There is no problem, background at 90% at display and at pdf opening.

Thanks for your reply and sorry for m'y english!


bugzilla-daemon@freedesktop.org a écrit :
>https://bugs.freedesktop.org/show_bug.cgi?id=83922
>
>--- Comment #2 from Julien Nabet <serval2412@yahoo.fr> ---
>mic: Just to be sure, the transparency disappear during export
>processing or
>when you open the created pdf?
>
>--
>You are receiving this mail because:
>You reported the bug.
Comment 4 Julien Nabet 2014-10-14 20:08:03 UTC
Thank you Mic for your feedback.
I don't use frames so I can't help here and let other people to give it a try.
Comment 5 Paddy Landau 2014-10-29 21:09:00 UTC
This appears to have been fixed in the forthcoming version 4.4 alpha.
Comment 6 Timur 2014-11-11 12:42:33 UTC
With the example: https://bugs.freedesktop.org/attachment.cgi?id=108358 from Bug 85409 problem reproduced with LO 4.3.3 in Windows and Linux, so I change Hardware to All. Cannot be reproduced with LO 4.2. Cannot be reproduced with LO 4.4.0 master. 

Seems that this Bug 83922 (PDF export of frames, explained), Bug 84294 (PDF export of frames, bibisected, proper example), Bug 85409 (PDF export of frames, example) and probably also Bug 83963 (PDF export and transparency of text fields, explained, bibisected, example) are the same. 
Since it cannot be reproduced with LO 4.4.0 master, https://bugs.freedesktop.org/show_bug.cgi?id=84294#c8 suggests when it might've been fixed. 
While in 4.2 and 4.3 on right click there is Frame-Background, in 4.4 there is Frame-Transparency. Question is: can the fix be backported to 4.3?
Comment 7 Timur 2014-11-11 12:52:58 UTC

*** This bug has been marked as a duplicate of bug 84294 ***