Bug Hunting Session
Bug 83963 - PDF export from LibreOffice is not able to handle transparency of text fields (100% is wrong, 99% works...)
Summary: PDF export from LibreOffice is not able to handle transparency of text fields...
Status: RESOLVED DUPLICATE of bug 84294
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-09-17 06:04 UTC by Karel Hruska
Modified: 2015-12-15 11:03 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Source file for export (15.70 KB, application/vnd.oasis.opendocument.text)
2014-09-17 06:04 UTC, Karel Hruska
Details
Exported PDF without additional settings (broken) (11.41 KB, application/pdf)
2014-09-17 06:05 UTC, Karel Hruska
Details
Exported PDF, type PDF/1A (text converted to image because of transparency) (301.91 KB, application/pdf)
2014-09-17 06:06 UTC, Karel Hruska
Details
Printed text field with transparent background (601.25 KB, image/jpeg)
2014-10-08 12:45 UTC, Karel Hruska
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karel Hruska 2014-09-17 06:04:40 UTC
Created attachment 106404 [details]
Source file for export

A text field with transparent background created in LibreOffice Writer is exported to PDF without transparency. E. g. a text field with white background colour set to 100% transparency is exported as a text field with white background.
Comment 1 Karel Hruska 2014-09-17 06:05:24 UTC
Created attachment 106405 [details]
Exported PDF without additional settings (broken)
Comment 2 Karel Hruska 2014-09-17 06:06:23 UTC
Created attachment 106406 [details]
Exported PDF, type PDF/1A (text converted to image because of transparency)
Comment 3 Karel Hruska 2014-09-17 06:10:36 UTC
I did a bibisection with following result:

pushkin@pushkin-VBX:~/LO_bug/bibisect-43all$ git bisect good
9d57c189d74551d2b3770cc81139ea10a62e672f is the first bad commit
commit 9d57c189d74551d2b3770cc81139ea10a62e672f
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon May 12 05:19:54 2014 +0000

    source-hash-5b5e62650354788e50b44f32c22b687b2018aba9
    
    commit 5b5e62650354788e50b44f32c22b687b2018aba9
    Author:     Stephan Bergmann <sbergman@redhat.com>
    AuthorDate: Fri Mar 28 15:22:57 2014 +0100
    Commit:     Stephan Bergmann <sbergman@redhat.com>
    CommitDate: Fri Mar 28 15:23:09 2014 +0100
    
        Remove remaining DBG_CTOR etc. remnants from chart2
    
        Change-Id: Iaf07f77b4228d4debb2620625b14ce7dc41e3a98

:100644 100644 9506902c6a27010b21fa60db2785cf8c6a99663b b7caf44d24c70027187d09beb9d1a84d3c2251d5 M	ccache.log
:100644 100644 f131bc060e8059666f8d7f3d448a0a6b8e1df7e4 67e626a238104bf7e45c40698e0e7cc28a4cd98c M	commitmsg
:100644 100644 5db1c1712e795b3ab96960366a53cf84ae3d8bca e6b0918bbb842858c3ad70bde38bc555a88e1bf0 M	make.log
:040000 040000 6dbe8a26ebf7cb34dc34ce783aa54092c2e9e5ed 0be05708421a37d2d8695098f2569749e3ed39de M	opt


During the bibisection I also noticed, that the appearance of the text field in LO differed in broken versions (sometimes it did not show up transparent, sometimes it showed up with wrong colour). Maybe this is also related to this bug...
Comment 4 Jean-Baptiste Faure 2014-09-21 20:34:47 UTC
I can confirm the problem and the regression:
- works as expected in version 4.2.7.0.0+
- does not work in version 4.3.3.0.0+
- in master it is possible to get a correct pdf export but the frame parameters must be modified because of a different color palette and a different background filling management.
Each versions built at home under Ubuntu 14.04 x86-64.

Best regards. JBF
Comment 5 Cor Nouws 2014-09-30 06:29:20 UTC
Maybe add this one to the MAB?
Also, I see some more ODF/transparency PDF-export problems - not looked at this thoroughly though.
Comment 6 Karel Hruska 2014-10-08 12:45:32 UTC
Created attachment 107555 [details]
Printed text field with transparent background

I have bad news - this problem appears while printing transparent text fields, too. As an attachment I have added a photo of a document with transparent text field and its printed version - the transparency is replaced by black background.

OS: Debian Wheezy
Architecture: amd64
LibreOffice version: 4.3.2.2
Printer: Canon iR1020
Driver:	Canon iR1020/1024/1025 UFRII LT ver.2.2 (grayscale, 2-sided printing)
Printed via CUPS 1.5.3

Sorry for the quality, I have only my phone here...

Regards,
Karel Hruska
Comment 7 Joachim Wiedorn 2014-10-18 10:49:53 UTC
my Version: 4.3.2.2 on GNU/Linux Debian

I have tested this problem and found: Export to PDF or printing uses the transparency value only from 1% to 99%. But with 100% suddenly no transparency will be exported.

Workaround: instead of 100% use only 99% and all is o.k.
Comment 8 tommy27 2014-10-18 11:44:59 UTC
so let's set status to NEW
Comment 9 Cor Nouws 2014-10-18 12:36:55 UTC
thanks for the workaround Joachim!
Comment 10 Karel Hruska 2014-10-19 06:57:01 UTC
Hi,
thanks for hint, but this is a pretty ugly solution. I have tons of old documents with "transparency" - just because in previous versions of LibreOffice there was an option "no backgroud" of text fields, which is now interpreted as 100% transparency. I can't check each document before printing or PDF export for the presence of such a setting and change each text field to 99 per cent transparency.

Regards,
Karel Hruska

(In reply to Joachim Wiedorn from comment #7)
> my Version: 4.3.2.2 on GNU/Linux Debian
> 
> I have tested this problem and found: Export to PDF or printing uses the
> transparency value only from 1% to 99%. But with 100% suddenly no
> transparency will be exported.
> 
> Workaround: instead of 100% use only 99% and all is o.k.
Comment 11 tommy27 2014-10-19 07:37:46 UTC
@Karel Hruska
so you should consider downgrading to LibO 4.2.6.3 which is the stable branch and wait until the bug will be fixed in the LibO 4.3.x branch.

hopefully thank to your bibisect a bugfix could be worked out.
I put Bjoern Michaelsen on CC List to hear if he can do something.
Comment 12 Timur 2014-11-11 12:45:45 UTC
Seems that Bug 83922 (PDF export of frames, explained), Bug 84294 (PDF export of frames, bibisected, proper example), Bug 85409 (PDF export of frames, example) and probably also Bug 83963 (PDF export and transparency of text fields, explained, bibisected, example) are the same. 
I think that all except Bug 84294 may be marked as duplicates.
Since it cannot be reproduced with LO 4.4.0 master anymore, https://bugs.freedesktop.org/show_bug.cgi?id=84294#c8 suggests when it might've been fixed. 
While in 4.2 and 4.3 on right click there is Frame-Background, in 4.4 there is Frame-Transparency. Question is: can the fix be backported to 4.3?
Comment 13 Timur 2014-12-01 18:26:10 UTC
Feel free to reopen if not correct.

*** This bug has been marked as a duplicate of bug 84294 ***
Comment 14 Robinson Tryon (qubit) 2015-12-15 11:03:39 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]