Bug Hunting Session
Bug 85409 - Transparent background of Frame prints as white, covering background images
Summary: Transparent background of Frame prints as white, covering background images
Status: RESOLVED DUPLICATE of bug 84294
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-10-24 16:07 UTC by Paddy Landau
Modified: 2014-11-11 12:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with transparent frame, and resulting PDF. (216.12 KB, application/zip)
2014-10-24 16:07 UTC, Paddy Landau
Details
Zip with odt file and wrong pdf result (1.30 MB, application/zip)
2014-10-29 19:05 UTC, libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paddy Landau 2014-10-24 16:07:46 UTC
Created attachment 108358 [details]
Sample document with transparent frame, and resulting PDF.

A frame with a transparent background prints with a white background, covering the images and text underneath it.

This previously worked correctly at least until 16 June 2014 (I know because of files that I created and printed then), but has been erroneous since at least 16 August 2014, if not before.

How to duplicate:

1. Create a Writer document containing an image and other items.
2. Create a frame to overlay the items. The wrap will need to be set to "Through".
3. Add text to the frame.
4. Make the frame's background transparent: either "White" with 100% transparency, or "No Fill".
5. Print the document, to either paper or PDF.

What happens:

* The frame has a white background, hiding the underlying image and other items.

What should happen:

* The frame's background should be invisible, with only its text being printed, and the underlying items visible.

Attached: Sample document containing an image, some text, and a rectangle, with a transparent frame containing text and partially covering them. Also the resulting PDF.
Comment 1 Terrence Enger 2014-10-26 03:50:43 UTC
I am unable to reproduce the problem either by "Export directly as
PDF" or menu option File > "Export as PDF...".  I tried Writer
versions daily dbgutil bibisect repository version 2014-10-25 running
in a chroot environment to debian-sid, and

    Version: 4.4.0.0.alpha1+
    Build ID: 04ea7b24ec1b5a027efa0b850f2bc3ac7116c52e
    TinderBox: Win-x86@39, Branch:master, Time: 2014-10-25_08:36:56

running on Windows Vista SP2.
Comment 2 Paddy Landau 2014-10-26 12:54:43 UTC
I have downloaded the prerelease version 4.3.3.1, and unfortunately still the same result.

I tried to find the alpha 4.4 version, but I didn't find one suitable for Ubuntu (I don't know how to compile the source). If you know where I can get a .deb for version 4.4, please let me know and I'll try it.

I tested this on a Windows 7 computer with LibreOffice version 3.2.2. I get the same (incorrect) results, which means that it is not just Linux.
Comment 3 Paddy Landau 2014-10-29 16:41:11 UTC
I finally found version 4.4 and installed it. I'm pleased to find that the bug has been fixed in the development version (I hope it remains fixed!).
Comment 4 libreoffice 2014-10-29 19:05:39 UTC
Created attachment 108644 [details]
Zip with odt file and wrong pdf result
Comment 5 Timur 2014-11-11 11:35:56 UTC
Reproduced with LO 4.3.3 Cannot be reproduced with LO 4.2, so added keyword "regression". Cannot be reproduced with LO 4.4.0 master. 
While in 4.2 and 4.3 there is Frame-Background, in 4.4 there is Frame-Transparency.
@libreoffice@abccorsicad.it: you didn't specify which LO version you used

I suggest this be marked as duplicate of Bug 83922, because it's earlier and has better explanation.
Comment 6 Timur 2014-11-11 12:43:18 UTC
Correction: 
Seems that Bug 83922 (PDF export of frames, explained), Bug 84294 (PDF export of frames, bibisected, proper example), Bug 85409 (PDF export of frames, example) and probably also Bug 83963 (PDF export and transparency of text fields, explained, bibisected, example) are the same.
Comment 7 Timur 2014-11-11 12:53:59 UTC

*** This bug has been marked as a duplicate of bug 84294 ***