Bug 84198 - UI: make document modified status more obvious -- status bar
Summary: UI: make document modified status more obvious -- status bar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Windows (All)
: lowest enhancement
Assignee: Not Assigned
URL: http://ux.stackexchange.com/q/41038
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Statusbar
  Show dependency treegraph
 
Reported: 2014-09-22 19:34 UTC by pb
Modified: 2019-03-12 14:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pb 2014-09-22 19:34:21 UTC
Problem description: 

Current behavior:

Tiny asterisk in status bar, hardly evident to the casual user

Expected behavior:

Something better.

I would suggest an asterisk, or double asterisk in the program title bar.  This would have several benefits over the current method:

1.  When it changes, it is large enough that peripheral vision will notice a flicker and therefore a naive user will become aware that there is such an indicator, and any user is more likely to notice that either he needs to save his document, or else that he accidentally unintentionally changed something.

2.  Because, at least in Windows, the title bar is propagated to the task bar, it would be evident that there is unsaved work even if the document is minimized or otherwise not visible.

Currently, the visibility of this indicator also depends on screen size and resolution.  Maybe on a low res screen it is more evident.  Not on my high-res screen.

So, another alternative is a LARGE indicator in the status bar.  On my screen the indicator asterisk is 5x5 pixels, which is approximately 1mm in diameter on a screen I am sitting about 1 meter away from.

I'm aware that there some concern about what 'modified' means, because it can also refer to view state in addition to document content, or even history.  IMHO, the 'modified' flag should relate to document content.  It is not even clear to me that view state should even be saved by default.  I'm a latecomer to this party, so this has probably been argued about ad infinitum and ad nauseum already.
              
Operating System: Windows 7
Version: 4.2.6.2 release
Comment 1 Adolfo Jayme 2014-09-23 05:19:54 UTC
Asterisks in title bars to indicate modifications are an obsolete convention and are nonstandard, even though many programs follow it.

Also, note that adding a flickering asterisk to the title bar would be redundant with the dot OS X adds to the Close Window button for the same purpose. 

> 2.  Because, at least in Windows, the title bar is propagated to the task
> bar, it would be evident that there is unsaved work even if the document is
> minimized or otherwise not visible.

Not in Windows 7’s and 8-8.1’s default configuration, where taskbar icons have no text.

> Currently, the visibility of this indicator also depends on screen size and
> resolution.  Maybe on a low res screen it is more evident.  Not on my
> high-res screen.
> 
> So, another alternative is a LARGE indicator in the status bar.  On my
> screen the indicator asterisk is 5x5 pixels, which is approximately 1mm in
> diameter on a screen I am sitting about 1 meter away from.

Then you should change your DPI settings, otherwise you won’t see many UI items, not only in LibreOffice but in many other programs.


This said, our existing statusbar icon can definitely be improved.
Comment 2 pb 2014-09-24 06:12:35 UTC
The big red X that appears in the menu bar when I start typing into a cell is about 3.5 x 3.5 mm on my screen, about 18x18 pixels.  It is huge.  I don't think I need to adjust my dpi settings.  I do, however, think that the 1 x 1 mm asterisk that denotes that a document needs to be saved deserves a size at least as big as that big red X for cancelling an entry, something that pretty much anyone would guess could be done by hitting the ESC key.  (Granted, perhaps that big red X is useful if you don't know you entered something, e.g. by accident when you thought something else had focus.)

One might also ask why the big red X for cancelling an entry is in the menu bar, while the tiny red asterisk for saving the document (or at least reminding the eagle-eyed user to do so) is in the status bar.  That seems inconsistent.

BTW, the dot pitch of the monitor in question is 0.27 /mm, which implies a dpi of about 94 dpi.  The Windows dpi is set at 100% for what the OS correctly believes that monitor to be, which it calls 96 dpi.  This yields good results for almost all applications.  (BTW, my claims of size of stuff on the screen are from direct measurement with a ruler so are approximate.  One could make them more exact with the value of about 1/0.27 = 3.7 dots per mm, though it gets tricky depending on dot layout.)
Comment 3 matthias sweertvaegher 2015-01-01 11:36:43 UTC
Hi, as a testament that the document modified status needs to be made more obvious, I can tell you I had to google for it to know where/what to look for. Luckily first hit is this bug report :)

So yeah, I don't really care how, but definitely please do something about this. Personally I never really cared much until my parents asked me how they can know the document is modified. So I had to come with an answer, right? ;) Most people have indeed the reflex to look at the titlebar for .. 'something', but if you know of a better mechanism that is as discoverable, please go ahead.

cheers
matthias
Comment 4 iyosifov 2017-07-04 10:52:55 UTC
Three years later, I also found this bug through google. 

Dear people, how about just going with the asterisk ???

It will help actual users with a real problem, today. Windows still has window titles in every configuration. It should take 5 minutes and 5 lines of code, that can be trivially reverted, if you come up with a much better fix, which, in the last 3 years, you haven't!
Comment 5 Thomas Lendo 2018-09-22 21:03:02 UTC
Adding keyword needsUXEval as I don't see a concrete way to fix this bug in the existing comments.
Comment 6 Heiko Tietze 2019-03-12 10:04:36 UTC
The status is shown in the title bar, the status bar, and on the save icon. We think it's enough, see bug 121814 comment 2.
Comment 7 ybeltukov 2019-03-12 12:37:42 UTC
(In reply to Heiko Tietze from comment #6)
> The status is shown in the title bar, the status bar, and on the save icon.
> We think it's enough, see bug 121814 comment 2.

I do not see the status in the title bar, my version is 6.2.1.2 on Linux. Should I apply some option or switch to another version?
Comment 8 Heiko Tietze 2019-03-12 14:32:19 UTC
(In reply to ybeltukov from comment #7)
> I do not see the status in the title bar...

Right, IIRC we removed that in favor of the other properties.