Bug Hunting Session
Bug 84603 - Can't install 4.3.2 on Win 7 - object already exisits error message caused by MS KB2918614
Summary: Can't install 4.3.2 on Win 7 - object already exisits error message caused by...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 84869 (view as bug list)
Depends on:
Blocks: Win-Installer-MAB
  Show dependency treegraph
 
Reported: 2014-10-02 16:15 UTC by Norbert Richter
Modified: 2014-12-13 14:39 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Installation window with error message (70.70 KB, image/jpeg)
2014-10-02 16:15 UTC, Norbert Richter
Details
System details Win 7 (84.66 KB, image/jpeg)
2014-10-04 12:48 UTC, Norbert Richter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Richter 2014-10-02 16:15:44 UTC
Created attachment 107230 [details]
Installation window with error message

I used LO 4.3.1. When installing 4.3.2.2 the Installer works with "Registering Components" and gives the Errormessage "Object is already existing". No more Information which object. Installation aborts. When I try to install the version before, the same error.
What can I do?
Comment 1 Jacques Guilleron 2014-10-02 17:09:22 UTC
Hi Norbert,

I presume you are under Windows 7. If not, please precise.
If your previous version was not uninstalled, begin by that.
Try to rename your profile: 
https://wiki.documentfoundation.org/Documentation/UserProfile#Resetting_the_User-Profile
and install again LO 4.3.2.2
Does this work?

Jacques
Comment 2 Norbert Richter 2014-10-04 12:46:35 UTC
(In reply to Jacques Guilleron from comment #1)
> Hi Norbert,
> 
> I presume you are under Windows 7. If not, please precise.
> If your previous version was not uninstalled, begin by that.
> Try to rename your profile: 
> https://wiki.documentfoundation.org/Documentation/
> UserProfile#Resetting_the_User-Profile
> and install again LO 4.3.2.2
> Does this work?
> 
> Jacques

Hi Jacques,
thank you for helping, merci!
My System is Windows 7 Professional, latest Updates (see Attachement "system-screenshot").
I renamed the ...roaming\libreoffice\4 directory to "2014", but the installation aborts as before (see attachement)
The history:
I installed LO 4.3.2 without deinstallation of the older 4.3.1. The updates before worked perfect without deinstallation.
When I got the Installation-Error-Message, I checked for the older version. At this time was no LO installed, only the helppack. So I deinstalled the helppack and tried again. Same error. Then I tried to install the older version 4.3.1, same error.
Now I try to install the 4.2.6-secfix: same problem!!
Comment 3 Norbert Richter 2014-10-04 12:48:43 UTC
Created attachment 107320 [details]
System details Win 7
Comment 4 Jacques Guilleron 2014-10-10 12:50:02 UTC
*** Bug 84869 has been marked as a duplicate of this bug. ***
Comment 5 Jacques Guilleron 2014-10-10 13:13:42 UTC
Since confirmed by mdekeyser in bug 84869, I set Status to NEW.

Regards,

Jacques
Comment 6 V Stuart Foote 2014-10-10 14:10:30 UTC
The "Object already exists" error message is likely being caused by a Microsoft security update done mid-August. Check system to see if KB2918614 ( http://support2.microsoft.com/kb/2918614 )was installed.  See the KB for Windows registry work around. 

-=For the average LibreOffice users=-
Simplest is to perform an uninstall of affected program being updated, LibreOffice in this case, and then do a fresh install. 

An uninstall/reinstall should not affect your LibreOffice per-user profiles recorded in %APPDATA%.

Or the security patch can be reverted--but then it won't do its job of protecting the MS Installer packages and database.


-=For the IT types=-
The uninstall(s) and reinstall(s) (with KB2918614 in place)  generates a SourceHash value in the Windows system registry for each MS installer package during installation--inclusion of that value allows any future MS installer actions for repair or upgrade.  Its absence is what is causing the issue (and why the uninstall & reinstall is needed for programs after the KB2918614 security patch is applied).

There is a mechanism for whitelisting described in the KB, and it is possible to generate a hash of all preexisting installer packages present on a system.

-=Refs=-
http://ccmexec.com/2014/09/kb2918614-windows-installer-triggers-uac/
http://happysccm.com/kb2918614-uac-gate/
Comment 7 Norbert Richter 2014-10-11 07:47:22 UTC
Great! It works!
I deinstalled the KB2918614, after that the Installation of LO 4.3.2.2 was running without errors.
What to do next? 
- reinstall the KB2918614
- delete the new ...roaming\libreoffice\4
- rename the old ...roaming\libreoffice\2014 to \4
- before installing the next LO-Update, deinstall the running LO
Is that right to do so?

Is it possible to integrate the deinstallation of an old version into the install-script?
Comment 8 V Stuart Foote 2014-10-11 18:48:20 UTC
@Andras, Jesus, Fridrich,*
(In reply to Norbert Richter from comment #7)
> 
> Is it possible to integrate the deinstallation of an old version into the
> install-script?

Any thoughts on how best to handle the MS KB2918614 security patch for our update install?  Anything we can do programatically in our packaging, an uninstall-reinstall?
Comment 9 Andras Timar 2014-10-11 19:36:29 UTC
I don't think we should change LibreOffice installer. It is only a temporary problem. As time passes by, everyone will have this security patch and solve the issue once with uninstall/reinstall. Then upgrades will work again. Comment 6 contains very useful instructions, that should be made widely available.
Comment 10 tommy27 2014-12-13 08:04:53 UTC
can anybody give an update of this bug status (still reproducible?) with LibO 4.3.4.1?
Comment 11 V Stuart Foote 2014-12-13 14:39:01 UTC
Setting resolved won't fix as OP was able to work around for MS KB2918614 as suggested comment 6, and we are not likely to adjust the MS installer packages to accommodate--as in comment 9