Download it now!
Bug 84647 - FILEOPEN: text flow parameters incorrectly set in .XLSX causing some labels to disappear
Summary: FILEOPEN: text flow parameters incorrectly set in .XLSX causing some labels t...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks: OOXML-Chart Chart-Labels
  Show dependency treegraph
 
Reported: 2014-10-04 03:20 UTC by Joey Reid
Modified: 2019-01-13 08:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Problem with Overlap and Break import settings with XLS on Left and XLSX on right (216.39 KB, image/png)
2014-10-04 03:20 UTC, Joey Reid
Details
Sample XLSX chart with missing labels (13.05 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-10-04 03:21 UTC, Joey Reid
Details
Same file but saved as XLS correctly imported (31.50 KB, application/vnd.ms-excel)
2014-10-04 03:22 UTC, Joey Reid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joey Reid 2014-10-04 03:20:34 UTC
Created attachment 107295 [details]
Problem with Overlap and Break import settings with XLS on Left and XLSX on right

When Calc imports Excel XLS charts, it correctly sets:
 
Text Flow:Overlap-enabled
Text FLow:Break-enabled

But for XLSX charts it sets

Text Flow:Overlap-DISABLED
Text FLow:Break-DISABLED

This causes visual data loss, as the labels disappear. In the screenshot, you can see every other label is missing in the XLSX file.
Comment 1 Joey Reid 2014-10-04 03:21:36 UTC
Created attachment 107296 [details]
Sample XLSX chart with missing labels
Comment 2 Joey Reid 2014-10-04 03:22:17 UTC
Created attachment 107297 [details]
Same file but saved as XLS correctly imported
Comment 3 tommy27 2014-10-05 07:52:28 UTC
confirmed under Win7x64 using 4.3.2.2 and 4.4.0.0.alpha0+
Build ID: 268b9c10c9ff27c74678ace99762f28d58d33012
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-02_23:35:24

it seems that 50% of the labels in the x axis are not shown

same issue even with older LibO release (tried with 3.4.3) and in AOO 4.1.0 as well so the bug is likely to be inherited from OOo
Comment 4 Adolfo Jayme 2014-10-11 17:11:08 UTC
Sushil Shinde committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4027bc476a1df9df1924447795ddc2d8b7744e20

fdo#84647 : Fixed default value for TickLableSkip value.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Joey Reid 2014-10-26 19:08:38 UTC
Steps to reproduce:
1. Create a chart in Excel with long label names (2 or more lines)
2. Save as .XLS and .XLSX
3. Open in Calc

When Calc imports Excel XLS charts, it correctly sets:
Text FLow:Break-enabled

But for XLSX charts it sets
Text FLow:Break-DISABLED

This causes as the labels in XLSX to overlap and makes them unreadable.
Comment 6 tommy27 2014-10-26 19:38:38 UTC
@Joey Reid  
have you tested that with recent 4.0.x daily builds? those are the only LibO versions featuring that bugfix
Comment 7 Joey Reid 2014-10-26 19:49:00 UTC
Tommy,
Yes, Sushil fixed the Text Flow:Overlap default. I verified that's it's working now with the latest 4.4 builds. Instead of messing up this report, I just now created Bug 85491 for the Text FLow:Break default.
Comment 8 Luke 2014-12-27 03:18:57 UTC
Sushil,
Should this bug report be reopened? In recent builds Text Flow:Overlap is not being set any more.
Comment 9 Sushil Shinde 2014-12-27 05:37:38 UTC
Hi Luke,

This issue was fixed in two parts,
1. https://gerrit.libreoffice.org/#/c/11901/
2. https://gerrit.libreoffice.org/#/c/12213/
Second patch is not yet merged to master. If possible, Please apply these patches and verify.
If this issue still reproducible then reopen it. I will look into it.

Thanks.
Comment 10 Joey Reid 2015-02-20 06:49:30 UTC
What's going on here? It was fixed perfectly with Sushil's patch, but now is broken again. We are back to using the wrong OOXML defaults for:

Text Flow:Overlap-enabled
Text FLow:Break-enabled

These incorrect values cause the every other label disappear. Could someone explain why we went back? Unless there's a good reason, could we please restore them? 

Since we're back to the using old bad values, I've reopened this bug.
Comment 11 Sushil Shinde 2015-02-20 07:37:09 UTC
I have merged two patches and resubmitted it.
Please review.
Link : https://gerrit.libreoffice.org/#/c/12213/
Comment 12 tommy27 2016-04-16 07:25:43 UTC Comment hidden (obsolete)
Comment 13 Joey Reid 2016-05-15 19:30:38 UTC
We are still ignoring the OOXML text flow parameters causing charts with long label names to render incorrectly.

Verified on: Version: 5.2.0.0.alpha1+
Build ID: 23ad336bfe61316b08f85e827b98fc593ac6908a
Comment 14 QA Administrators 2018-06-16 02:46:13 UTC Comment hidden (obsolete)
Comment 15 Luke 2018-08-09 05:03:44 UTC Comment hidden (obsolete)
Comment 16 Luke 2019-01-13 08:37:32 UTC
This report seems to be based on an incorrect assumption that there is an XML tag in the OOXML standard that maps to the ODF text flow parameter. There is no mapping for OOXML's automatic label settings. 

WFM in Version: 6.3.0.0.alpha0+ (x64)
Build ID: f548dfa29239913fd71be67eadc2905010cabd95

and WFM in Version: 6.1.1.2 (x64)
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b