Bug 84729 - CRASH on an EMF IMPORT
Summary: CRASH on an EMF IMPORT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other Windows (All)
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.4.0 4.3.4 bisected noRep...
Keywords: regression
: 85931 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-06 22:06 UTC by Mike Kaganski
Modified: 2014-11-14 19:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Problematic EMF (804.34 KB, image/x-emf)
2014-10-06 22:06 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2014-10-06 22:06:43 UTC
Created attachment 107447 [details]
Problematic EMF

The attached EMF crashes LO on opening.
More specifically: the crash occurs AFTER open on any UI interaction: mouse movement over any toolbar, or command invocation (say, Ctrl+Shift+S).

Tested under Win7x64
Already present on: LO 4.3.0.4
Still present on: 4.3.2.2
NOT REPRODUCIBLE on: Version: 4.3.0.0.alpha0+
Build ID: ecf22894f522374cbdb8196d3bdef88e2fba7af9
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-15_01:01:17
-> REGRESSION
Comment 1 Jean-Baptiste Faure 2014-10-07 04:55:31 UTC
No crash for me with Version: 4.3.3.0.0+
Build ID: d4a1b5dc8aff03718625d03ad3ea77750069e196 built at home under Ubuntu 14.04 x86-64
My tests: 
1/ opening the file itself: it opens in Draw without problem
2/ inserting the image in a new text document: no problem in Writer and Impress.

That said LO freezed when I double-clicked on the image once it was inserted in an empty presentation.

Best regards. JBF
Comment 2 V Stuart Foote 2014-10-07 17:13:56 UTC
Confirming regression, drawing of this EMF works correctly through the 4.2 builds up to 4.2.6.3

So, regression early in the 4.3 branch, need to bibisect against alpha0+ builds. Thus far none of the pre-alpha1 fare especially well with the EMF if inserted or opened including a 2014-04-09 TB 47 build Version: 4.3.0.0.alpha0+, ID 20fb1bfc72e626251b435bcff2339e1e425c7130

But, it was handled OK at 4.2 tag off from master, i.e. functions correctly with  initial version: 4.3.0.0.alpha0+ build
Build ID: e3b7e62b0dc34787f66c504230252b2c5edd18c3
TinderBox: Win-x86@39, Branch:master, Time: 2013-11-23_14:43:54

STR:
1. Open or insert attached EMF file in Draw
2. One or two zoom steps, then it closes.  

On the 4.2 builds, able to resize the EMF image with clean redraw.

Unable to capture much of a log, and WinDbg is being troublesome at the moment.
Comment 3 V Stuart Foote 2014-10-08 00:56:01 UTC
As expected OK on the 4.2.7.1 release,
Build ID: ad618ebe74a072c4ad8fae3b902f6ff1be98983d

Bibisect results from Windows installers of 4.3.0.0alpha0+ on hand--these could probably be refined down further on a Linux

http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=17a8b2ed7cff9dd11911cd3176679bf809a174d7..12ca5ec6f4485ab8c837d32eefdf39a2dda025a4

So, ~150 commits between 2014-01-15 and 2014-01-17

-=OK=-
Version: 4.3.0.0.alpha0+
Build ID: b32651febdaad5939250fb04f721d88952f54732
TinderBox: Win-x86@39, Branch:master, Time: 2013-11-26_00:09:34

Version: 4.3.0.0.alpha0+
Build ID: 8949d6f32acb9046cb3ddceb4f6fbe39dcc04383
TinderBox: Win-x86@39, Branch:master, Time: 2013-12-13_13:22:39

Version: 4.3.0.0.alpha0+
Build ID: be4035d00f37c492494fa7860955b6d0868c7f77
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-05_23:43:43

Version: 4.3.0.0.alpha0+
Build ID: 17a8b2ed7cff9dd11911cd3176679bf809a174d7
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-15_01:30:28

-=First Bad, showing consistent crash with manipulations of EMF=-

Version: 4.3.0.0.alpha0+
Build ID: 12ca5ec6f4485ab8c837d32eefdf39a2dda025a4
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-17_02:58:58

Version: 4.3.0.0.alpha0+
Build ID: 77637324abc193d831bb4a0fa6f9a91ef3601960
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-22_16:19:04

Version: 4.3.0.0.alpha0+
Build ID: a904aa609dddb80a44cf34a5e4299efe0dc2c49f
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-30_05:15:33
Comment 4 Chris Sherlock 2014-10-11 06:34:07 UTC
When I get a moment, I'll see what I can do.
Comment 5 V Stuart Foote 2014-10-12 05:51:17 UTC
A good chance that complex SVG files are also similarly affected--at least on Windows builds--have yet to fully parse things out. But, getting some instability in working with large SVGs that are otherwise stable through out the 4.2.x builds, but go flaky early in 4.3.0.0alpha0+ builds.

Will work on it but for anyone interested, for an example take a look at handling of SVG attachment 76676 [details] from bug 62461, SVG similar in complexity to the problem EMF here.
Comment 6 Chris Sherlock 2014-10-13 23:20:23 UTC
Reproduced. 

1. Open .emf file in Draw
2. Zoomed to 150%
3. Zoomed to 200%

It literally closes. No core dump as far as I can see, no stack trace.
Comment 8 V Stuart Foote 2014-10-25 14:57:05 UTC
@Caolán, *,
(In reply to Caolán McNamara from comment #7)
> fixed I bet with ...

Yes, very much better. Both the EMF and the SVG are much more responsive when manipulating. Draw, Writer and Impress are stable when resizing.  

Can actually have a document page with both the EMF and SVG images placed, the drawing and repaint is a little choppy (to be expected with this much vector detail to render, right?), but can reformat page and resize images.

On Windows 7 sp1, 64-bit en-US with
Version: 4.4.0.0.alpha1+
Build ID: 04ea7b24ec1b5a027efa0b850f2bc3ac7116c52e
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-25_08:36:56

@Mike K. would you please verify it is working correctly for you.
Comment 9 Mike Kaganski 2014-10-25 23:23:01 UTC
Thank you very much!
Comment 10 V Stuart Foote 2014-10-26 01:05:50 UTC
@Caolán, might be a good candidate to back port for 4.3.4 -- Stuart
Comment 11 Caolán McNamara 2014-10-28 13:37:17 UTC
I have it in 4.3, and are trying for 4.3.3 with https://gerrit.libreoffice.org/#/c/12088/
Comment 12 V Stuart Foote 2014-11-05 23:57:20 UTC
*** Bug 85931 has been marked as a duplicate of this bug. ***