Download it now!
Bug 85620 - Changing the label 'Gallery' and having it in the insert menu
Summary: Changing the label 'Gallery' and having it in the insert menu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:4.4.0
Keywords:
: 80545 (view as bug list)
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2014-10-29 21:01 UTC by Yousuf Philips (jay) (retired)
Modified: 2014-11-03 18:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-29 21:01:14 UTC
I think the clipart gallery should be renamed from 'Gallery' to either 'Clip Art Gallery' or 'Clip Art' and should be moved from Tools to Insert > Clip Art next to the Media entry.

Where other apps put and name it

Abiword : Insert > Clip Art
Word 2003 : Insert > Picture > Clip Art
WordPerfect : Insert > Graphics/Picture > Clipart
Comment 1 Cor Nouws 2014-10-29 21:31:24 UTC
Nice one - thanks!
Comment 2 Jean-Baptiste Faure 2014-10-30 08:57:58 UTC
I partially disagree because the gallery does not contains only pictures, but sounds and whatever the user want add in his own themes.
For backward compatibility it is important to have the word "gallery" in the new label.

That said I am disappointed when the effect of several changes in the UI are to produce uniformity between Office software. Please, give LibreOffice a strong personality instead of becoming a clone of other applications.

However, if you can make easier for newcomers to find the gallery and its possibilities, go ahead.
For example adding an entry "From the clipart gallery" in the submenu Insert > Picture.

Best regards. JBF
Comment 3 Yousuf Philips (jay) (retired) 2014-10-30 11:47:48 UTC
(In reply to Jean-Baptiste Faure from comment #2)
> I partially disagree because the gallery does not contains only pictures,
> but sounds and whatever the user want add in his own themes.
> For backward compatibility it is important to have the word "gallery" in the
> new label.

Yes i had forgotten that it does have a sound folder. So 'Clip Art Gallery' it is.

> That said I am disappointed when the effect of several changes in the UI are
> to produce uniformity between Office software. Please, give LibreOffice a
> strong personality instead of becoming a clone of other applications.

Well i only make UI change recommendations that i think are logical. Its logical to access the gallery from the insert menu as you are inserting a clip art, sound, etc. Which particular changes you were disappointed in?

> However, if you can make easier for newcomers to find the gallery and its
> possibilities, go ahead.
> For example adding an entry "From the clipart gallery" in the submenu Insert
> > Picture.

Well the picture submenu has been changed in 4.4, but will make suitable changes that i hope you will pleased with. :D
Comment 4 Yousuf Philips (jay) (retired) 2014-10-31 13:33:57 UTC
So here are my thoughts -

1) Add Insert > Clip Art Gallery
2) Move Gallery from Tools to View as View has other sidebar activated items (sidebar, navigator)
Comment 5 Jean-Baptiste Faure 2014-10-31 20:30:58 UTC
(In reply to Jay Philips from comment #4)
> So here are my thoughts -
> 
> 1) Add Insert > Clip Art Gallery
> 2) Move Gallery from Tools to View as View has other sidebar activated items
> (sidebar, navigator)

I like this proposition :-)

Best regards. JBF
Comment 6 Yousuf Philips (jay) (retired) 2014-10-31 21:42:05 UTC
Patch is in - https://gerrit.libreoffice.org/12167
Comment 7 Samuel Mehrbrodt (CIB) 2014-11-01 14:26:20 UTC
Shouldn't we put this also in the "Insert->Media" submenu?
Comment 8 Yousuf Philips (jay) (retired) 2014-11-01 14:57:48 UTC
With it being right before the submenu, there isnt a need to also have it in the submenu, unless we can change the name in the submenu to maybe 'sound gallery' and link it to the sound folder in the gallery sidebar. Is that possible?
Comment 9 Samuel Mehrbrodt (CIB) 2014-11-01 16:03:58 UTC
Oh I meant to put it in the submenu instead of above.

I wouldn't put a menu link to the sound folder since users can delete that folder.
Comment 10 Yousuf Philips (jay) (retired) 2014-11-01 17:18:33 UTC
I think both image and clip art shouldnt be placed in the submenu, as inserting an image is the 2nd most inserted element in a document, and we should be trying to make it easier for them to get to this highly used features.
Comment 11 Samuel Mehrbrodt (CIB) 2014-11-03 09:05:25 UTC
I agree that we should place Image not in the submenu - but I'm not sure about the clip art.
I don't have stats but I guess that few people use clip arts. Also the clip art is in the sidebar (which is visible by default in Writer and Impress).
Comment 12 Yousuf Philips (jay) (retired) 2014-11-03 13:36:24 UTC
*** Bug 80545 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2014-11-03 17:19:55 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7e4920419e4a7c791ad6becd39078f3814876003

fdo#85620 - Changing the label 'Gallery' and having it in the insert menu

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.