Bug 86138 - TOOLBAR: Context menu should state the name of the toolbar
Summary: TOOLBAR: Context menu should state the name of the toolbar
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Philippe Jung
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks: Context-Menu Calc-Toolbars
  Show dependency treegraph
 
Reported: 2014-11-11 03:57 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-22 20:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of new menu appearance (50.22 KB, image/png)
2015-05-12 11:38 UTC, Philippe Jung
Details
Updated screenshot (30.20 KB, image/png)
2015-05-13 14:31 UTC, Philippe Jung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-11 03:57:46 UTC
When you right-click on a toolbar there isnt any indication of what the name of the toolbar is. This could easily be fixed by having the name of the toolbar mentioned in the 'Close Toolbar' item.
Comment 1 Cor Nouws 2014-11-11 09:01:37 UTC
very good :)
Comment 2 Philippe Jung 2015-05-12 11:38:42 UTC
Created attachment 115521 [details]
Screenshot of new menu appearance
Comment 3 Yousuf Philips (jay) (retired) 2015-05-12 15:50:21 UTC
(In reply to Philippe Jung from comment #2)
> Created attachment 115521 [details]
> Screenshot of new menu appearance

I was thinking that instead of adding another entry to the context menu, we could add the toolbar name to one of the existing entries. For example, we can change 'Close Toolbar' to 'Close Standard Toolbar'.

What does the ux team think?
Comment 4 Adolfo Jayme Barrientos 2015-05-12 16:23:36 UTC
I prefer Philippe’s solution since it won’t make menus even wider, which is a huge issue in other languages.
Comment 5 Cor Nouws 2015-05-12 18:51:05 UTC
(In reply to Adolfo Jayme from comment #4)
> I prefer Philippe’s solution since it won’t make menus even wider, which is
> a huge issue in other languages.

Are you sure? Philippe's solution implies "close <NAME> toolbar" which is definitely wider then "<NAME> ..
Comment 6 Philippe Jung 2015-05-12 18:56:29 UTC
I think he prefers the solution from the screenshot :-)

We have:
- Title (bold, top of menu, coherent with left to right, top to bottom reader), read-only, defined as a menu title. 
or
- Modified label of close. Simple solution, few modifications. 

What I asked to Jay is what is the use case we want to face by adding toolbar name to contextual menu. This is what should drive the choice. 

What I understood, it is to avoid closing the wrong toolbar. So the information has to be visible, simply and quickly.
But it also has to be geographically close to the "Close action".
Comment 7 Philippe Jung 2015-05-13 14:31:34 UTC
Created attachment 115562 [details]
Updated screenshot

Patchset 3 pushed to gerrit.
This is the new appearance of the popup.

I reused an existing aTitleText defined with Menu::SetText

The title is painted on top of the menu. It is no longer a hacked MenuItem. It is bold, centered on a slightly darker background.
Comment 8 Commit Notification 2015-05-14 17:18:53 UTC
Philippe Jung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=415454cfbc6add8534e1dcff1ff16cc8dcc9296c

tdf#86138 Context menu should state the name of the toolbar

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Yousuf Philips (jay) (retired) 2015-05-15 21:48:50 UTC
Looks great Philippe.
Comment 10 Mike §chinagl 2015-05-21 16:21:19 UTC
This bug fix is mentioned in the release notes of the coming LibreOffice 5.0 (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0). Therefore it would be wonderful if this feature really worked well, otherwise it should not be mentioned in the release notes. In the notes it reads:

Toolbar’s context menus display the name of the corresponding toolbar. tdf#86138 (Philippe Jung)
Comment 11 Adolfo Jayme Barrientos 2015-05-21 21:41:03 UTC Comment hidden (off-topic)
Comment 12 Cor Nouws 2015-05-22 07:29:42 UTC Comment hidden (off-topic)
Comment 13 Mike §chinagl 2015-05-22 13:51:42 UTC Comment hidden (off-topic)
Comment 14 Julien Nabet 2015-05-22 14:33:24 UTC Comment hidden (off-topic)
Comment 15 Cor Nouws 2015-05-22 14:46:04 UTC Comment hidden (off-topic)