Bug Hunting Session
Bug 86185 - UI: Line Numbering "Format" dropdown list is blank
Summary: UI: Line Numbering "Format" dropdown list is blank
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha1
Hardware: All All
: medium major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.5.0 target:4.4.0.0.beta2 ta...
Keywords: bisected, regression
: 85955 86556 (view as bug list)
Depends on:
Blocks: Line-Numbering
  Show dependency treegraph
 
Reported: 2014-11-12 04:22 UTC by Kevin Suo
Modified: 2018-03-07 00:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-11-12 04:22:31 UTC
In Writer, Tools - Line Numbering - Format dropdown list is blank.

Win 7 X64

Broken in:
Version: 4.4.0.0.alpha2
Build ID: 24f0a5815f581dd9a7f09d30213a379edee6e9ac

Works OK in:
4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243
Comment 1 Kevin Suo 2014-11-12 04:28:28 UTC
Also reproduce in Linux, with lo-linux-dbgutil-daily updated today.
Comment 2 Kevin Suo 2014-11-12 04:40:07 UTC
785246df606966e83402647cc4923a4ea105a157 is the first bad commit
commit 785246df606966e83402647cc4923a4ea105a157
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Fri Oct 10 09:01:45 2014 +0200

    2014-10-10


$: /lo/lo-linux-dbgutil-daily$ git bisect log
# bad: [90a1c59acbcd8a2d11f6bf8d914af71fb558d849] 2014-11-05: source-hash-b7d8a58ff2698ffc6e22943f64aa97c5ea253bd9
# good: [b3130c846de5cf1b4be48b48dfc780bb369549fa] 2014-05-21
git bisect start 'master' 'oldest'
# good: [ba5b58a62db37685dbd283123bd62fbd2458f4c7] 2014-08-13
git bisect good ba5b58a62db37685dbd283123bd62fbd2458f4c7
# good: [cfa0d940ef43e42c4315a778e55d6e8b1dea6291] 2014-09-24
git bisect good cfa0d940ef43e42c4315a778e55d6e8b1dea6291
# bad: [671ac8dc45cb809092bcabfe76006eb0948ee081] 2014-10-15: source-hash-defa080e585fb351bc4049b2f280d2e7e5256f6e
git bisect bad 671ac8dc45cb809092bcabfe76006eb0948ee081
# good: [4d2047ed98f73c3d17ea2c003858a86c7c13d0e3] 2014-10-04
git bisect good 4d2047ed98f73c3d17ea2c003858a86c7c13d0e3
# good: [f4caa611c55114b6fb18422851535b4d921b25e4] 2014-10-09
git bisect good f4caa611c55114b6fb18422851535b4d921b25e4
# bad: [2b1d7230ae5464cd8cbfb5d4119ba05dc93a23e2] 2014-10-12
git bisect bad 2b1d7230ae5464cd8cbfb5d4119ba05dc93a23e2
# bad: [f74c7588b7c904a42918d844d67a58ca89430dec] 2014-10-11
git bisect bad f74c7588b7c904a42918d844d67a58ca89430dec
# bad: [785246df606966e83402647cc4923a4ea105a157] 2014-10-10
git bisect bad 785246df606966e83402647cc4923a4ea105a157


P.S. Why isn't there a source-hash for the first bad commit?
Comment 3 sophie 2014-11-12 09:47:56 UTC
*** Bug 85955 has been marked as a duplicate of this bug. ***
Comment 4 sophie 2014-11-12 09:49:27 UTC
Change the version, to reflect where it was first found - Sophie
Comment 5 Michael Stahl (CIB) 2014-11-25 20:56:59 UTC
regression from:

commit a2feb420fa547b89bff5e0c6f848e22f503e6602
Author:     Adolfo Jayme Barrientos <fitojb@ubuntu.com>
AuthorDate: Thu Oct 9 03:46:10 2014 -0500
Commit:     Caolán McNamara <caolanm@redhat.com>
CommitDate: Thu Oct 9 10:35:15 2014 +0000

    HIG: Miscellaneous improvements to Line Numbering dialog


... not sure what "<property name="type">16</property>" does but it's apparently important.
    
fixed on master.
Comment 6 Commit Notification 2014-11-25 20:57:33 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=617427806d0a1aa7d8b3f3a6977e7bc2a292e73b

fdo#86185: sw: Line Numbering dialog: fix "Format" combo box

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-11-25 20:59:46 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c0c857b5e10bd01fe2e53685539a9555087c802&h=libreoffice-4-4

fdo#86185: sw: Line Numbering dialog: fix "Format" combo box

It will be available in 4.4.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 sophie 2014-11-26 10:51:53 UTC
*** Bug 86556 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2018-03-07 00:42:37 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f480bda7a8ddc40da300d0faebda159cd94ac052

uitest - Writer Line Numbering dialog; tdf#86185 test

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.