Bug 86207 - Insufficient spacing and alignment of components in colour picker
Summary: Insufficient spacing and alignment of components in colour picker
Status: RESOLVED DUPLICATE of bug 84595
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: x86-64 (AMD64) Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-12 15:18 UTC by Gabriel Diosan
Modified: 2014-12-03 16:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Colour picker sreenshot showing insufficient spacing and alignment (137.74 KB, image/png)
2014-11-12 15:18 UTC, Gabriel Diosan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Diosan 2014-11-12 15:18:04 UTC
Created attachment 109350 [details]
Colour picker sreenshot showing insufficient spacing and alignment

The colour picker used for "Font Colour", "Highlighting" and "Background Colour" has insufficient spacing between certain elements resulting in an unpolished UI.

Steps to reproduce:

1. Open Libreoffice Writer.
2. Click on "Font Colour", "Highlighting" or "Background Colour" buttons.

Current Behaviour:

The colour picker opens but:

1. The palette dropdown is too close to the colour selection/grid.
2. There is insufficient spacing on the right margin resulting in an uneven appearance.

Expected Behaviour/suggested design:

1. Move the palette dropdown up slightly to provide more space between it and the colours grid.
2. Increase the margin on the right side of the colour picker by a few pixels to match the left side margin.

I have attached a screenshot showing the colour picker where the inconsistent spacing is visible. I believe with these minor changes the colour picker would have a more polished look.

Tested on Ubuntu 14.04.1 wth Libreoffice:

Version: 4.4.0.0.alpha2+
Build ID: 98f9baa5253f7bb8034f148519f31f548b1452fa
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-11-12_00:13:54
Comment 1 Adolfo Jayme 2014-11-12 15:51:58 UTC

*** This bug has been marked as a duplicate of bug 86159 ***
Comment 2 Yousuf Philips (jay) (retired) 2014-11-12 16:02:52 UTC
My bug was put as a duplicate of this one, but in it i've stated that this issue effects not only the color picker, but also the redo and undo drop downs.
Comment 3 Adolfo Jayme 2014-11-13 15:56:59 UTC
(In reply to Jay Philips from comment #2)
> My bug was put as a duplicate of this one

What????????????????

It was actually the other way around.
Comment 4 Yousuf Philips (jay) (retired) 2014-11-13 17:17:40 UTC
(In reply to Adolfo Jayme from comment #3)
> It was actually the other way around.

Yep i noticed that after i submitted it. :D
Comment 5 V Stuart Foote 2014-12-03 16:42:04 UTC
is a duplicate of bug 84595

*** This bug has been marked as a duplicate of bug 84595 ***