Bug 84595 - COLOR PICKER: 'Color Picker' button at bottom of dialog is cropped
Summary: COLOR PICKER: 'Color Picker' button at bottom of dialog is cropped
Status: RESOLVED DUPLICATE of bug 86159
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 86207 86561 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-02 12:23 UTC by tommy27
Modified: 2015-01-23 07:31 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
how the color picker button looks (20.29 KB, image/png)
2014-10-04 23:43 UTC, Yousuf Philips (jay) (retired)
Details
GNU/Linux screenshot of background colour dialog (16.62 KB, image/png)
2014-10-05 22:17 UTC, Owen Genat (retired)
Details
ColorPicker_Windows7sp1_64-bit_ATI_customVisualEffects (89.18 KB, image/png)
2014-10-24 20:08 UTC, V Stuart Foote
Details
ColorPicker_Windows7sp1_64-bit_ATI_bestPerformance (61.49 KB, image/png)
2014-10-24 20:10 UTC, V Stuart Foote
Details
Win8.1x64 screenshot 4.5.0.0 alpha (26.75 KB, image/png)
2014-12-03 03:10 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2014-10-02 12:23:26 UTC
under Windows the "color picker" text label at the bottom is badly displayed and almost cut in half. see attachment 107214 [details] 

compare with screenshot from Linux at attachment 107210 [details]

tested under Win7x64 screenshot with4.4.0.0.alpha0+
Build ID: faf99f6f405e076d5c9ab95c876ae1ffb896f8d1
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-26_09:41:28
Comment 1 V Stuart Foote 2014-10-03 14:27:27 UTC
@tommy27,

Any particular component, or steps to get to the Highlighting clip you show?

Where present in the UI thus far on color dialogs, the color picker button seems correctly structured other than lacking a bottom border. 

Does it improve if you set your Windows --> Systems Properties --> Advanced --> Performance --> Visual Effects tab to Adjust for best performance, and then add back GDI elements?

Seems OK for me on Windows 7 sp1, 64-bit en-US with
Version: 4.4.0.0.alpha0+
Build ID: 93f9451340957dae29a6b3ccec127a99a03ffd31
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-27_06:02:32

or later build,

Version: 4.4.0.0.alpha0+
Build ID: fc24eadc6283cd03397b70fda309a578ce295f16
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-03_00:31:27
Comment 2 tommy27 2014-10-03 17:18:54 UTC
still having issue with  4.4.0.0.alpha0+
Build ID: 268b9c10c9ff27c74678ace99762f28d58d33012
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-02_23:35:24 

I have tried to unflag multiple of those option but nothing changes the look of that color picker cut text
Comment 3 Yousuf Philips (jay) (retired) 2014-10-03 20:38:52 UTC
Hey tommy, this is a result of the popup moving downwards, as mentioned in bug 84572.
Comment 4 tommy27 2014-10-04 07:06:35 UTC
@Jay
the "color picker" text label at the bottom in Win7x64 is already cut even if I have no recent colors in the list.

moreover in your screenshot  attachment 107210 [details] (was it a Linux screenshot?) that text is correctly displayed.

so that color picker GUI seems to have some issues under Linux and other under Windows
Comment 5 Yousuf Philips (jay) (retired) 2014-10-04 23:43:42 UTC
Created attachment 107337 [details]
how the color picker button looks

(In reply to tommy27 from comment #4)
> @Jay
> the "color picker" text label at the bottom in Win7x64 is already cut even
> if I have no recent colors in the list.

@Tommy
Yes i was mistaken about it being pushed down similar to the other bug.

> moreover in your screenshot  attachment 107210 [details] (was it a Linux
> screenshot?) that text is correctly displayed.

Text is correctly displayed but button is chopped as in attached screenshot. It was the same for me on windows 7. So for me on Windows 7, i cant confirm that the text is chopped using either the Windows Classic or Windows 7 Basic themes. Which theme are you using?

> so that color picker GUI seems to have some issues under Linux and other
> under Windows

I havent seen any problems that were different on windows compared to linux.
Comment 6 tommy27 2014-10-05 06:56:30 UTC
I use Windows Classic (good old theme from Win98) on Win7x64 and tge vytt
are you using 64 bit or 32bit Win7?

my screenshot and yours are very different.

you miss scrollbar and have no chopped text at the bottom, whilst I have scrollbar and see chopped text. weird.
Comment 7 V Stuart Foote 2014-10-05 13:56:20 UTC
@tommy27,
(In reply to tommy27 from comment #2)
> I have tried to unflag multiple of those option but nothing changes the look
> of that color picker cut text

Use the Computer --> Properties --> Advanced System settings to launch the Windows System Properties dialog. There on the Advanced tab, select the Settings button in the Performance section--i.e. where visual effects. In the Performance options dialog that opens--on the Visual Effects tab--set the radio button to "Adjust for best performance"  Apply and OK out.

Any change in the LO Color Picker button with just this basic setting? 

If not, I would verify from Control Panel -->  Display, that your screen resolution is set at %100 and not %125 or %150.  You might also run through the ClearType Text Tuner, or see if simply turning off ClearType improves the LO Color Picker label issue on your GPU/monitor combination.

Stuart
Comment 8 tommy27 2014-10-05 14:27:26 UTC
(In reply to V Stuart Foote from comment #7)

> ... In the Performance options dialog that opens--on the Visual Effects tab--set
> the radio button to "Adjust for best performance"  Apply and OK out.
> 
> Any change in the LO Color Picker button with just this basic setting? 

no change at all. same issue at any setup I tried

> If not, I would verify from Control Panel -->  Display, that your screen
> resolution is set at %100 and not %125 or %150. 

resolution was already 100%
 
> You might also run through the ClearType Text Tuner, or see if simply turning off ClearType improves the LO Color Picker label issue on your GPU/monitor combination.
> Stuart

still no effect.
Comment 9 Yousuf Philips (jay) (retired) 2014-10-05 15:00:14 UTC
(In reply to tommy27 from comment #6)
> I use Windows Classic (good old theme from Win98) on Win7x64 and tge vytt
> are you using 64 bit or 32bit Win7?

Yes i prefer the classic look as well :D. I'm using 64-bit. You can see a windows screenshot with attachment 84676 [details], as attachment 107337 [details] was from linux.
Comment 10 Yousuf Philips (jay) (retired) 2014-10-05 15:00:55 UTC
My bad. The windows screenshot is attachment 107339 [details].
Comment 11 Owen Genat (retired) 2014-10-05 22:17:54 UTC
Created attachment 107382 [details]
GNU/Linux screenshot of background colour dialog

Taken under Crunchbang 11 x86_64 using v4.4.0.0.alpha0+ Build ID: 65277f994ae25d930c15aebba0ed19f8de0abba1 TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-09-29_19:47:20

It appears this problem is not O/S-specific. I thought the recent .ui widget changes for all dialogs fixed this type of cropping? It may relate to desktop environment settings. The indicated system is using Openbox window manager. I also note that there is is less space at the right side of the dialog (than the left) in both this screenshot and that taken from Windows.
Comment 12 Owen Genat (retired) 2014-10-05 22:22:55 UTC
As per comment 10 and comment 11, confirmed. Status set to NEW. Summary amended for clarity. Operating system set to All.
Comment 13 Yousuf Philips (jay) (retired) 2014-10-06 01:50:58 UTC
Changed summary as the cropping on the right which removes the scrollbar is in bug 84574.
Comment 14 Owen Genat (retired) 2014-10-10 22:30:02 UTC
(In reply to Jay Philips from comment #13)
> Changed summary as the cropping on the right which removes the scrollbar is
> in bug 84574.

It seems a separate issue to the scrollbar Jay. Have a look at attachment 107214 [details] (under Windows with scrollbar) and it can clearly be seen that the entire content of the dialog (separating lines, pull-down, swatches/scrollbar, and buttons) is closer to the right edge, than the left. In previous versions the spacing is equal down either side. It may need a new report.
Comment 15 Yousuf Philips (jay) (retired) 2014-10-11 07:11:53 UTC
(In reply to Owen Genat from comment #14)
> It seems a separate issue to the scrollbar Jay. Have a look at attachment
> 107214 [details] (under Windows with scrollbar) and it can clearly be seen
> that the entire content of the dialog (separating lines, pull-down,
> swatches/scrollbar, and buttons) is closer to the right edge, than the left.

As the scrollbar is on the right and it is being removed even in windows (attachment 107339 [details]), this bug can focus on increasing the height of the dialog and that bug can focus on increasing the width of the dialog.

From my windows and linux screenshots and your linux screenshot Owen, they all look quite similar in how much it is cropped at the bottom, while tommy's screenshot seems to be the odd one out. Stuart can you send in a screenshot on windows with the mouse over the button and let us know what theme your using.

> In previous versions the spacing is equal down either side. It may need a
> new report.

Which previous version was the spacing equal on both sides?
Comment 16 tommy27 2014-10-24 19:42:35 UTC
still cropper under Win7x64 using 4.4.0.0.alpha1+
Build ID: 6ba8b7f5eacac969e4781d63718083a05491b1bc
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-24_02:23:51
Comment 17 V Stuart Foote 2014-10-24 20:08:18 UTC
Created attachment 108366 [details]
ColorPicker_Windows7sp1_64-bit_ATI_customVisualEffects

button fully formed with current builds
Comment 18 V Stuart Foote 2014-10-24 20:10:05 UTC
Created attachment 108367 [details]
ColorPicker_Windows7sp1_64-bit_ATI_bestPerformance

As can be seen, the Widnows OS Graphics settings will impact the rendering of the button widget. Not sure there is anything that can be done when the OS graphics settings don't fully render elements.
Comment 19 Adolfo Jayme 2014-11-22 10:59:57 UTC
*** Bug 86561 has been marked as a duplicate of this bug. ***
Comment 20 tommy27 2014-12-03 03:10:26 UTC
Created attachment 110382 [details]
Win8.1x64 screenshot 4.5.0.0 alpha

retested with Version: 4.5.0.0.alpha0+
Build ID: f20043a0805c3a75eb4024ed59f45291aea93ac0
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-03_01:16:50

looks better now, anyway I wonder if that rainbow ball icon close to "custom color" is supposed to have a flat lower margin or if it's some kind of residual cropping.

could you show me your screenshots to compare?
Comment 21 Yousuf Philips (jay) (retired) 2014-12-03 15:11:40 UTC
I'm assuming this can be closed as a duplicate of bug 86159, as the cropping at the bottom and right are not only limited to the color picker.
Comment 22 V Stuart Foote 2014-12-03 16:42:04 UTC
*** Bug 86207 has been marked as a duplicate of this bug. ***
Comment 23 V Stuart Foote 2014-12-03 16:47:53 UTC
Resolving as duplicate of the inclusive "drop downs not having sufficient space on the right and bottom" issues of bug 86159

*** This bug has been marked as a duplicate of bug 86159 ***