Bug 86606 - CONTEXT MENU: Removal of remaining direct formatting entries
Summary: CONTEXT MENU: Removal of remaining direct formatting entries
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Yousuf Philips (jay)
QA Contact:
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2014-11-23 05:15 UTC by Yousuf Philips (jay)
Modified: 2016-10-02 17:22 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-11-23 05:15:43 UTC
Since the removal of 'Font', 'Size', and 'Alignment' went into effect with bug 81132, we now have a line spacing drop down added to the toolbar with bug 83076, as well as the addition of the strike through, superscript and subscript found in the 'Style' submenu also in the toolbar. So its useful to remove the 'Style' and 'Line Spacing' entries from Writer.

As bug 81132 only removed some of these direct formatting entries from Writer, it would be good to remove all of these entries from the other modules as well.
Comment 1 Yousuf Philips (jay) 2014-11-28 05:05:15 UTC
I also believe that 'Change Case' should also be removed.
Comment 2 Yousuf Philips (jay) 2014-11-30 00:18:15 UTC
Patch is in only for master - https://gerrit.libreoffice.org/#/c/13196/
Comment 3 Adolfo Jayme 2014-11-30 05:58:24 UTC
(In reply to Jay Philips from comment #0)
> it would be good to remove all of these entries from the other
> modules as well.

Good to you anyway… Where is the agreement? Or at least you data-driven design…
Comment 4 Yousuf Philips (jay) 2014-11-30 15:26:44 UTC
(In reply to Adolfo Jayme from comment #3)
> Good to you anyway… Where is the agreement? Or at least you data-driven
> design…

All the arguments were provided in bug 81132 and the reasoning for leaving the style and line spacing entries were that these didnt have toolbar entries at that time and the gradual reduction of these entries would give time for users to get used to it.

I will be submitting a patch for 4.4 for the removal of the same three entries removed in bug 81132 to be removed from other modules, so it is a consistent change across LO.
Comment 5 Yousuf Philips (jay) 2014-11-30 18:25:29 UTC
The alternative solution would be to create a direct formatting submenu that would contain all of these entries.

Paste Special >
- separator -
Direct Formatting >
   Font Name (this would still be broken if it is to be kept - bug 34085)
   Font Size
   Font Format
   Text Alignment
   Line Spacing
   - separator -
   Clear Direct Formatting

Maybe the font name issue could be solved by only listing a limited set of font names and the fonts used in the current document.
Comment 6 Commit Notification 2015-03-26 09:57:17 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2df3522a5159baa1c9d55e52adbfeba7eae76955

tdf#86606 remove direct formatting entries from context menu

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Yousuf Philips (jay) 2015-03-28 12:11:49 UTC
The idea to keep the direct formatting mentioned in comment 5 was rejected by the design team in one of its meetings.

https://wiki.documentfoundation.org/Design/Meetings/2014-12-03
Comment 8 Yousuf Philips (jay) 2015-04-12 07:51:21 UTC
Seems the issue hasnt been fully resolved as there are still direct formatting in context menus in Writer and Calc comments.
Comment 9 Yousuf Philips (jay) 2015-04-27 06:58:39 UTC
I've pushed a commit which i believe will solve the last remaining occurrences of direct formatting. https://gerrit.libreoffice.org/#/c/15547/

There seem to be direct formatting context menu entries in svx/source/form/formshell.src but i cant track down what it is used for.
Comment 10 David Tardon 2015-04-28 08:51:39 UTC
(In reply to Jay Philips from comment #9)
> There seem to be direct formatting context menu entries in
> svx/source/form/formshell.src but i cant track down what it is used for.

Probably for form controls.
Comment 11 Commit Notification 2015-04-28 08:52:49 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b0be6c0e9d23f1b8535ba7033732ae2e3bfb5c9

tdf#86606 Removal of additional direct formatting

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Yousuf Philips (jay) 2015-04-28 10:27:33 UTC
(In reply to David Tardon from comment #10)
> Probably for form controls.

I tried the context menu for form controls but didnt see anything there.
Comment 13 Mike §chinagl 2015-05-21 16:20:12 UTC
This bug fix is mentioned in the release notes of the coming LibreOffice 5.0 (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0). Therefore it would be wonderful if this feature really worked well, otherwise it should not be mentioned in the release notes. In the notes it reads:

All direct formatting entries were removed, as they are readily available in toolbars and the Sidebar. tdf#86606 (Yousuf Philips)
Comment 14 m.a.riosv 2016-10-01 21:44:15 UTC
*** Bug 100604 has been marked as a duplicate of this bug. ***
Comment 15 sworddragon2 2016-10-02 00:24:51 UTC
My ticket #100604 got marked as a duplicate of this fixed issue while my issue is still valid with LibreOffice 5.2.1.2. Maybe this discrepancy should be checked.
Comment 16 V Stuart Foote 2016-10-02 01:00:23 UTC
(In reply to sworddragon2 from comment #15)
> My ticket #100604 got marked as a duplicate of this fixed issue while my
> issue is still valid with LibreOffice 5.2.1.2. Maybe this discrepancy should
> be checked.

No discrepancy. Direct formatting has been removed from the default configuration of the context menu. The fact that the Clear Direct formatting remains active with <Ctrl>+M or from Format -> Clear Direct Formatting is *not* an issue--the control is not context sensitive as to state.
Comment 17 sworddragon2 2016-10-02 03:44:40 UTC
So that the "Clear Direct Formatting" context menu entry does still exist in Calc is intended? In that case I think the duplicate status is just wrong.
Comment 18 Octavio Alvarez 2016-10-02 08:01:59 UTC
I also consider the bug merging to be a mistake, as neither bug has anything to do with the other one.

This bug talks about removal of individual DF attributes from the context menu, while #100604 talks about the state of the "Clear DF" context menu item not being context-aware.

Comment #16 just makes no sense and just introduced noise. It talks about the control state in the toolbar and the menu bar, but the original bug has nothing to do with it. It states that "Direct formatting has been removed from the default configuration of the context menu", it apparently implying that "Clear DF" is removed too or should be removed too.

Now both bugs are confusing, as there is now some implication that "Clear DF" is or should be removed from the context menu, but "Clear DF" *has not* been removed from the context menu, and...

"Clear DF" *should not* be removed from the context menu because the context menu *still has* DF in the form of the "Character..." and "Paragraph..." menu items, as opposed to what was stated in comment #16.

I agree they are related, though, so "See also" might be a good idea and possibly appropriate, but "duplicate" is definitely false.
Comment 19 V Stuart Foote 2016-10-02 16:42:36 UTC
(In reply to Octavio Alvarez from comment #18)
> I also consider the bug merging to be a mistake, as neither bug has anything
> to do with the other one.
> 

OK, sure it is undone.