Download it now!
Bug 86851 - MENU: Moving table number recognition from context menu to table menu
Summary: MENU: Moving table number recognition from context menu to table menu
Status: RESOLVED DUPLICATE of bug 86619
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Main-Menu Context-Menu
  Show dependency treegraph
 
Reported: 2014-11-29 14:49 UTC by Yousuf Philips (jay) (retired)
Modified: 2014-12-02 23:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-29 14:49:04 UTC
Presently, 'Number Recognition' (.uno:TableNumberRecognition) is only available in the context menu, when the cursor is inside of a table. It would be best if this selectable feature would be always accessible inside the menu and removed from the context menu.
Comment 1 Cor Nouws 2014-12-01 02:09:37 UTC
Hi Jay, you write it as if it is a problem that the entry is only available with the cursor in a table?
Do you  have ideas on all the settings related to number recognition (see Tools > Options > Writer > Table (iirc) ?
Comment 2 Yousuf Philips (jay) (retired) 2014-12-01 07:09:57 UTC
Hi Cor,

The main point here is that it is given a major importance when it is in the context menu and that it shouldnt be in the context menu when it effects all tables and not just the table you are right-clicking on.
Comment 3 Cor Nouws 2014-12-02 22:50:50 UTC
Hi Jay,

(In reply to Jay Philips from comment #2)

> The main point here is that it is given a major importance when it is in the
> context menu 

Why do you think it's given major importance here?
And isn't it a function of major importance? 

> ...  and that it shouldnt be in the context menu when it effects all
> tables and not just the table you are right-clicking on.

Number recognition is directly linked with numbering notation, and a function influencing the very cell at the cursor..
Comment 4 Yousuf Philips (jay) (retired) 2014-12-02 23:23:44 UTC
Hi Cor,

> Why do you think it's given major importance here?
> And isn't it a function of major importance? 

As the context menu is to give easy access to frequently used features of context, this isnt the case for number recognition. Unfortunately this function isnt of major importance as its an on/off button that is switched on by users who want its functionality and left on, so even for users who use it, them seeing in the context menu of every table isnt of benefit.

> Number recognition is directly linked with numbering notation, and a
> function influencing the very cell at the cursor..

Number recognition affects all cells and not just the cell you are currently in. Number format affects the cell that you are currently in.

I've setup a bug for the reorganization of all the context menu table related entries, so i'm closing this as a duplicate of that. Please read through bug 86619 comment 3, for the full scope of the change.

*** This bug has been marked as a duplicate of bug 86619 ***