Bug Hunting Session
Bug 86984 - UI:Line Numbering. Include header or footer not preserved and has no effect on counting in locales other than EN_US
Summary: UI:Line Numbering. Include header or footer not preserved and has no effect o...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0 target:4.4.1
Keywords:
: 88123 (view as bug list)
Depends on:
Blocks: Line-Numbering mab4.4
  Show dependency treegraph
 
Reported: 2014-12-03 19:08 UTC by Jacques Guilleron
Modified: 2017-10-17 21:38 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacques Guilleron 2014-12-03 19:08:39 UTC
Open in Writer a document with header or/and footer and some lines.
In Tools, choose Line Numbering and check 
  Show Numbering 
Click OK.
Line count appears in the margin. 

Open again Line Numbering and check
  Include header and footer.
Click OK.
None change.

Open Line Numbering and see Include header and footer isn't checked.

Observed on:
LO 4.4.0.0.beta1 Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e Locale: fr_FR
& Windows 7 Home Premium.

Jacques
Comment 1 Jacques Guilleron 2014-12-04 02:17:03 UTC
Works as expected in LO 4.5.0.0.alpha0+
Build ID: 736b040cb158308e002d24cee8c33e794b2f59a1
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-01_15:20:47
Locale: fr_FR

so I close this as Works for me.

Jacques
Comment 2 Cor Nouws 2014-12-21 11:34:59 UTC
I reopen this one.
Does not work in 4.0.0.rc1 and it's announced as new feature..
Comment 3 Cor Nouws 2014-12-21 11:35:25 UTC
will mark as MAB
Comment 4 Cor Nouws 2014-12-21 12:18:31 UTC
hmm. seems to work with ENG_US but not with Dutch_NL locale?
Comment 5 riesslibo 2014-12-21 15:37:15 UTC
Can confirm described behaviour even for German de_de UI in Win7/64 LibO 4.4.0.0.beta2 .

No recounting is startet and displaxed and looking in the numbering properties shows, that the check of the "include head and footer" disapear.
Comment 6 Jacques Guilleron 2014-12-27 17:44:00 UTC
Hi,

I confirm that all works with English UI but "Include header and footer" not efficient with French Locale.

regards,

Jacques
Comment 7 Muthu 2014-12-29 11:52:54 UTC
If I understand this chain right: It works properly on EN locale but not for FR?
or is it something else...?
Comment 8 Jacques Guilleron 2014-12-29 15:08:10 UTC
Hi Muthu,

If I ask for the English UI when French integrated Help is installed, all works.
The same with Dutch Locale, I think.

Regards,

Jacques
Comment 9 Cor Nouws 2014-12-29 16:03:39 UTC
(In reply to Muthu from comment #7)
> If I understand this chain right: It works properly on EN locale but not for
> FR?

Yes, when I set UI to English, it works.
When I set UI to Dutch, it doesn't.
Confirmed by comment #5
Comment 10 Cor Nouws 2015-01-06 19:22:49 UTC
*** Bug 88123 has been marked as a duplicate of this bug. ***
Comment 11 Roman Kuznetsov 2015-01-07 10:54:46 UTC
confirm this bug, for

Version: 4.4.0.1.0+
ID build: 310c6e617f48ac94f2bd982b2dca6c05c06a2d51
TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2015-01-04_20:52:31
Locale: ru_RU
OS: Windows 7 x86-64
Comment 12 Commit Notification 2015-01-28 12:48:54 UTC
Muthu Subramanian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb9e0063d64243ffd56174566b9eda723daf0cb3

fdo#86984: UI Line numbering works only for EN_US

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-01-28 12:52:23 UTC
Muthu Subramanian committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e930c08494346627f5bf658d46a81c735e3917ec&h=libreoffice-4-4

fdo#86984: UI Line numbering works only for EN_US

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Cor Nouws 2015-02-02 20:30:56 UTC
Hi mutu,

Thanks!
The most recent daily for me is d1c9bd13ec7af93f5368dfda6d6d3c955f0b0816 so I'm not yet able to check.
Will do later again,
Ciao,

Cor
Comment 15 Cor Nouws 2015-02-10 10:04:38 UTC
I just checked in Master 4.5.0.0.alpha0+ 
Build ID: 39e9e3ee8369eeb00025291e637f0bb2a8f87ed2
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-02-07_22:46:27
Locale: nl_NL

Works fine there. So this is fixed. Thanks!
(Not yet checked in 4.4 code line)
Comment 16 Jean-Baptiste Faure 2015-02-11 05:55:08 UTC
Verified fixed in LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

Best regards. JBF