Bug Hunting Session
Bug 87876 - Tools -> Options -> View tab crushed by new OpenGL Graphics Output strings
Summary: Tools -> Options -> View tab crushed by new OpenGL Graphics Output strings
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: Other All
: highest critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.5.0 target:4.4.1 target:4.4.2
Keywords:
: 88901 88907 88946 88952 88988 89078 89098 89118 89229 89275 89635 90412 (view as bug list)
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2014-12-30 21:37 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-04-28 03:59 UTC (History)
20 users (show)

See Also:
Crash report or crash signature:


Attachments
options dialog (160.73 KB, image/png)
2014-12-30 21:37 UTC, Yousuf Philips (jay) (retired)
Details
clip of dropdown menu open, shows full width (30.08 KB, image/png)
2014-12-31 05:03 UTC, V Stuart Foote
Details
Options Dialogue with German Localisation (67.27 KB, image/png)
2015-01-27 09:45 UTC, Harald Koester
Details
View pane FR locale master 27/04/2015 (87.41 KB, image/png)
2015-04-27 16:10 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-30 21:37:03 UTC
Created attachment 111539 [details]
options dialog

On the Tools > Options dialog and goto the view entry and the new entries added under graphics output are crushing the entries in the column to the left of it. This is likely being caused by the long text label 'Force OpenGL even if blacklisted (might expose driver bugs)'.
Comment 1 A (Andy) 2014-12-30 22:40:49 UTC
How can I see these OpenCL entries?  I don't have them in my LO 4.4.0.0.beta1.  Do I have something to enable to see them?
Comment 2 Yousuf Philips (jay) (retired) 2014-12-30 23:25:59 UTC
You have to have 4.4 or master to see them. You can easily get it from here http://dev-builds.libreoffice.org/pre-releases/
Comment 3 V Stuart Foote 2014-12-31 05:03:31 UTC
Created attachment 111552 [details]
clip of dropdown menu open, shows full width

@Jay, *,

Dialog can be resized horizontally if space is available. Otherwise not really an issue as the dropdown list is fully readable. Only the exposed item in the widget is truncated, and that pretty minor. Even the 'old' view in your clip shows truncated.  

Resolving invalid.
Comment 4 V Stuart Foote 2014-12-31 05:05:41 UTC
No regression, dropdown list items are fully readable. Also, as the dialog can be expanded or shrunk as user prefers there is no loss of function.

Resolving invalid.
Comment 5 Yousuf Philips (jay) (retired) 2014-12-31 09:56:51 UTC
Hi Stuart,

By default, the dialog should look as we intend it to look and IMHO, that is the not case here. In the old version, we could read 'Automatic' fully, and actually looking at the older version again, there isnt a reason for 'Use system font for user interface' to be on two rows when there was so much space on the right. So if anything, 'Force OpenGL even if blacklisted (might expose driver bugs)' should be allowed to be on multiple rows so it doesnt cramp items on the left column, and the left column should be increased so 'Use system font for user interface' appears on one row.
Comment 6 V Stuart Foote 2014-12-31 16:13:10 UTC
OK, back to new... if you really want to fix it.

http://opengrok.libreoffice.org/xref/core/cui/uiconfig/ui/optviewpage.ui
line #101

The containing Gtk frames/grids have the same padding 12 left and 6 top, 6 between rows with nothing set right.

So would be two ways to "fix" this visually, move the "(might expose driver bugs)" warning to its own Gtk label, or figure out a way to add a line break to the overly long label for the GtkCheckButton--I think that can be done. Adolfo?

Either should relax the width truncation of the frames at the dialogs default width, I don't think we'd want to make the width any wider as it would look bad and consume too much screen.
Comment 7 Harald Koester 2015-01-27 09:45:11 UTC
Created attachment 112820 [details]
Options Dialogue with German Localisation

The situation is even worse in the German localisation. Have a look to the attached screen shot.
Comment 8 Harald Koester 2015-01-27 09:47:39 UTC
Oh, I forgot to mention the LO version and my system: Ver. 4.4.0.3, Win7.
Comment 9 Adolfo Jayme 2015-01-27 18:11:18 UTC
Will have a look.

Please don’t use UX-Advise for these obvious bugs…
Comment 10 V Stuart Foote 2015-01-29 16:14:50 UTC
*** Bug 88901 has been marked as a duplicate of this bug. ***
Comment 11 V Stuart Foote 2015-01-29 19:06:59 UTC
*** Bug 88907 has been marked as a duplicate of this bug. ***
Comment 12 Adolfo Jayme 2015-01-30 01:10:38 UTC
OK, this is a new reincarnation of bug 65595, and the same fix will probably work. Although I’d much prefer to just fix the label (either by adding a line break or by splitting into two labels), that will annoy a tiny bunch of vocal people in libreoffice-l10n and don’t want to receive death threats.
Comment 13 Yousuf Philips (jay) (retired) 2015-01-30 06:58:00 UTC
I'd go for the wrap Adolfo as it is the easiest solution, as i'm assuming the string text likely will changed in the future and having it across 2 labels wont work well with translation.
Comment 14 V Stuart Foote 2015-01-30 15:14:41 UTC
*** Bug 88946 has been marked as a duplicate of this bug. ***
Comment 15 V Stuart Foote 2015-01-31 15:42:49 UTC
*** Bug 88952 has been marked as a duplicate of this bug. ***
Comment 16 Eugene 2015-01-31 16:10:39 UTC
Not only German Localisations affected. For example, UK also.
Comment 17 V Stuart Foote 2015-01-31 19:25:16 UTC
*** Bug 88988 has been marked as a duplicate of this bug. ***
Comment 18 Adolfo Jayme 2015-02-04 11:34:44 UTC
*** Bug 89098 has been marked as a duplicate of this bug. ***
Comment 19 Adolfo Jayme 2015-02-04 11:40:52 UTC
*** Bug 89078 has been marked as a duplicate of this bug. ***
Comment 20 Adolfo Jayme 2015-02-05 17:07:55 UTC
*** Bug 89118 has been marked as a duplicate of this bug. ***
Comment 21 V Stuart Foote 2015-02-08 16:18:07 UTC
*** Bug 89229 has been marked as a duplicate of this bug. ***
Comment 22 Commit Notification 2015-02-09 09:37:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=081f3c0f70a9aa4d9f1f72bfbdb838bbd2dc993e

Resolves: fdo#87876 full text of war and peace used as checkbox label

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Caolán McNamara 2015-02-09 09:44:15 UTC
https://gerrit.libreoffice.org/14379 for 4-4 where I force a wrap to get it to fit and not have to change translations. And for 4-5 I'll change the text to be a more reasonable length.
Comment 24 Commit Notification 2015-02-09 09:46:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=110751e5415cda9ba9488a0673e956a443c836fd

Related: fdo#87876 make checkbox label shorter, move warning into tooltip

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2015-02-09 10:54:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=27b5c708938167e7516407db7d22bf48aac796b2&h=libreoffice-4-4

Resolves: fdo#87876 full text of war and peace used as checkbox label

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Adolfo Jayme 2015-02-10 07:43:45 UTC
*** Bug 89275 has been marked as a duplicate of this bug. ***
Comment 27 V Stuart Foote 2015-02-11 18:27:21 UTC
@Caolán, *,

Looks good in 4.5.0 master with the warning in the tooltip.

Version: 4.5.0.0.alpha0+
Build ID: 233da237ad4b593c945903c3b32185a540025516
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-02-10_16:44:04
Locale: en_US

=-=-=

The line wrap for 4.4.1 works, but is still truncating the left column of widgets--impacting the User Interface: Icon size and style area's dropdown menu. 
Dialog, does open out to full size of selection when the drop down is activated.

So workable, just a little ugly.

Version: 4.4.2.0.0+
Build ID: dd53735c5fe98fa4f8da4bf214a04b7883bf73c8
TinderBox: Win-x86@42, Branch:libreoffice-4-4, Time: 2015-02-11_15:55:36
Locale: en_US
Comment 28 Caolán McNamara 2015-02-12 09:43:44 UTC
https://gerrit.libreoffice.org/#/c/14438/ would fix that if it gets in
Comment 29 Commit Notification 2015-02-12 14:38:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df38063461947c87419b10942909f72785f8895c&h=libreoffice-4-4

Related: fdo#87876 calculate ideal width after icon style entries are added

It will be available in 4.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 30 Adolfo Jayme 2015-02-25 00:33:12 UTC
*** Bug 89635 has been marked as a duplicate of this bug. ***
Comment 31 Adolfo Jayme 2015-04-02 12:59:05 UTC
*** Bug 90412 has been marked as a duplicate of this bug. ***
Comment 32 Alex Thurgood 2015-04-27 16:09:44 UTC
This is broken again in master 

Version: 5.0.0.0.alpha1+
Build ID: 950055bcb06c8edcd9062c71184f02bf8e0604e6
Locale : fr_

I only see the problem in FR locale and not en-US

Enclosing screenshot
Comment 33 Alex Thurgood 2015-04-27 16:10:35 UTC
Created attachment 115140 [details]
View pane FR locale master 27/04/2015
Comment 34 Caolán McNamara 2015-04-27 19:36:22 UTC
That's now a different bug of "French translations out of date on master", I hacked in a line-break for 4-4, then shortened the string there because that was a hugely long set of works for an option in any language and move all the english text inside the brackets into a tooltip. If the French trans is updated then from the visual above I see that the long string and the one above will be approx the same length and all will presumably be well
Comment 35 Adolfo Jayme 2015-04-28 03:59:30 UTC
@Alex: as Caolán said this is an issue you should report to the Franch translation team, but after 5.0 is in beta. Do not report anything translation-related for alphas, as it’s obvious that we translators are just starting working on them. And, in future avoid reopening fixed issues like that, which just generates useless bug mail to everyone subscribed to this and associated bugs. Thanks.