Bug 89242 - Libreoffice doesn't render or print bold face Computer Modern fonts
Summary: Libreoffice doesn't render or print bold face Computer Modern fonts
Status: RESOLVED DUPLICATE of bug 69254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-02-09 04:10 UTC by SB
Modified: 2018-01-23 14:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the issue (159.88 KB, image/png)
2015-02-09 07:20 UTC, SB
Details
ODT file showing the issue (8.27 KB, application/vnd.oasis.opendocument.text)
2015-02-09 07:21 UTC, SB
Details
Fonts used in the file (4.63 MB, application/x-xz)
2015-02-09 09:33 UTC, SB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SB 2015-02-09 04:10:14 UTC
I have LibreOffice 4.4.0.3 on a Mac and it doesn't render CMU Fonts in Bold-face. Even when I change them to bold, it stays normal. This bug wasn't there in Libreoffice 3 and has been there from the start in Libreoffice 4. This is what prevented me from migrating. Please help! I had earlier installed the fonts as OTF, but now I have them in the TTF format and the bug persists.
Thanks.
Comment 1 SB 2015-02-09 04:11:39 UTC
Sorry not migrating, I meant upgrading.
Comment 2 Joel Madero 2015-02-09 05:30:51 UTC
Please attach a sample file along with the font (assuming you have the rights to do so, please don't attach a file that is no freely distributed under some sort of copyleft license). Marking as NEEDINFO - once you attach a file and hopefully the font, set the bug to UNCONFIRMED. Thanks.

Changing version to 4.0.0.3 release as you said this appeared in 4.0 release. Version is the oldest version that the bug is confirmed on, 4.0 all has special meaning which does not apply here.
Comment 3 SB 2015-02-09 07:20:54 UTC
Created attachment 113243 [details]
Screenshot of the issue
Comment 4 SB 2015-02-09 07:21:47 UTC
Created attachment 113244 [details]
ODT file showing the issue
Comment 5 SB 2015-02-09 09:33:23 UTC
Created attachment 113247 [details]
Fonts used in the file

The fonts are downloaded from sourceforge, so, hopefully, they are open-source.
Comment 6 QA Administrators 2015-02-11 23:08:24 UTC
In the future please read the message in its entirety as we don't review NEEDINFO bugs. I am pushing this back to UNCONFIRMED. Thanks for the info.
Comment 7 Alex Thurgood 2015-04-01 08:59:03 UTC
Version: 4.5.0.0.alpha0+
Build ID: 09f83e1f409853a6c6e4300287c4e50bad5b9d0b
Locale: fr_

OSX 10.10.2

I can't reproduce the problem when the CMU fonts are  not installed. When I open the document, the first line is in bold, the second line, normal weight. So, when the fonts are not installed, the fallback correctly substitutes that font for a bold weight.

After I install the CMU fonts, the document *appears to be* incorrectly displayed. The first line no longer appears bold, however, if you select the word "bold" and remove the bold attribute, then you will notice a difference in display.

So, it is not that the bold attribute isn't registered/displayed, just that the weight of CMU Serif is not sufficiently distinguished between BOLD/NON-BOLD.

Whether this is down to our incomplete core text support for all font weights of a given family, the font itself, or some other problem linked to LO font handling, I have no idea, but it very much falls within the category of other True/Opentype font weight support issues that one sees in numerous font bugs with LibreOffice on OSX.

Confirming
Comment 8 Alex Thurgood 2015-04-03 15:59:32 UTC
Setting as duplicate of 69254

*** This bug has been marked as a duplicate of bug 69254 ***
Comment 9 Thomas Linard 2018-01-05 09:57:28 UTC

*** This bug has been marked as a duplicate of bug 35538 ***
Comment 10 Thomas Linard 2018-01-23 14:01:54 UTC

*** This bug has been marked as a duplicate of bug 69254 ***