Bug 89770 - TABLE: Cursor not visible after deletion of nested table
Summary: TABLE: Cursor not visible after deletion of nested table
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Writer-Tables Text-Cursor
  Show dependency treegraph
 
Reported: 2015-03-02 01:16 UTC by Gordo
Modified: 2018-12-28 16:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (2.45 KB, text/plain)
2017-10-03 18:26 UTC, Telesto
Details
Bibisect log (1.92 KB, text/plain)
2017-10-03 18:32 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-03-02 01:16:52 UTC
1. New Text Document.
2. Insert Table 2x2.
3. In cell A1 Insert Table 2x2.
4. Delete nested table.
5. Click mouse in cell where nested table used to be.
6. No cursor, but can type and cursor reappears.

If the document is saved, closed, and reopened, then the cursor is visible.
Comment 1 Octavio Alvarez 2015-03-02 06:41:33 UTC
Confirmed in 4.3.3.2, Debian Sid. The cursor disappears as specified.

However, did three more tests, inserting the table before, between and after a letter in the A1 cell. Did it with the same steps but inserting the following step:

Step 2.5: According to 1 of 3 cases, type 'a' and position the cursor before or after the letter. Or, type 'aa' and place the cursor between the letters.

Inserting the table after the letter the bug does also occur.

Inserting the table before the letter the bug does not occur.

Inserting the table between two letters the bug does not occur.
Comment 2 tommy27 2016-04-16 07:25:58 UTC Comment hidden (obsolete)
Comment 3 Octavio Alvarez 2016-04-22 00:50:42 UTC
Confirmed again on 5.1.1.2 under Ubuntu 14.04.
Comment 4 Telesto 2017-01-24 17:02:34 UTC
*** Bug 105330 has been marked as a duplicate of this bug. ***
Comment 5 Telesto 2017-07-08 11:49:02 UTC
Found in
Version: 6.0.0.0.alpha0+
Build ID: cac5c9f6081590b0548d3116bc4cd4a2509ec576
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-01_00:41:48
Locale: it-IT (nl_NL); Calc: CL

and in
Versie 4.0.0.3 (Bouw-id: 7545bee9c2a0782548772a21bc84a9dcc583b89)

but not in
LibreOffice 3.5.7.2 
Build ID: 3215f89-f603614-ab984f2-7348103-1225a5
Comment 6 Xavier Van Wijmeersch 2017-07-08 16:59:28 UTC
confirmed in
Version: 6.0.0.0.alpha0+
Build ID: 505ce3a2ba3adeef46daecbf9b14c42cea211408
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: group

and in
Version: 5.3.4.2
Build ID: SlackBuild for 5.3.4 by Eric Hameleers
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 7 Telesto 2017-10-03 18:26:32 UTC
Created attachment 136743 [details]
Bibisect log

demo@Demo:~/bibisect-43all$ git bisect bad
d3f11a2232b85bc3ab3e69000f571c0eba1930fd is the first bad commit
commit d3f11a2232b85bc3ab3e69000f571c0eba1930fd
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed May 2 19:14:52 2012 +0200

    source-hash-0bbf79005a697c6781047c01f05eb660836a18e1
    
    commit 0bbf79005a697c6781047c01f05eb660836a18e1
    Author:     Stephan Bergmann <sbergman@redhat.com>
    AuthorDate: Mon Apr 23 11:47:45 2012 +0200
    Commit:     Stephan Bergmann <sbergman@redhat.com>
    CommitDate: Mon Apr 23 11:47:45 2012 +0200
    
        Do not fail for legacy rdb that only contains root key

:100644 100644 b453a604fc3c5fb4f63f3aed412de93d20c55f20 30cc0b83db3fdcc1184dc05167bee66d47065710 M    ccache.log
:100644 100644 5b0c05d5b6e9bda9bd68f447b69ed7bed74e3f33 06d353cf5a0dd1d1225f43c0f21e1401f4316324 M    commitmsg
:100644 100644 c6128a76d64ef1fe9d7cfd8fbb4cddb737fcf551 e9791ae34f56f896af9eeb3ad1a21850bb54b086 M    dev-install.log
:100644 100644 c0a3d2e12aaac1a7028a9d2c80d22e60efd1998f 43a4d682bdd87ac9421ebe7a42ce229c9f1acba7 M    make.log
:040000 040000 39dc0b7004ecedf0b4458a6b1df2c44f75bb8725 ae3ab874138db9d0d407fc0f11d1738a17f398b8 M    opt
:100644 100644 3098f58f38447b6f729b16c23f3edcc4ae973b8a 27ab6b5b5adb9e65e24651db698082531c3d5593 M    patch.log
Comment 8 Telesto 2017-10-03 18:32:34 UTC
Created attachment 136744 [details]
Bibisect log
Comment 10 Telesto 2018-02-09 11:25:46 UTC
No repro with
Version: 6.1.0.0.alpha0+
Build ID: d1bc14b318c9a412a761d243085da0895a1aed4a
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: nl-NL (nl_NL.UTF-8); Calc: group threade
Comment 11 Dieter Praas 2018-03-02 16:27:32 UTC
Also for me not reproducible in

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d64ce643275e0b2b0dea9e532fc261391dc8793c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-01_03:24:30
Locale: de-DE (de_DE); Calc: CL

But see bug 116144

Telesto, you opened the new bug 116144. So do you think, we can close this bug as WORKSFORME?
Comment 12 Telesto 2018-03-02 16:39:30 UTC
Thanks for the confirmation: Closing WFM