Bug 90387 - START CENTER: Breeze Writer and Calc icons appearing as white and black
Summary: START CENTER: Breeze Writer and Calc icons appearing as white and black
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: andreas_k
URL:
Whiteboard: target:5.0.0
Keywords:
: 91103 (view as bug list)
Depends on:
Blocks: Start-Center mab5.0 87234
  Show dependency treegraph
 
Reported: 2015-04-01 06:20 UTC by k-j
Modified: 2015-05-09 16:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
new breeze calc icon in toolbar (11.70 KB, image/png)
2015-04-01 06:20 UTC, k-j
Details
Calc-Icon (6.28 KB, image/png)
2015-04-01 10:34 UTC, k-j
Details
Breeze start center (38.46 KB, image/png)
2015-04-02 05:49 UTC, k-j
Details
start center on linux (21.62 KB, image/png)
2015-04-02 09:08 UTC, Yousuf Philips (jay) (retired)
Details
calc icon correctly displayed (25.59 KB, image/jpeg)
2015-04-04 13:28 UTC, steve -_-
Details
White Breeze Calc icon still present 20150404 build (44.67 KB, image/png)
2015-04-04 13:48 UTC, V Stuart Foote
Details
StartCenter and Main menu rendering (22.51 KB, image/png)
2015-04-04 13:54 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description k-j 2015-04-01 06:20:36 UTC
Created attachment 114516 [details]
new breeze calc icon in toolbar

The icon for a new Calc document in toolbar is white on white background. The other icons for "new" are coloured and ok. See attachment. WIN 10 Pro Technical Preview Build 10049, LibO 4.5.0.0 alpha+ Tinderbox: Win-x86@62-TDF 2015-03-27 Locale: de_De
Comment 1 Yousuf Philips (jay) (retired) 2015-04-01 10:09:08 UTC
Hi k-j,

It is the white new icon from writer that shows this issue and it has already been reported to the designer.
Comment 2 k-j 2015-04-01 10:34:27 UTC
Created attachment 114519 [details]
Calc-Icon

Hi Jay,
maybe I'm wrong, but here it is the white Spreadsheet-Icon.
Comment 3 Yousuf Philips (jay) (retired) 2015-04-01 21:18:29 UTC
Weird as that doesnt happen to me on Linux. :D

Do you got a screenshot of the start center?
Comment 4 k-j 2015-04-02 05:49:43 UTC
Created attachment 114543 [details]
Breeze start center

Seems to be ok for me.
Comment 5 Yousuf Philips (jay) (retired) 2015-04-02 09:08:43 UTC
Created attachment 114548 [details]
start center on linux

Something is weird as my start center icons for writer and calc are different then yours.

Version: 4.5.0.0.alpha0+
Build ID: b024e36ddb3b53163d7a01f6f7b5aadb7a858cd9
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-03-31_08:18:46

Just checked my windows box and i can see it the same as yours. Something is quite wrong here.
Comment 6 Yousuf Philips (jay) (retired) 2015-04-04 06:49:42 UTC
Digging into the repo in icon-themes/breeze/res, the writer icon is blue and the spreadsheet icon green, so why are they black an white in the start center.
Comment 7 steve -_- 2015-04-04 13:27:24 UTC
FIXED

both writer and calc icons display correctly.

Version: 4.5.0.0.alpha0+
Build ID: b24a15a0aaea310806259eaa20a7d509ce30e5c8
TinderBox: MacOSX-10.10@61, Branch:master, Time: 2015-04-02_23:36:47
Locale: de_
Comment 8 steve -_- 2015-04-04 13:28:00 UTC
Created attachment 114616 [details]
calc icon correctly displayed
Comment 9 steve -_- 2015-04-04 13:29:34 UTC
Also start center is correct now.

k-j can you check with a current nightly build and re-open if this issue persists on Win10. Then it is a win only bug and we need to adjust the affected hardware in that case.
Comment 10 V Stuart Foote 2015-04-04 13:48:52 UTC
Created attachment 114617 [details]
White Breeze Calc icon still present 20150404 build

Nope, still not correct.

Version: 4.5.0.0.alpha0+ (x64)
Build ID: e2ed0c6e2729438a6512fc51fc0bfd6055e849f2
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-04_03:35:50
Locale: en_US
Comment 11 V Stuart Foote 2015-04-04 13:54:55 UTC
Created attachment 114618 [details]
StartCenter and Main menu rendering

Version: 4.5.0.0.alpha0+ (x64)
Build ID: e2ed0c6e2729438a6512fc51fc0bfd6055e849f2
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-04_03:35:50
Locale: en_US

Breeze Calc icon, white on Start Center, but on Main menu has a dark green rendering.
Comment 12 steve -_- 2015-04-05 09:07:12 UTC
Stuart: Should this then be windows only?
Comment 13 Yousuf Philips (jay) (retired) 2015-04-05 12:34:40 UTC
(In reply to steve ... from comment #12)
> Stuart: Should this then be windows only?

Steve: I'd assume its still affecting Linux, though unfortunately there are no new linux builds since the 31st, so i cant confirm it.
Comment 14 Heiko Tietze 2015-04-05 20:32:00 UTC
KDE HIG says about icons:
* Use colorful icons for applications, folders, mimetypes and devices.
* Application icons should be unique and easily recognizable.
* When creating an system icon theme, respect trademarks by avoiding significant alterations to application icons.

Plus, it shows Chrome as an example. That means non of the LO branded icons should be changed on any platform.

https://techbase.kde.org/Projects/Usability/HIG/IconDesign
Comment 15 k-j 2015-04-07 06:19:30 UTC
(In reply to Heiko Tietze from comment #14)
> KDE HIG says about icons:

And how concerns this the bug?
Comment 16 k-j 2015-04-07 06:22:41 UTC
(In reply to steve ... from comment #9)
> Also start center is correct now.
> 
> k-j can you check with a current nightly build and re-open if this issue
> persists on Win10. Then it is a win only bug and we need to adjust the
> affected hardware in that case.

The bug is still here:
TinderBox: Win-x86@42; Branch:master, Time: 2015-04-06_23:15:08
Comment 17 Heiko Tietze 2015-04-07 07:16:42 UTC
(In reply to k-j from comment #15)
> (In reply to Heiko Tietze from comment #14)
> > KDE HIG says about icons:
> 
> And how concerns this the bug?

It confirms the bug as a UX fault. Keep branded icons as them are and don't breezify the LO start center.
Comment 18 Jan Holesovsky 2015-04-09 10:32:55 UTC
Remove the dependency on 65138, pollutes the MAB5.0 dependencies.
Comment 19 V Stuart Foote 2015-04-09 11:18:43 UTC
(In reply to Jan Holesovsky from comment #18)
> Remove the dependency on 65138, pollutes the MAB5.0 dependencies.

I think Jay may have meant meant bug 61914 when 65138 added as a dependency. Don't see this as a Sidebar related issue. Adjusted the meta blockages.
Comment 20 Yousuf Philips (jay) (retired) 2015-04-09 12:46:29 UTC
Yep that was my mistake. Thanks for noticing kendy and stuart for rectifying it. :D
Comment 21 m.a.riosv 2015-05-05 22:10:00 UTC
*** Bug 91103 has been marked as a duplicate of this bug. ***
Comment 22 andreas_k 2015-05-09 11:12:25 UTC
should be fixed with patch 15681
I changed the files lx03250, lx03251, ods_32_8 and odt_32_8 from png color indexed in RGB and then the icon was shown as it is in the Start Center and the writer and calc apps.
Comment 23 Commit Notification 2015-05-09 16:26:29 UTC
andreas_ka committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=96ce8550752abebc8ed178caf5d16312a58e3b3e

Breeze: update icon theme, and fix tdf#90387

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2015-05-09 16:26:33 UTC
andreas_ka committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28e26aa44960300039b35ce1fd325d0255a19f62

Breeze: fix tdf#90387 in writer and calc

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.