Bug 90452 - Breeze icons poorly visible in Start Center
Summary: Breeze icons poorly visible in Start Center
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta3 ta...
Keywords:
: 91532 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-04 15:38 UTC by Pedro
Modified: 2016-10-25 19:23 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
breeze icons in start center (51.39 KB, image/jpeg)
2015-05-28 08:59 UTC, steve -_-
Details
startCenter-Gray icons (23.09 KB, image/png)
2015-05-29 23:09 UTC, andreas_k
Details
startCenter White icons (22.97 KB, image/png)
2015-05-29 23:10 UTC, andreas_k
Details
LO Start 48px (63.90 KB, image/png)
2015-06-05 19:34 UTC, andreas_k
Details
LO44-sl Start Center (75.03 KB, image/png)
2015-06-06 07:57 UTC, Martin Srebotnjak
Details
Pages startcenter (187.70 KB, image/jpeg)
2015-06-06 08:44 UTC, steve -_-
Details
start center white and green (214.99 KB, image/png)
2015-06-06 21:43 UTC, andreas_k
Details
LO gray (195.25 KB, image/png)
2015-06-06 23:21 UTC, andreas_k
Details
StartCenter AppIcons 48 (10.75 KB, application/zip)
2015-06-07 17:47 UTC, andreas_k
Details
StartCenter wit LO Gray 2 and 7 (197.37 KB, image/png)
2015-06-07 18:18 UTC, andreas_k
Details
Hacked breeze theme including the 48 pixel icons for the Start Center (906.75 KB, application/zip)
2015-06-07 18:19 UTC, Pedro
Details
StartCenter brand color proposal Adolfo (101.99 KB, image/png)
2015-06-09 03:22 UTC, Adolfo Jayme
Details
LO 2015-07-02 nightly + osx 10.10.4 (126.65 KB, image/jpeg)
2015-07-02 15:40 UTC, steve -_-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2015-04-04 15:38:56 UTC
As discussed in the Design mailing list
http://nabble.documentfoundation.org/Breeze-Icons-tp4145012.html

the Breeze icons (at least the Templates and Draw Drawing icons) have low visibility in the Start Center because of low contrast with the green sidebar.

The two options seem to be: 1) keep the icons defined in the LibreOffice branding in the Start Center, regardless of the icon style selected OR 2)have a "Breeze representations of the current LO icons" as suggested by Rosmaninho
(something like this https://kdeonlinux.wordpress.com/2015/03/25/breeze-love-libre-office/)
Comment 1 Yousuf Philips (jay) (retired) 2015-04-10 15:29:19 UTC
This issue was discussed at wednesday's design meeting as part of bug 90387 and kendy will be checking with the marketing team whether the icons are branding or not.
Comment 2 Yousuf Philips (jay) (retired) 2015-05-27 18:46:10 UTC
The icons were decided that they werent branding so icon themes can change them if they choose.
Comment 3 Jean-Baptiste Faure 2015-05-27 20:05:36 UTC
(In reply to Yousuf (Jay) Philips from comment #2)
> The icons were decided that they werent branding so icon themes can change
> them if they choose.

Not sure if we can say that the problem is fixed. Indeed there is a remaining problem linked to Breeze icons in the startcenter: if you choose the Sifr icons set, you get Breeze icons in the startcenter as fallback. If I am not wrong Sifr is the default icons set on OS-X.

Best regards. JBF
Comment 4 Pedro 2015-05-27 21:30:01 UTC
(In reply to Yousuf (Jay) Philips from comment #2)
> The icons were decided that they werent branding so icon themes can change
> them if they choose.

I strongly disagree with the Status change. The bug report is about the Breeze icons having a low visibility against the green background in the Start Center.

That problem still remains.
Comment 5 Pedro 2015-05-27 21:33:02 UTC
(In reply to Jean-Baptiste Faure from comment #3)
> Not sure if we can say that the problem is fixed. Indeed there is a
> remaining problem linked to Breeze icons in the startcenter: if you choose
> the Sifr icons set, you get Breeze icons in the startcenter as fallback. If
> I am not wrong Sifr is the default icons set on OS-X.

Jean-Baptiste, that is a separate bug, which is reported to be fixed
https://bugs.documentfoundation.org/show_bug.cgi?id=90127
Comment 6 Jean-Baptiste Faure 2015-05-28 04:22:20 UTC
(In reply to Pedro from comment #5)
> (In reply to Jean-Baptiste Faure from comment #3)
> > Not sure if we can say that the problem is fixed. Indeed there is a
> > remaining problem linked to Breeze icons in the startcenter: if you choose
> > the Sifr icons set, you get Breeze icons in the startcenter as fallback. If
> > I am not wrong Sifr is the default icons set on OS-X.
> 
> Jean-Baptiste, that is a separate bug, which is reported to be fixed
> https://bugs.documentfoundation.org/show_bug.cgi?id=90127

I do not think it is that bug. The problem concerns Sifr icons set, if you set Sifr you get Breeze in the StartCenter. No problem if I set Tango as icons set.
Tested this morning with Version: 5.0.0.0.beta1+
Build ID: cf851cda7c943548d0ce60d0b4836ccbf6e76698
Ubuntu_15.04_x86-64
Locale: fr-FR (fr_FR.UTF-8)

Best regards. JBF
Comment 7 steve -_- 2015-05-28 08:59:23 UTC
At all: I find the title of this bug very clear and am attaching a screenshot.

I love breeze but the way it integrates in the start center is contrast wise not acceptable.

http://contrastrebellion.com/

I'm not sure I can follow the discussion with Sifr / Breeze. No matter if I choose Sifr or Breeze I get the same icons in startcenter as shown in screenshot. Breeze indeed is fall back to Sifr. So both concerned and Sifr is default on OSX. But I think Breeze should be. But that's another discussion.

I disagree with this being fixed. Why is it? I don't understand.

But this discussion is totally depending on the 5.x branding. Depending on that choice this might be a big or a non issue.

Back to NEW.
Comment 8 steve -_- 2015-05-28 08:59:56 UTC
Created attachment 116101 [details]
breeze icons in start center
Comment 9 Yousuf Philips (jay) (retired) 2015-05-28 10:23:09 UTC
(In reply to Jean-Baptiste Faure from comment #3)
> Not sure if we can say that the problem is fixed. Indeed there is a
> remaining problem linked to Breeze icons in the startcenter: if you choose
> the Sifr icons set, you get Breeze icons in the startcenter as fallback. If
> I am not wrong Sifr is the default icons set on OS-X.

Yes that maybe a problem, but that is a sifr problem and not a breeze problem as tango and breeze fallback on galaxy and sifr falls back on breeze. This can be easily remedied by copying the tango start center icons into sifr.

(In reply to Pedro from comment #4)
> I strongly disagree with the Status change. The bug report is about the
> Breeze icons having a low visibility against the green background in the
> Start Center.

Sorry for the misunderstanding, as i didnt re-read the bug report thoroughly. I will speak to the icon designer about this issue and see if anything can be done, as the breeze color palette is quite limited ( https://techbase.kde.org/images.techbase/8/8b/Breeze_Color_Palette.png ). I think the best solution would be to use the same gray found in the 'Open File' icon on all of the icons. This would also remedy the sifr problem as well.
Comment 10 Pedro 2015-05-28 17:19:11 UTC
(In reply to Yousuf (Jay) Philips from comment #9)
> I will speak to the icon designer about this issue and see if
> anything can be done, as the breeze color palette is quite limited (
> https://techbase.kde.org/images.techbase/8/8b/Breeze_Color_Palette.png ). I
> think the best solution would be to use the same gray found in the 'Open
> File' icon on all of the icons. This would also remedy the sifr problem as
> well.

In Bug report #91532 (which is a duplicate of this bug), the last comment by Adolfo indicates that the Start Center itself will be redesigned for 5.0 so maybe this is no longer an issue...
Comment 11 Jean-Baptiste Faure 2015-05-28 18:42:15 UTC
(In reply to Pedro from comment #10)
> [...]
> In Bug report #91532 (which is a duplicate of this bug), the last comment by
> Adolfo indicates that the Start Center itself will be redesigned for 5.0 so
> maybe this is no longer an issue...

For 5.0? Seems to be too late for that.

Best regards. JBF
Comment 12 V Stuart Foote 2015-05-28 19:13:11 UTC
*** Bug 91532 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2015-05-28 19:28:47 UTC
bug 90127 has been corrected by Kendy, the user selected icon set (or default Tango) will appear on Start Center.  Issue of low contrast with Breeze incons over specific backgrounds is likely unfixable short of an arbitrary recoloring of the breeze icon set as Jay mentions.

Some of us still prefer that the Start Center icon sets be fixed as a branding issue, but what is likely going to be necessary for that is a new UI control to specify icon set for Start Center separate from the rest of the UI.

Otherwise the Icon set appearing on the Start Center is now (post tdf#90127) the user selected icon set from Tools -> Options -> View --until changes can be made to coloring of Breeze icons they will appear in low contrast over the <= 4.x builds.
Comment 14 Jean-Baptiste Faure 2015-05-28 20:15:21 UTC
(In reply to V Stuart Foote from comment #13)
> [...]
> Otherwise the Icon set appearing on the Start Center is now (post tdf#90127)
> the user selected icon set from Tools -> Options -> View 

Sorry, it is not true if you choose Sifr icons set. See comment #6.

Best regards. JBF
Comment 15 Yousuf Philips (jay) (retired) 2015-05-28 21:00:28 UTC
(In reply to Pedro from comment #10)
> In Bug report #91532 (which is a duplicate of this bug), the last comment by
> Adolfo indicates that the Start Center itself will be redesigned for 5.0 so
> maybe this is no longer an issue...

The start center wont be redesigned, but there maybe a different color used in the sidebar - https://wiki.documentfoundation.org/Design/Whiteboards/5.0_Branding#Contributions_submitted_so_far

(In reply to Jean-Baptiste Faure from comment #11)
> For 5.0? Seems to be too late for that.

Yes it will likely be in 5.0.

(In reply to Jean-Baptiste Faure from comment #14)
> Sorry, it is not true if you choose Sifr icons set. See comment #6.

As sifr fallsback on breeze, it is true. See comment #9.
Comment 16 andreas_k 2015-05-29 23:09:38 UTC
Created attachment 116161 [details]
startCenter-Gray icons

gray icons
Comment 17 andreas_k 2015-05-29 23:10:11 UTC
Created attachment 116162 [details]
startCenter White icons

white icons
Comment 18 andreas_k 2015-05-29 23:15:33 UTC
If the new Branding is green than I'd prefer white icons (breeze dark icon color). But my wish would be to use the color of the menue bar (gray in this example) for the side bar background, than I can use the colored icons.
Comment 19 Yousuf Philips (jay) (retired) 2015-05-29 23:24:12 UTC
I agree that white looks better in the start center, but these same icons are also used in the NEW button in the toolbar and them being white is bug 90387 all over again. :D
Comment 20 Pedro 2015-05-30 06:29:33 UTC
(In reply to andreas_k from comment #18)
> If the new Branding is green than I'd prefer white icons (breeze dark icon
> color). But my wish would be to use the color of the menue bar (gray in this
> example) for the side bar background, than I can use the colored icons.

I think this is missing the whole point of an icon. The icon is supposed to be a unique image that you can easily associate with the task you want to perform. 

If all icons use the same colour and they are similar then you need to read the icon label which makes the icons useless.

Why is it not possible to use the beautiful icons created specifically for LibreOffice?
https://kdeonlinux.wordpress.com/2015/03/25/breeze-love-libre-office/

If this is not possible then I think the theme should use the default icons for the Start Center.
Comment 21 Martin Srebotnjak 2015-05-30 10:06:50 UTC
I voting is allowed - I vote for white icons.

The icon is one thing, it's color variants are other.

An icon can be adapted for different occasions, even logos as such have color variants, so sticking just to one color version and not adapting it to a specific/extreme UI situation (such as this vibrant green background is) misses the point of UI design.
Comment 22 Yousuf Philips (jay) (retired) 2015-05-30 19:11:21 UTC
If its possible to get the nice icons like Pedro suggested ( e.g. https://kdeonlinux.files.wordpress.com/2015/03/libreoffice-writer.png ), that would be the best possible outcome.
Comment 23 andreas_k 2015-06-05 19:34:01 UTC
Created attachment 116317 [details]
LO Start 48px

the icons are 48 px in size. thanks for the feedback. would work good. is the contrast ok for you?
Comment 24 Yousuf Philips (jay) (retired) 2015-06-05 19:39:17 UTC
(In reply to andreas_k from comment #23)
> the icons are 48 px in size. thanks for the feedback. would work good. is
> the contrast ok for you?

I like them, though the folder icons seem a bit large compared to other icons.
Comment 25 Martin Srebotnjak 2015-06-05 20:10:15 UTC
If I may say so - the attached solution seems to colorful and uses too many different colours, also it does not step away from the background, some white halo effect or shine would make it better.
I prefer the icons from the Breeze theme, but maybe with some white halo effect or border or white shade they might prove a better solution.
Also the folders do look from outer space or some other icon set.
This does not seem a reasonable solution.

The current situation in 4.4 is still better.
Comment 26 andreas_k 2015-06-05 20:22:55 UTC
can you post the current situation in 4.4 (don't have installed it)

maybe we can talk about the sidebar color. which color is used in LO 5?
Comment 27 Martin Srebotnjak 2015-06-06 07:57:01 UTC
Created attachment 116324 [details]
LO44-sl Start Center

Hi, here is the current version, very readable, clear, as one can see.
Comment 28 steve -_- 2015-06-06 08:44:22 UTC
Created attachment 116326 [details]
Pages startcenter
Comment 29 steve -_- 2015-06-06 08:49:31 UTC
am I crazy if I make the observation, that proper colors (dark background for documents and grey for left panel) would solve all start center icon issues and would give the startcenter a modern look?
Comment 30 Yousuf Philips (jay) (retired) 2015-06-06 09:04:28 UTC
Yes i think if we swapped the green and white between the right and left sections (of course inverting the color of the text as well), that would be a good combination. Document thumbnails would be alot easier to see when they are not on a white background.
Comment 31 Martin Srebotnjak 2015-06-06 09:51:39 UTC
Also in that case of inverting the two background colors the nice Breeze icons could probably be used.
Comment 32 Adolfo Jayme 2015-06-06 14:00:24 UTC
No idea why this bug blocks 87234.
Comment 33 V Stuart Foote 2015-06-06 14:27:58 UTC
There is pending branding/design work being done for 5.0 that will reskin the StartCenter and Welcome/About panes. Until that is resolved there is no point in this proceeding.

Comments 28 - 31 are somewhat onerous, and transcend the specific UI issue of the poor Breeze icon contrast on background of StartCenter button panel, or of the Sifr icon set fall-back to Breeze.

Regards a background color swap between the launch buttons panel and the thumbnail view pane:

As implemented, thumbnail document views on the start pane are rendered, or generic document type icons are shown, onto fixed 260 x 300 pixel panels that currently show blue when the object is selected. That same blue is defined in a gradient for selected button objects on the launch buttons. So it really is not just two colors but also text contrast that needs to be judged. Rather the whole default color scheme for the StartCenter and LO branding.

While we wait for resolution to the design work, not much can be done with the Breeze icon set in 5.0, beyond possibly assigning a fixed color to just the breeze icons used on the StartCenter, as in comments 16 - 19.  But then Pedro's comment 20 is equally germane. And which the Apple Pages startcenter of attachment 116326 [details] suffers from.

Moving this back to UX advise, and enhancement since it seems to have drifted away from the visibility issue.
Comment 34 andreas_k 2015-06-06 19:00:30 UTC
I made some mockups with different colors. as higher the mockup number as better I think.

https://www.dropbox.com/sh/bdox203inh7t82a/AAArWVKB-KJICrI3GojLykDCa?dl=0
Comment 35 andreas_k 2015-06-06 21:43:05 UTC
Created attachment 116339 [details]
start center white and green

After a design session with jphilipz and octal the result is the attached file StartCenterMockup23. The new start menu windows works also better for galaxy, tango, ...

sidebar
=======
background white, text black

main window
===========
background green 1 (18A303) primary LO Color
text white
thumbnail boarder 1px green 0 (106802) secondary LO Color

hover thumbnail, button
=======================
Calc Spreadsheet, Help and Offene Punkte TSI INF PRM ENE are shown as mouse hover
green 0 (106802) secondary LO Color

select button
=============
Recent Files is selected for the main window, when Templates was selected Templates has a green background
background green 1 (18A303) primary LO Color
text color black

All colors are from the Branding (https://wiki.documentfoundation.org/Marketing/Branding)
Comment 36 andreas_k 2015-06-06 23:21:39 UTC
Created attachment 116340 [details]
LO gray

long discussion after the design session. It is difficult. We would like to use the branding but green isn't that good for such large color areas.

The problem is that there isn't a gray branding color so we deside to use dark gray for the main window and lighter gray in the sidebar as you can see in the mockup file StartCenterMockup27.
Comment 37 Martin Srebotnjak 2015-06-06 23:23:11 UTC
Wouldn't Breeze icons look better in that?
Comment 38 Martin Srebotnjak 2015-06-06 23:24:29 UTC
And this still does not solve the issue of two buttons at the bottom of sidebar, they are still from some other design (smaller font size, box around them, two in a row, ...).
Comment 39 V Stuart Foote 2015-06-07 01:16:08 UTC
(In reply to andreas_k from comment #36)
> Created attachment 116340 [details]
> LO gray
> 
Hey looks pretty good. Thanks guys! Please be sure to add them to the Wiki at
https://wiki.documentfoundation.org/Design/Whiteboards/5.0_Branding

> long discussion after the design session. It is difficult. We would like to
> use the branding but green isn't that good for such large color areas.
> 
> The problem is that there isn't a gray branding color so we deside to use
> dark gray for the main window and lighter gray in the sidebar as you can see
> in the mockup file StartCenterMockup27.

So the dark grey looks to be #2b2f33 and the light grey #eeeeee -- you could use the LO standard pallet "Gray 8" (#333333 - 3355443) and "Gray 1" (#eeeeee - 15658734) respectively.

If anyone wants to see the colors as rendered--open Tools -> Options -> Advanced: ExpertConfiguration and search for StartCenterBacground -- current TDF Green is Dec 7514196 or Hex 72A854 -- Button labels are hard-coded white for now as is the canvas of the thumbnail view pane.

(In reply to miles from comment #37)
> Wouldn't Breeze icons look better in that?

Those are Breeze icons--just the special set done for ODF documents

(In reply to miles from comment #38)
> And this still does not solve the issue of two buttons at the bottom of
> sidebar, they are still from some other design (smaller font size, box
> around them, two in a row, ...).

Nothing to "solve", that is simply styling assigned to textbox buttons in the backingwindow.cxx source, easily adjusted as needed -- http://opengrok.libreoffice.org/xref/core/sfx2/source/dialog/backingwindow.cxx#335
Comment 40 V Stuart Foote 2015-06-07 01:18:16 UTC
(In reply to V Stuart Foote from comment #39)
s/StartCenterBacground/StartCenterBackgroundColor/
Comment 41 Pedro 2015-06-07 06:53:14 UTC
(In reply to V Stuart Foote from comment #39)

> If anyone wants to see the colors as rendered--open Tools -> Options ->
> Advanced: ExpertConfiguration and search for StartCenterBackgroundColor -- current
> TDF Green is Dec 7514196 or Hex 72A854 -- Button labels are hard-coded white
> for now as is the canvas of the thumbnail view pane.

Interesting feature. BTW just search startcenter ;)

You can only input decimal numbers (because it only accepts numbers)

It is a shame that the other settings are hard-coded. And it would be nice that the settings were applied on-the-fly (instead of having to exit LO and starting again).

IMO the left panel looks too dark with Gray 8. I tested with Dec 6710886 (the background from https://wiki.documentfoundation.org/File:LibreOffice-Initial-Artwork-Colors_Guidelines_Valid2.png) and it looks good.

Can someone share a link for the zip containing the icon theme with the large Breeze icons?
Comment 42 Martin Srebotnjak 2015-06-07 07:41:49 UTC
(In reply to V Stuart Foote from comment #39)

> (In reply to miles from comment #37)
> > Wouldn't Breeze icons look better in that?
> 
> Those are Breeze icons--just the special set done for ODF documents
> 
Well, just wanted to say I prefered those appearing by default in 5.0b1.

(In reply to V Stuart Foote from comment #39)
> (In reply to miles from comment #38)
> > And this still does not solve the issue of two buttons at the bottom of
> > sidebar, they are still from some other design (smaller font size, box
> > around them, two in a row, ...).
> 
> Nothing to "solve", that is simply styling assigned to textbox buttons in
> the backingwindow.cxx source, easily adjusted as needed --
> http://opengrok.libreoffice.org/xref/core/sfx2/source/dialog/backingwindow.
> cxx#335

What I wanted to say is that the concept of having both hyperlinks with icons and boxed buttons (with smaller font size), one stacked vertically and one stacked horizontally in the same pane is not coherent and clean.

Was there any mockup of having those two buttons transfered into hyperlinks, one in a row, just like the above app links? A divider, already used between the Create and folders section, could still be used at the bottom. But that is just my opinion, of course.

I must also support the notion that the folder icons in this icon set seem bigger than the module icons.

As far as readability is concerned, these app icons are really not readable well (unlike the ones appearing by default in LO50b1), the quite small and thin-lined white design inside them is hardly readable so users will not "read" from the icon what app they want, which actually makes the icons somewhat redundant in this scenario.

It would be the same if not better if only colored dots or boxes or already used (semi-transparent) triangles (each of the current icon/app color) would be in front of the app links text (in fact that might even be a graphically clearer solution, there will be enough un-unified graphics shown in the document preview pane, so excess design in the left pane just makes it all too ).

The Calc icon especially is a bit misguiding, I thought at first that a calculator is displayed (but it should represent a table, spreadsheet).

Also the "Recent files" text should probably be rendered in white, not grey (to be on par with file names etc.), if needed at all - currently I do not see this text in LO44 or LO50b1 and I do not see why it would be needed - if this pane also contained the Open file dialog upon clicking the "Open File" link, that would be reasonable. But the content of this pane does not change clicking any of the buttons on the left, so titles here are not explicitly needed. It just takes additional space. If already needed, this title should remain in space and only the thumbnails pane should be scrollable - but that would require fixing it into another-colored pane etc.

And another thing - why is the Extensions button there at all? Why would someone be looking or trying to install an extension even before one single module is started? I never used it in this context and I do use several extensions, also regularly updating them. But it is just not something you open with LO, so an explanation why this link to a website is here would be in place; of course if clicking it would open an array of suggested extensions in the thumbnail preview pane that would make some sense, but this now is like a work in progress that just got forgotten in the middle.
Comment 43 andreas_k 2015-06-07 17:47:28 UTC
Created attachment 116354 [details]
StartCenter AppIcons 48

Attached the Application Icons for the start center in 48x48px. The icons are different than the "mimetype" like breeze icons which are now in the Start Center. I would prefere the app icons because you start the app and not an odt file. But when we choose the app icon the minimum size is 48x48px in the original size (32x32px) you can only choose the mimetype icons.
Comment 44 Pedro 2015-06-07 18:17:03 UTC
(In reply to andreas_k from comment #43)
> Attached the Application Icons for the start center in 48x48px. 

Thanks. I was hoping for a modified images_breeze.zip but no problem, I already hacked it ;)

It looks pretty good! Actually nicer than the Tango icons :)

> The icons
> are different than the "mimetype" like breeze icons which are now in the
> Start Center. I would prefere the app icons because you start the app and
> not an odt file. But when we choose the app icon the minimum size is 48x48px
> in the original size (32x32px) you can only choose the mimetype icons.

Personally I find the Breeze icons too thin, so I'm using Sifr (or a hacked version of Industrial...)

But I do like these easily recognizable icons on the Start Center! Of course they don't match the Sifr theme at all...
Comment 45 andreas_k 2015-06-07 18:18:25 UTC
Created attachment 116355 [details]
StartCenter wit LO Gray 2 and 7

I would say finished. You to?

Sidebar
=======
background: Gray 2 221/221/221 #dddddd
text and line: Gray 8 51/51/51 #333333

Thumbnail window
================
background: Gray 7 102/102/102 #666666
text and line: Gray 1 238/238/238 #eeeeee
hover background: Gray 2 221/221/221 #dddddd
hover text: Gray 8 51/51/51 #333333

Extension (icon isn't finished only placeholder) and Help buttons same style as other buttons. 
Recnet Files and Templates > element for show on right side.
Comment 46 Pedro 2015-06-07 18:19:29 UTC
Created attachment 116356 [details]
Hacked breeze theme including the 48 pixel icons for the Start Center
Comment 47 Pedro 2015-06-07 18:23:46 UTC
(In reply to andreas_k from comment #45)

> I would say finished. You too?

+1

The Recent Files should be different from the Recent Files. But this is a problem that affects all Themes so it needs to be discussed by UX... Maybe for 5.1?
Comment 48 andreas_k 2015-06-07 20:23:36 UTC
> But I do like these easily recognizable icons on the Start Center! Of course
> they don't match the Sifr theme at all...

breeze is fallback for sifr, so you will get the breeze icons ;-) until someone will make sifr icons.
Comment 49 andreas_k 2015-06-07 20:25:25 UTC
that's true we only discuss the colors the other points are for the future and should be discussed at another point.
Comment 50 V Stuart Foote 2015-06-07 23:41:41 UTC
+1 for the mono-chrome TDF defined gray 7 / 8 / 2 / 1

perhaps complemented for 5.0 with an accent color (other than current TDF Green used in 4.x)  for a reshuffled document corner motif, and flashed in the About panel?

@Andreas,  you might want to spin out a mockup29 to use Adolfo's Recent Document icon--see bug 91911
Comment 51 andreas_k 2015-06-08 06:18:10 UTC
So happy that there will be an recent document icon to. I also don't like it that it was the same in the past. will make you a mockup. thanks for the information.
Comment 52 andreas_k 2015-06-08 23:29:33 UTC
I have done my part of the bug report see https://gerrit.libreoffice.org/#/c/16176/

All Start Center icons are 48x48 px because they doesn't work with 32x32 px. I also make the recent-documents icon from galaxy (thanks Adolfo). And I also make the extensions and help icon according to galaxy so it would be possible to change the design of the extension and help button to the standard layout.

how does it look like:
https://dl.dropboxusercontent.com/u/1642456/VDG/LibreOffice/StartCenter/StartCenterBreezeIcons.png

So how can change the colours as discussed that this bug report is fixed? I make it my own but if no one will do it I will search in the code for some night ;-( to fix the colours.

thanks for writing the bug report and for the discussion.
Comment 53 Commit Notification 2015-06-09 01:06:09 UTC
andreas_ka committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d28102b1ed0c31500bbc68453a7b7613bd2bfa06

Breeze: StartCenter new icons according to tdf#90452

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 54 Commit Notification 2015-06-09 01:20:33 UTC
andreas_ka committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=45e1b4cad938a8ac1c865df527dcc536d4c80920&h=libreoffice-5-0

Breeze: StartCenter new icons according to tdf#90452

It will be available in 5.0.0.0.beta3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 55 Adolfo Jayme 2015-06-09 03:22:55 UTC
Created attachment 116394 [details]
StartCenter brand color proposal Adolfo

I’ve updated my brand refresh proposal [1] to take this bug into account.


[1] https://wiki.documentfoundation.org/Design/Whiteboards/5.0_Branding#Contributions_submitted_so_far
Comment 56 Commit Notification 2015-06-30 15:59:44 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=562d2c3337051da5d98d55a28dc391dab387b692

tdf#90452: Implement the new design of the startcenter.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 57 Commit Notification 2015-06-30 16:00:07 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aef5e0a90cdfd37c2228a9959adee2efd543a717

tdf#90452: Remove the frame around the Help and Extension buttons.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 58 Commit Notification 2015-06-30 16:00:11 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7387cdbc41924a85cc48e6b68563c91e35b3915c

tdf#90452: The correct color for the message when there's no recent file yet.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 59 Commit Notification 2015-06-30 16:00:15 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1cf7e272f7731978695f4bcd8fbdf85766d4f14e

tdf#90452: Templates should adhere to the recent docs colors too.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 60 steve -_- 2015-07-02 15:39:41 UTC
Calling this Resolved > Fixed.

Thanks Andreas for the mockup session and kendy for implementing the results!

If I missed something please re-open and add your thoughts.
Comment 61 steve -_- 2015-07-02 15:40:11 UTC
Created attachment 117006 [details]
LO 2015-07-02 nightly + osx 10.10.4
Comment 62 V Stuart Foote 2015-07-02 22:29:37 UTC
Hey, a special thanks to Kendy! 

He did the extra bit needed in implementing Andreas's design such that the full set of StartCenter colors are accessible in Expert Configuration dialog: /org.openoffice.Office.common/Help/StartCenter

per tdf#90452 comment 45
Decimal	 HEX	Color	Property
3355443	 333333	Gray 8	StartCenterTextColor
14540253 DDDDDD	Gray 2	StartCenterBackgroundColor
15658734 EEEEEE	Gray 1	StartCenterThumbnailsTextColor
14540253 DDDDDD	Gray 2	StartCenterThumbnailsHighlightColor
6710886	 666666	Gray 7	StartCenterThumbnailsBackgroundColor
3355443	 333333	Gray 8	StartCenterThumbnailsHightlightTextColor

Meaning that users can adjust any of these properties from Expert Configuration to skin the StartCenter as desired.
Comment 63 Pedro 2015-07-03 08:38:14 UTC
Hi Stuart, all

(In reply to V Stuart Foote from comment #62)
> Hey, a special thanks to Kendy! 
> 
> He did the extra bit needed in implementing Andreas's design such that the
> full set of StartCenter colors are accessible in Expert Configuration
> dialog: /org.openoffice.Office.common/Help/StartCenter
> 
> per tdf#90452 comment 45
> Decimal	 HEX	Color	Property
> 3355443	 333333	Gray 8	StartCenterTextColor
> 14540253 DDDDDD	Gray 2	StartCenterBackgroundColor
> 15658734 EEEEEE	Gray 1	StartCenterThumbnailsTextColor
> 14540253 DDDDDD	Gray 2	StartCenterThumbnailsHighlightColor
> 6710886	 666666	Gray 7	StartCenterThumbnailsBackgroundColor
> 3355443	 333333	Gray 8	StartCenterThumbnailsHightlightTextColor
> 
> Meaning that users can adjust any of these properties from Expert
> Configuration to skin the StartCenter as desired.

Thank you to all that contributed. This is particularly good news! Not only has the problem been solved but especially in a way that users can modify to their preferences (instead of hardcoded options). Kudos to Jan "Kendy" Holesovsky! (and thank you Stuart for the new hidden options ;) )
Comment 64 Martin Srebotnjak 2015-07-03 08:40:08 UTC
Maybe a small competition for best looking design combining those settings to one's own liking (for a LO T-shirt etc.) could be announced (and even incorporated into LO, if it looks better than the current combination).
Comment 65 Commit Notification 2015-07-03 19:53:56 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3a36a6761c8edbeb5f3af236d2f54c3b6dc8072&h=libreoffice-5-0

tdf#90452: Implement the new design of the startcenter.

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 66 Commit Notification 2015-07-03 19:54:00 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=abbccd9e1c0f5ec231bf8b53878ce1f043ef26e1&h=libreoffice-5-0

tdf#90452: Remove the frame around the Help and Extension buttons.

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 67 Commit Notification 2015-07-03 19:55:34 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb1ae405750be24ddbcccb9bb0baf0b12efe680e&h=libreoffice-5-0

tdf#90452: The correct color for the message when there's no recent file yet.

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 68 Commit Notification 2015-07-03 19:55:38 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=56c1103d6a83b46d5cacdc9d0e249d2959256f76&h=libreoffice-5-0

tdf#90452: Templates should adhere to the recent docs colors too.

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 69 Commit Notification 2015-07-08 10:21:36 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9bb825704b7592cfc66267303cb019e38dcb3c2d

tdf#90452 StartCenter: Replace old, clunky, non-transparent LO logo…

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.