Bug Hunting Session
Bug 90778 - can't add a space between Hebrew letters and numbers/latin letters
Summary: can't add a space between Hebrew letters and numbers/latin letters
Status: RESOLVED DUPLICATE of bug 85852
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: Other Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-Hebrew
  Show dependency treegraph
 
Reported: 2015-04-22 09:22 UTC by Tofi
Modified: 2017-11-04 09:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (94.83 KB, image/png)
2015-04-22 09:22 UTC, Tofi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tofi 2015-04-22 09:22:31 UTC
Created attachment 115003 [details]
screenshot

Hello,

When typing in hebrew (which is written right to left), and clicking the space bear a space only appears at the beginning of the line (i.e. the right) and not at the end of it. This isn't a problem if the next word is also in Hebrew letters but if it is in Latin letters or a digit then no space appears between it and the previous word. 

This happens in every component I checked including text documents, spreadsheets etc.

This has happened before in previous versions. It may have been fixed although I'm not sure because more than once I had to revert to older versions because of this.
Unfortunately I don't remember which version I had where it worked fine so I'll just have to go back one by one to find out.
Comment 1 Tofi 2015-04-22 11:55:31 UTC
UPDATE: this problem doesn't occur when using the Still version (4.3.6)
Comment 2 Alex Thurgood 2015-04-22 18:15:41 UTC
@Tofi : is this the same behaviour that you already reported in bug 85852 ?
Comment 3 Alex Thurgood 2015-04-22 18:17:26 UTC
@Tofi : please try LO 4.4.x version and report back here - perhaps the issues has been fixed.

Setting to NEEDINFO pending requested information. Please set to UNCONFIRMED once requested information has been provided.
Comment 4 Tofi 2015-04-23 16:18:01 UTC
Hi @Alex, I already tried that version as well and it does the same. So far, it only works in the new Still version, but not in any of the Fresh versions currently available for download.
Comment 5 Alex Thurgood 2015-04-24 07:10:00 UTC
@Tofi : sorry, I am lost. You reported this bug against version 4362 release (see above) and now you say that the problem is gone in 436.x=unspecified (se you comment 1) ?

Also, is this the same problem you were having in bug 85852, which you also appear to have filed last year ?

Please clearly identify which version works and which doesn't for you. My understanding is that at present LO 4.4.x.x doesn't work for you, and that the latest 4.3.6.x does - please confirm / deny.
Comment 6 raal 2015-04-25 09:39:46 UTC
Setting needinfo, please answer comment 5 and attach testing file, thank you.
Comment 7 Tofi 2015-04-25 10:07:51 UTC
@Alex  I see now that I was mistaken - the version I have installed now (and works) is Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Strangely when I downloaded it from the site it said it was version 4.3.6. 

Anyway, like I previously wrote  it seems to only work in the Still version and not the Fresh ones (not sure what that means but it's a different section on the site)
Comment 8 raal 2015-04-25 10:31:34 UTC
 attach testing file, thank you.
Comment 9 Alex Thurgood 2015-04-25 14:38:15 UTC
So it works in LO44.x - closing as WFM
Still, which is currently 4.3.7, and at the moment the last version in the 4.3 line, is EOL in May 27th, 2015, so it will probably not be backported.
Comment 10 Zeev Turchinsky 2015-11-02 21:57:41 UTC
Hi, I have the same problem in the version 5.0.2.2
Comment 11 DanielG 2016-01-02 09:31:45 UTC
It also happens in 5.0.3.2.
Comment 12 eisa01 2016-09-11 13:54:27 UTC
Confirmed that this regressed again between 5.0.0.2 and 5.0.0.3, but this seems to be the same underlying behavior as bug 85852 so marking as dupe

*** This bug has been marked as a duplicate of bug 85852 ***