Bug Hunting Session
Bug 85852 - Bad Hebrew support: Can't add a space between Hebrew letters and numbers/latin letters
Summary: Bad Hebrew support: Can't add a space between Hebrew letters and numbers/lati...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: Other Mac OS X (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords: bibisected, bisected, regression
: 90778 92710 93062 (view as bug list)
Depends on: HarfBuzz
Blocks: RTL-Hebrew
  Show dependency treegraph
 
Reported: 2014-11-04 10:56 UTC by Tofi
Modified: 2017-11-04 09:20 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (8.35 KB, application/vnd.oasis.opendocument.text)
2016-05-12 15:30 UTC, Herouth Maoz
Details
Bad rendering in LibreOffice (13.29 KB, image/png)
2016-05-12 15:31 UTC, Herouth Maoz
Details
Good rendering in NeoOffice (10.18 KB, image/png)
2016-05-12 15:43 UTC, Herouth Maoz
Details
Good rendering in LO 5.4 (60.24 KB, image/png)
2017-08-27 10:07 UTC, eisa01
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tofi 2014-11-04 10:56:27 UTC
A few days ago, after getting a new computer, I installed the newest version (4.3) and really loved the new design and changes you made to fit Yosemite BUT the right-to-left support is completely ruined - it is now impossible to combine numbers in a Hebrew text, as you cannot add a space between the text and numbers (same thing happens when trying to combine Latin letters as well). 
This has forced me to downgrade to 4.2.7 for better right-to-left-support.
Comment 1 Alex Thurgood 2014-11-10 15:26:59 UTC
Can not confirm on LO 4322, seems to work for me, but I don't really know what I'm supposed to be typing. If I type some hebrew text, the enter a space, type some numbers, enter another space, then some more text, the number is correctly separated by spaces.
Comment 2 Alex Thurgood 2014-11-10 15:28:59 UTC
For the moment this is worksforme. For those of us unfamiliar with rtl support please explain what we should see and what you actually see.
Comment 3 Herouth Maoz 2016-05-12 15:30:47 UTC
Created attachment 125007 [details]
Test document

Document contains a few letters in Hebrew, followed by a space, followed by a few digits.
Comment 4 Herouth Maoz 2016-05-12 15:31:46 UTC
Created attachment 125008 [details]
Bad rendering in LibreOffice
Comment 5 Herouth Maoz 2016-05-12 15:43:55 UTC
Created attachment 125009 [details]
Good rendering in NeoOffice

I have attached a file, and screen shots of how it is rendered in LibreOffice and in NeoOffice.

The NeoOffice rendition is *correct* - the text is flush to the right, and there is a space between the text and the number.

The LibreOffice rendition is *incorrect* - the space somehow shifted to the right of the text, and the number is joined to the text.

* Version of LibreOffice on which this was produced: 5.1.2.2
* The font used in the example: Lucida Grande, which is supposed to exist
  on any Mac.
* MacOS X El-Capitan.
* NOTE THAT THIS IS A MAC-ONLY PROBLEM. Please make sure when you test it that
  you do so on a Mac, not on any other platform.
* This bug DOESN'T seem to be connected to #89034, which is multi-platform.

Please re-open this bug, and please put some effort into it, as the original poster said, this is a regression, LibreOffice used to work with Hebrew in the past, but this bug renders LibreOffice unusable with Hebrew on the Mac.
Comment 6 eisa01 2016-09-11 10:39:42 UTC
Can confirm this as well, marking as New and tagged with regression, I verified it worked correctly in 4.4.2.2

Bug 90778 is likely a duplicate of this bug.

Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 2; OS Version: Mac OS X 10.11.6; UI Render: default; 
Locale: en-US (en.UTF-8); Calc: group
Comment 7 eisa01 2016-09-11 13:54:27 UTC
*** Bug 90778 has been marked as a duplicate of this bug. ***
Comment 8 eisa01 2016-09-11 14:06:35 UTC
I have triaged this down to regressing between version 5.0.0.2 and 5.0.0.3, adding flag to request bibisect

It also applies to text in Calc documents, and likely the other components

Updating Summary with description from duplicate bug 90778 to better reflect actual bug 

Working:
Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Locale: en-US (en.UTF-8)


Not working:
Version: 5.0.0.3
Build ID: f79b5ba13f5e6cbad23f8038060e556217e66632
Locale: en-US (en.UTF-8)
Comment 9 eisa01 2016-09-12 18:34:57 UTC
I bibisected and bisected this to commit https://cgit.freedesktop.org/libreoffice/core/commit/?id=ab39f8c213bffa00f2b196c05a23ab3ccda8f901 fixing bug 88941

Adding Norbert to CC, could you possible take a look?



MacBook-Pro:bibisect-macosx-64-5.1 $ git bisect good
cfe71be01fc349dc7b2d51aeb8335e6cc63fbea3 is the first bad commit
commit cfe71be01fc349dc7b2d51aeb8335e6cc63fbea3
Author: TDF builder <tdf@tb66.local>
Date:   Mon Jul 6 00:38:26 2015 -0500

    source sha:ab39f8c213bffa00f2b196c05a23ab3ccda8f901
    
    source sha:ab39f8c213bffa00f2b196c05a23ab3ccda8f901

:040000 040000 dbd721d4359203645fa11a0fbdd2f17edf10fd0e 337e681196332f5b03c2238c13555fcf337844d1 M	LibreOffice.app
MacBook-Pro:bibisect-macosx-64-5.1 $ git bisect log
# bad: [11172e488cf90c09164072b8abb50b2b2d343cd4] source sha:35d929f42b074a75eb344b623ea74e548ca72fb0
# good: [4d33afe3fa6a97e61c5c4134553845fb68de1c64] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
git bisect start 'master' 'oldest'
# bad: [1c5667f54cf17bac6c21486d227c404c8e1d4a85] source sha:796b2d6b20e3e9d6ca7f095a49d9b3a54f58645f
git bisect bad 1c5667f54cf17bac6c21486d227c404c8e1d4a85
# bad: [b20628eb2affe10974181b129fd0026fe624e81c] source sha:e544f449eded2738b45de4be13c72b128a16bafe
git bisect bad b20628eb2affe10974181b129fd0026fe624e81c
# good: [b29efce642b5ea66ec11549ddbe309e1b1a6e5e8] source sha:1f408db49740f8cc6ba67d72b54f49d2e4fdae9b
git bisect good b29efce642b5ea66ec11549ddbe309e1b1a6e5e8
# good: [7d1302b568dce1cd3a64b17a26eb628af6f54f7b] source sha:cec3fd6de65a0f526c2b990e8dc54935d0a7864a
git bisect good 7d1302b568dce1cd3a64b17a26eb628af6f54f7b
# good: [ef88dfc1b03a88f6715c5ca9e217e8ea012b8471] source sha:a12db8e9e1960f3f209f1b95547041681566d636
git bisect good ef88dfc1b03a88f6715c5ca9e217e8ea012b8471
# bad: [ef95970f78880ef311a756c96aa33f372ad55d69] source sha:2eea698f5b41b2dbf371e3a6c9d3b242c347206d
git bisect bad ef95970f78880ef311a756c96aa33f372ad55d69
# good: [9af3b33d31155e6650437006c8d94db473f090d3] source sha:3f2c6a02df51f5d548bb1100275860be5196b766
git bisect good 9af3b33d31155e6650437006c8d94db473f090d3
# good: [f83613bc3b543059b7bdd97f70e36a974f5e6cc2] source sha:b5a4e6974a5473c44fc239b6a9ae21f233111c2a
git bisect good f83613bc3b543059b7bdd97f70e36a974f5e6cc2
# good: [55a003fcf116dc238e814d52aa4ff3dce1983985] source sha:b010e4074e5d5ee3a3905f1351f04efafe937c2a
git bisect good 55a003fcf116dc238e814d52aa4ff3dce1983985
# bad: [cfe71be01fc349dc7b2d51aeb8335e6cc63fbea3] source sha:ab39f8c213bffa00f2b196c05a23ab3ccda8f901
git bisect bad cfe71be01fc349dc7b2d51aeb8335e6cc63fbea3
# good: [46230ce0211df334871bb285fbcbfdea314d6a46] source sha:6cadfe0f07659235c6438c345d501eca89b411d5
git bisect good 46230ce0211df334871bb285fbcbfdea314d6a46
# good: [cbcf710dd2aa5a9f5b0a2076913e64d80d86d2de] source sha:c59726e696b7a507f0b5e752a52e3ea7773c230f
git bisect good cbcf710dd2aa5a9f5b0a2076913e64d80d86d2de
# good: [6cb48cc3abb6344acee8d0c820f91bd9853bd78f] source sha:3c45bfb0cabf206f6217f1de9eb5cfa12b78e46f
git bisect good 6cb48cc3abb6344acee8d0c820f91bd9853bd78f
# first bad commit: [cfe71be01fc349dc7b2d51aeb8335e6cc63fbea3] source sha:ab39f8c213bffa00f2b196c05a23ab3ccda8f901
Comment 10 Alex Thurgood 2016-09-23 09:57:38 UTC
Elsa : I think you've hit the nail on the head.
Comment 11 Alex Thurgood 2016-09-23 10:00:55 UTC
*** Bug 92710 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2016-09-23 10:08:48 UTC
Increasing severity and priority...
Comment 13 Xisco Faulí 2016-09-26 15:46:41 UTC
Adding Cc: to Norbert Thiebaud
Comment 14 Cor Nouws 2017-05-11 12:34:06 UTC
Hi, why is this resolved as fixed?
90778 and 92710 are resolved because they are marked as duplicates of this issue. I see no fix. And do get a mail from someone writing that right to left for Arabic is broken..
Comment 15 Buovjaga 2017-08-27 09:25:05 UTC
(In reply to Cor Nouws from comment #14)
> Hi, why is this resolved as fixed?
> 90778 and 92710 are resolved because they are marked as duplicates of this
> issue. I see no fix. And do get a mail from someone writing that right to
> left for Arabic is broken..

Khaled marked it as fixed: https://bugs.documentfoundation.org/show_activity.cgi?id=85852
I guess due to HarfBuzz.
Comment 16 eisa01 2017-08-27 10:07:10 UTC
Created attachment 135817 [details]
Good rendering in LO 5.4

I can verify that this specific is fixed in current LibreOffice, the document renders as NeoOffice

For bug 92710 that also seems to work fine for me now.
Using the test case on this bug as the test document (as I'm not able to enable the RTL/LTR buttons in the toolbar), the spaces seem to behave well, not as in the video.

There might of course be other issues with RTL support

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 17 Xisco Faulí 2017-10-28 18:25:59 UTC
*** Bug 93062 has been marked as a duplicate of this bug. ***