Bug 93062 - Spaces in RTL direction go to the left of the cursor instead of the cursor moves forward
Summary: Spaces in RTL direction go to the left of the cursor instead of the cursor mo...
Status: RESOLVED DUPLICATE of bug 85852
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-01 14:39 UTC by Mohammed Rahawi
Modified: 2017-10-28 18:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast for RTL bug (1.10 MB, video/mp4)
2015-08-01 14:39 UTC, Mohammed Rahawi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammed Rahawi 2015-08-01 14:39:04 UTC
Created attachment 117581 [details]
Screencast for RTL bug

When typing spaces in RTL mode the spaces go to left of the cursor and the text is draged with it to the left! See the screencast.
Comment 1 Joel Madero 2015-08-01 15:20:57 UTC
I am almost positive this is a dupe but a couple things:

1) Please don't set your bug to BLOCKER - we are not going to block a release because of this and marking it as such does absolutely nothing to get the issue fix;

2) Please refrain from exclamation marks in the title - again, does nothing, seems like your yelling, not helpful at all;

3) Please provide clear reproducible steps in your bug reports;

4) Please provide details about your system;

5) Please tell us if this is a regression (is this a new problem)?

6) Please tell us if this actually affects anything or if it's just the placement of the cursor (i.e., does this actually impact your ability to work with RTL or is it just the visual placement of the cursor)?

For now:

Marking as:
NEEDINFO - provide answers to all of the above and then set to UNCONFIRMED;

Normal - default, for now this is appropriate, please do not change it;
Medium - default, do not change it.

If you have questions, concerns, etc.. come chat with us at http://webchat.freenode.net/?channels=libreoffice-qa
Comment 2 Mohammed Rahawi 2015-08-01 17:11:30 UTC
Sorry for the confusion. Just to let you know that as of release 5.0.0.3 LO is no longer supports Arabic and Farsi on Mac OS 10.05 and 10.10.4. I will delete it and go back to version 4.4. Or use Pages. If you look at the screencast you will see that it's incompatible with RTL.

(In reply to Joel Madero from comment #1)
> I am almost positive this is a dupe but a couple things:
> 
> 1) Please don't set your bug to BLOCKER - we are not going to block a
> release because of this and marking it as such does absolutely nothing to
> get the issue fix;
> 
> 2) Please refrain from exclamation marks in the title - again, does nothing,
> seems like your yelling, not helpful at all;
> 
> 3) Please provide clear reproducible steps in your bug reports;
> 
> 4) Please provide details about your system;
> 
> 5) Please tell us if this is a regression (is this a new problem)?
> 
> 6) Please tell us if this actually affects anything or if it's just the
> placement of the cursor (i.e., does this actually impact your ability to
> work with RTL or is it just the visual placement of the cursor)?
> 
> For now:
> 
> Marking as:
> NEEDINFO - provide answers to all of the above and then set to UNCONFIRMED;
> 
> Normal - default, for now this is appropriate, please do not change it;
> Medium - default, do not change it.
> 
> If you have questions, concerns, etc.. come chat with us at
> http://webchat.freenode.net/?channels=libreoffice-qa
Comment 3 Alex Thurgood 2016-09-05 10:06:04 UTC

*** This bug has been marked as a duplicate of bug 92710 ***
Comment 4 Xisco Faulí 2017-10-28 18:25:59 UTC

*** This bug has been marked as a duplicate of bug 85852 ***