Bug Hunting Session
Bug 91293 - Links in Impress Are Removed When Exported to PPTX
Summary: Links in Impress Are Removed When Exported to PPTX
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: highest major
Assignee: Katarina Behrens (CIB)
URL:
Whiteboard: target:5.1.0 target:5.0.3 target:4.4.6
Keywords: bibisected, filter:pptx, regression
: 91640 (view as bug list)
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2015-05-14 19:28 UTC by heidi
Modified: 2016-10-25 19:19 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description heidi 2015-05-14 19:28:57 UTC
I think it's pretty weird that Impress can't do something basic like insert a link into a slideshow. I'm saving this as a *.pptx file (PowerPoint) for job reasons and, if I can't do this, I'm basically losing money. I'm sure you get the picture. It's all on the latest versions.
Comment 1 Joel Madero 2015-05-14 19:48:45 UTC
Please provide reproducible steps....there is nothing here that tells us what you have tried.

Also - if you're using LibreOffice in an office setting where you are making money...I highly recommend getting paid support and contributing back to the community: http://www.documentfoundation.org/certification/developers/

Marking as NEEDINFO, once you provide reproducible steps of what you have tried, please set it to UNCONFIRMED.

If you are just not sure *how* to insert a hyperlink - I suggest asking on the user forum as that's a user question (and not a bug report).

Thanks for your understanding.
Comment 2 Joel Madero 2015-05-14 19:49:01 UTC
Sorry I meant user mailing list - we don't have a forum :)
Comment 3 Joel Madero 2015-05-14 19:58:35 UTC
Ubuntu 15.04
Ubuntu 4.4.2.2 release

FWIW - I just inserted a hyperlink without a hitch (and I'm not getting paid for this time :) )

1) Start impress;
2) Type some text;
3) highlight said text;
4) ctrl + k OR insert -> Hyperlink

You can also skip typing the text and just:

1) start impress;
2) ctrl + k  OR insert -> hyperlink

type whatever you want, and it'll appear.

If those steps don't work for you, please report back with proper reproducible steps, what you see, and what you expect and then mark the bug as UNCONFIRMED.
Comment 4 Joel Madero 2015-05-14 20:04:33 UTC
Upon further (free) investigation I have identified the bug. Steps below:

1) start impress;
2) insert a hyperlink (ctrl + k)
3) Save file as pptx
4) Close file;
5) Open file

Observed: Link is no longer there;
Expected: Link is maintained

Note: PPT works fine (so to the original reporter, I suggest saving as a ppt instead of a pptx)

@Reporter - we do not give time estimates, a volunteer will have to voluntarily resolve the bug (or like I said, you can pay for support which will get a company to fix it)

I am doing further regression analysis to find out if it's a regression.
Comment 5 Joel Madero 2015-05-14 20:23:51 UTC
e4e679399813ef91e0b66deed6cc4970b997e5c4 is the first bad commit
commit e4e679399813ef91e0b66deed6cc4970b997e5c4
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Dec 7 03:50:01 2011 +0100

    source-hash-2ba4caca79923ffe6db3a07a59ba84886b43f84a
    
    commit 2ba4caca79923ffe6db3a07a59ba84886b43f84a
    Author:     Marco Cecchetti <mrcekets@gmail.com>
    AuthorDate: Wed Jul 20 22:33:13 2011 +0200
    Commit:     Thorsten Behrens <tbehrens@novell.com>
    CommitDate: Fri Aug 26 18:25:20 2011 +0200
    
        Now a unique id for each page and each shape is generated through the UnoInterfaceToUniqueIdentifierMapper class.
    
        This class is the same used for generating a unique identifier for pages
        and shapes when a presentation is saved in odp format.
        No change to the presentation engine script has been needed.

:100644 100644 4b0459f7f3acd77a1350c6d97c138f0c548a820a ad2148fab3406489dc78f1f9312fc3048090be66 M	ccache.log
:100644 100644 a801d558f3de18efe40a4def559b58103084ec27 8af698b3061ed802984f5100a271fefba0ff44c9 M	commitmsg
:100644 100644 4e0a4b1149542164839f1dff45a27acdbe560499 322ddd9800c3938266d65e7307c97b19fc1a492e M	dev-install.log
:100644 100644 d80bb8079d1aa2a4665d943c16ee46477efe8a8a 6a62345de8cf39e0eb4e1e9f9dec53195e0b3c13 M	make.log
:040000 040000 2cbb3de9ab8f054c42717e74a7e616bb75e90f12 08ddc62bfb9f99733691993517e2ac072e92b081 M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect bad 369369915d3582924b3d01c9b01167268ed38f3b
# bad: [351622aec2dff3cc3bbbb020ad0097c4322d2a21] source-hash-2c4537471c932b65e6f72e41881b505c4bbad12c
git bisect bad 351622aec2dff3cc3bbbb020ad0097c4322d2a21
# bad: [035c276ec5a8da669e6043a3db6b0701dd3c2ade] source-hash-dc8249af103741415a074d9bbf8b1211f24a7c3f
git bisect bad 035c276ec5a8da669e6043a3db6b0701dd3c2ade
# bad: [4225403645019b6af53db0bf9ba9bbd063e9aa93] source-hash-cf16ef6c250a2755155a02f24bad861b35a1f92b
git bisect bad 4225403645019b6af53db0bf9ba9bbd063e9aa93
# bad: [07e8171f32b03a1146ef80d086c2dd61f3def5aa] source-hash-886762160996dfa3fee07cf135e53dfe952ed298
git bisect bad 07e8171f32b03a1146ef80d086c2dd61f3def5aa
# good: [a699fdbb511958b0a434a30174512791625d0c7d] source-hash-01f5362e7982cc1e5b8c9fa7216c892667971737
git bisect good a699fdbb511958b0a434a30174512791625d0c7d
# bad: [070634f10fa098cd83834fe8deb3b4968448c295] source-hash-f7d71e379edf2c29d53182458342d7a5ce1446d6
git bisect bad 070634f10fa098cd83834fe8deb3b4968448c295
# bad: [e4e679399813ef91e0b66deed6cc4970b997e5c4] source-hash-2ba4caca79923ffe6db3a07a59ba84886b43f84a
git bisect bad e4e679399813ef91e0b66deed6cc4970b997e5c4
# first bad commit: [e4e679399813ef91e0b66deed6cc4970b997e5c4] source-hash-2ba4caca79923ffe6db3a07a59ba84886b43f84a
Comment 6 Björn Michaelsen 2015-06-22 08:08:15 UTC
Please dont just CC random names showing up in a bibisect if you dont know what they mean.
Comment 7 Gerhard Schaber 2015-06-22 08:19:14 UTC
I know what it means, but indeed was not sure how deeply everyone was actually involved. Please remove the irrelevant ones. Thanks.
Comment 8 tommy27 2015-06-24 04:26:39 UTC
still reproducible under Win8.1 x64 using LibO 5.1.0.0.alpha1+
Build ID: 17815049103b920df054b4f1bb8b1e99486972f2
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-22_23:27:30
Locale: en-US (it_IT)
Comment 9 Robinson Tryon (qubit) 2015-07-30 15:03:12 UTC
(In reply to Joel Madero from comment #4)
> Upon further (free) investigation I have identified the bug. Steps below:
> 
> 1) start impress;
> 2) insert a hyperlink (ctrl + k)
> 3) Save file as pptx
> 4) Close file;
> 5) Open file

CONFIRMED on Ubuntu 14.04 with Version: 5.0.0.4

(In reply to tommy27 from comment #8)
> still reproducible under Win8.1 x64 using LibO 5.1.0.0.alpha1+

(As this is cross-platform, I'm changing OS -> All)
Comment 10 Katarina Behrens (CIB) 2015-08-24 19:53:56 UTC
*** Bug 91640 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2015-09-14 16:53:36 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b2a812b89d0d1df08c5d771bfe9bc5eaa3a040c

tdf#91293: Preserve hyperlink on URL field OOXML export

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-09-21 16:13:13 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e17187c323428b7edea425278ea33bca77db12b5&h=libreoffice-5-0

tdf#91293: Preserve hyperlink on URL field OOXML export

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-09-29 10:58:22 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7e2c726fc1ca98d2a21bd75b8669e41e461ed85f&h=libreoffice-4-4

tdf#91293: Preserve hyperlink on URL field OOXML export

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Katarina Behrens (CIB) 2015-09-29 12:29:43 UTC
Let's set this to fixed then
Comment 15 Robinson Tryon (qubit) 2015-12-17 06:34:35 UTC Comment hidden (obsolete)