Bug 91301 - UI: dialog boxes painted incorrectly
Summary: UI: dialog boxes painted incorrectly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta4
Keywords: bibisected
: 91391 (view as bug list)
Depends on:
Blocks: mab5.0
  Show dependency treegraph
 
Reported: 2015-05-15 10:31 UTC by Michael
Modified: 2016-10-25 19:20 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of incorrectly painted dialog box (61.02 KB, image/png)
2015-05-15 10:31 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2015-05-15 10:31:31 UTC
Created attachment 115619 [details]
Screenshot of incorrectly painted dialog box

Some dialog boxes are painted incorrectly. To reproduce: Open Writer, then open Tools->Customize, and see a dialog box that has a wrong background and a greyed out "Description" textbox. Also see attached screenshot.

I first noticed this around Mar 8 on dev build of the master branch, and it persists to today May 15. Bibisect log with lo-linux-dbgutil-daily below. Bisection selected the same commit that was found by a bisection at bug 89873, so it's possibly related. 

Bug 89873: https://bugs.documentfoundation.org/show_bug.cgi?id=89873#c13

Graphics hardware is Intel's on-chip "HD Graphics 4600"

$ uname -a
Linux magrathea 3.19.5-200.fc21.x86_64 #1 SMP Mon Apr 20 19:51:56 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Bibisect log:
# bad: [0cedadc7b2e8c75bf0893100e8fae49f62cc2545] 2015-05-14: source-hash-9de1d53a2ce3ee7036b4688b373db7b2235af4d9
# good: [e4b0a61cedc6ac0e65a4a110fd83edd8295f4856] 2014-11-20: source-hash-d273a60bfdbf9bb7623bed38667ec0647753157c
git bisect start '0cedadc7b2e8c75bf0893100e8fae49f62cc2545' 'e4b0a61cedc6ac0e65a4a110fd83edd8295f4856'
# good: [01fc6c887682b44cdcd716a36df3de95c42f1eaa] 2015-02-15: source-hash-a0956d3960422c6804a749ababc58964522f8d66
git bisect good 01fc6c887682b44cdcd716a36df3de95c42f1eaa
# bad: [2503e300c7cede2d938675c82ec1c6c82b12ef4d] 2015-03-31: source-hash-77315c187af612e3534ad0926f205f0e83fb42fb
git bisect bad 2503e300c7cede2d938675c82ec1c6c82b12ef4d
# bad: [9e37e4717d5d4149070485c32ff965398debf184] 2015-03-09: source-hash-9b92d8afbabe564de703f8bc083723d97e765011
git bisect bad 9e37e4717d5d4149070485c32ff965398debf184
# good: [7cacd865be7861c0470c3587e363fbd75dce54de] 2015-02-26: source-hash-fe9f69f6c86b75bf42ec13aef76aab1975d51c6f
git bisect good 7cacd865be7861c0470c3587e363fbd75dce54de
# good: [4d58d1754779eafff4b2442671953dd62bb0f4ae] 2015-03-03: source-hash-8acdf876c52240c5f3c6d428162b15d4e89f32a7
git bisect good 4d58d1754779eafff4b2442671953dd62bb0f4ae
# good: [36ef092ea89459313baa5fea23540d702f943c78] 2015-03-06: source-hash-825098182227fdca958f84235d278c41b2b942ab
git bisect good 36ef092ea89459313baa5fea23540d702f943c78
# bad: [9639bf64dcd0186088db2bd2af5186328cb0e509] 2015-03-08: source-hash-27bc6714df6638c6fd9d2ee5c26870ae5eb2f63e
git bisect bad 9639bf64dcd0186088db2bd2af5186328cb0e509
# bad: [0d45a5d167c62cde4d7f1a76b2bed58c118cfb7d] 2015-03-07: source-hash-333f8a76341f5b4921e89012d133007503e49612
git bisect bad 0d45a5d167c62cde4d7f1a76b2bed58c118cfb7d
# first bad commit: [0d45a5d167c62cde4d7f1a76b2bed58c118cfb7d] 2015-03-07: source-hash-333f8a76341f5b4921e89012d133007503e49612
Comment 1 raal 2015-05-15 18:45:54 UTC
I can confirm with Version: 5.0.0.0.alpha1+
Build ID: 9c08a06f5d399a7cd11849a377a82663ef6a528e
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-15_01:42:11
Comment 2 Alex Thurgood 2015-05-19 15:57:01 UTC
*** Bug 91391 has been marked as a duplicate of this bug. ***
Comment 3 Alex Thurgood 2015-05-19 15:58:15 UTC
Confirmed also on 


ersion: 5.0.0.0.alpha1+
Build ID: 245142cef18d4670a52094165fb4e4aedbb75496
Locale: fr-FR (fr.UTF-8)

It affects all rendered windows containing any kind of object
Comment 4 sophie 2015-05-21 12:11:45 UTC
Reproduced also on Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: fr-FR (fr_FR.UTF-8) - Sophie
Comment 5 Alex Thurgood 2015-05-21 14:59:58 UTC
This is now WFM with 


Version: 5.0.0.0.alpha1+
Build ID: 1349491d48a2f8a130f1b8b840383d31e7927252
Locale : fr-FR (fr.UTF-8)

on OSX 10.10.3
Comment 6 raal 2015-05-21 15:19:26 UTC
WFM with Version: 5.1.0.0.alpha1+
Build ID: 5b248f1348260f953686b20621255aece57358fe
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-21_12:28:08

Michael, please retest with newer build. Thanks
Comment 7 Michael 2015-05-21 16:19:03 UTC
Bug still present in 5.1.0.0.alpha1+

build 1c9302565aefb5a54b1b7f1478dd6dac724d30ea in lo-linux-dbgutil-daily
Comment 8 Michael 2015-05-21 18:25:30 UTC
The bug is not restricted to Tools->Customize. Others that have the same problem are:

File->Properties
File->Print
Insert->Frame
Insert->Section
Insert->Cross Reference
Format->Paragraph
Format->Page
Tools->Footnotes/Endnotes
Tools->Outline Numbering

However having just tried all of those, I now notice that it's primarily dialog boxes that have multiple tabs that are affected, and those without tabs are fine. (The corruption persists when switching tabs.)

There is at least one with tabs that does not have the bad background:
Tools->AutoCorrect Options
Comment 9 Miklos Vajna 2015-05-22 13:31:35 UTC
Adding Tobias to CC, I can reproduce the problem with a default LO build (only gtk2 VCL plug, no gtk3 or kde* one) + on KDE/Linux (oxygen-gtk theme).

As the description says, this sounds like a regression from the VCL mainloop properities rework, source range:

825098182227fdca958f84235d278c41b2b942ab..333f8a76341f5b4921e89012d133007503e49612
Comment 10 Miklos Vajna 2015-06-03 07:48:44 UTC
Bubli on IRC says that she doesn't see this in a "kde4 vclplug under kde" scenario, so it seems that the bug is limited to using the gtk2 vclplug under kde. This "gtk2 under kde" may sound like a rare corner-case, but given that the default build without any arguments gives that, it makes e.g. all bibisect builds hardly usable under KDE, which is more worrying.
Comment 11 Commit Notification 2015-06-12 13:40:22 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e6a1956034c98204e30b0ca40330249d6f6f8155

tdf#91301: Don't cache incomplete tabs.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-06-12 13:41:49 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b33e8f6c8bb6aea259b97e58bd8534d47919910&h=libreoffice-5-0

tdf#91301: Don't cache incomplete tabs.

It will be available in 5.0.0.0.beta4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Jan Holesovsky 2015-06-12 15:55:47 UTC
Fixed now.

The rendercontext double-buffering will make this easier, as the Gtk+ theme engine attempts to do a kind of double-buffering via fetching the bitmap from the screen - which is very expensive, so additionally it has a cache to remember the fetched data, that easily can get out of sync with the real screen.
Comment 14 Michael 2015-06-13 08:41:20 UTC
I confirm that the incorrect background painting is fixed following this patch, tested with:

Version: 5.1.0.0.alpha1+
Build ID: f36ac1aa3bef5ba218f3dae24f260ce7e4afba95
Locale: en-CA (en_CA.UTF-8)
Comment 15 raal 2015-06-13 09:06:24 UTC
(In reply to Michael from comment #14)
> I confirm that the incorrect background painting is fixed following this
> patch, tested with:
> 
> Version: 5.1.0.0.alpha1+
> Build ID: f36ac1aa3bef5ba218f3dae24f260ce7e4afba95
> Locale: en-CA (en_CA.UTF-8)

Verified
Comment 16 Robinson Tryon (qubit) 2015-12-17 09:09:21 UTC Comment hidden (obsolete)