Bug 91493 - Issue with installing and not an administrator
Summary: Issue with installing and not an administrator
Status: RESOLVED DUPLICATE of bug 58118
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Win-Installer-MAB
  Show dependency treegraph
 
Reported: 2015-05-22 18:41 UTC by Chuck Thomka
Modified: 2017-04-28 19:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Error message screenshot (10.33 KB, image/png)
2015-12-17 17:40 UTC, Michael Bauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Thomka 2015-05-22 18:41:17 UTC
I've noticed this for a while now, but I have finally decided to report it.

When I am logged on as a regular user, not as someone with administrative rights, I do get prompted to enter the administrator password (as to be expected).

It then goes about the usual processes to validate the files, and then removes the previous version, removing the desktop icon, etc., and starts copying the new files.
BUT THEN
At some point in copying the new files I get an "Error 1303"
"The installer has insufficient privileges to
access this directory: C:\Program Files (x86)\LibreOffice
4\program. The installation cannot continue. Log on as
an administrator or contact your system administrator."

Of course when I do log on as an administrator it does correctly install, but what annoys me is that it starts off fine, removing my current installation, and then makes the old install no workable. But then does not correctly install, leaving me with an unusable program.

Please, either prevent the install process from starting with any removing unless it really does have the correct rights to complete the whole process.
Comment 1 Jean-Baptiste Faure 2015-05-23 06:25:30 UTC
Please enter some essential information:
- your OS (MS-Windows, I presume, but which version?)
- the LibreOffice version
- a clear and not ambiguous step by step scenario to reproduce the problem.

Setting status to NEEDINFO, please set it back to UNCONFIRMED once you have provided requested information.

Best regards. JBF
Comment 2 Chuck Thomka 2015-05-28 21:05:26 UTC
Using Windows 7 Home Prem, trying to install LibreOffice 4.4.3
BUT I have noticed this same problem on earlier versions (ie, 4.40, 4.4.1, 4.4.2).
If I am logged on as a regular user (no admin rights) I run into a stop of "The installation cannot continue." because, evidently, I do not have admin rights. I have been simply just re-logging on as an administrator and then having no problem in installing LibreOff. But I feel that this should not be what I should have to do.

If I attempt to install, as a non-admin, the install process removes the working version I had, and then refuses to continue with the final steps of installing. A real inconvenience that could be avoided with either the proper knowledge of rights, or the proper assertion of temp admin rights when I give the correct admin password.

As for step-by-step....
is it so hard to just try to install LibreOff while not being an admin?
I need to tell you how to do that?
Comment 3 Jean-Baptiste Faure 2015-07-12 18:06:08 UTC
(In reply to Chuck Thomka from comment #2)
[...]
> As for step-by-step....
> is it so hard to just try to install LibreOff while not being an admin?
> I need to tell you how to do that?

Yes. I do not have a MS-Windows OS to try (yes, MS-Windows is not the only OS in the world), but I remember that you can try at least two ways to install a software while you are logged with a non administrative account:
1/ launch the installer
2/ right click on the installer in the file explorer and choose something like "open as...", then you are prompted to enter a login and password of an administrative account.

The first should not work at all and the second should work.

Best regards. JBF
Comment 4 Michael Bauer 2015-12-17 17:39:58 UTC
I can't believe this got marked as unconfirmed, it is literally all over the LO helpdesk (just google "libreoffice error 1303"). I've just run into it *again* installing 5.0.4.2 on Windows 10 (see screenshot).

To date, the *only* reliable workaround I have found is (as I commented in this help request in Feb 2014 https://ask.libreoffice.org/en/question/16047/error-1303-when-installing-libreoffice-402-on-windows-8-pro/) to install LO *outside* the default /Program Files or /Program Files (x86) folders.

I have tried UAC. No luck. I have tried running as admin, either via CMD or by tweaking the registry. No luck. I have tried manually uninstalling, rebooting, no luck.

Somehow I thought there was another bug on this, I vaguely remember a debate but I cannot find it just now.
Comment 5 Michael Bauer 2015-12-17 17:40:33 UTC
Created attachment 121371 [details]
Error message screenshot
Comment 6 tommy27 2017-04-25 12:21:17 UTC
is it still an issue with latest LibO 5.3.2.2?
Comment 7 Buovjaga 2017-04-28 19:12:06 UTC

*** This bug has been marked as a duplicate of bug 58118 ***