Bug Hunting Session
Bug 91515 - Inserting comments the text background will be white regardless of comment box background (black background after copy&paste)
Summary: Inserting comments the text background will be white regardless of comment bo...
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 89671 92319 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-23 11:09 UTC by Edmund Laugasson
Modified: 2015-10-28 09:13 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
document created during backtrace as root (3.11 KB, text/x-log)
2015-05-23 11:22 UTC, Edmund Laugasson
Details
document created during backtrace as root (19.26 KB, application/vnd.oasis.opendocument.text)
2015-05-23 11:24 UTC, Edmund Laugasson
Details
document created during strace as regular user (19.37 KB, application/vnd.oasis.opendocument.text)
2015-05-23 11:25 UTC, Edmund Laugasson
Details
strace log in Linux (53.85 KB, text/plain)
2015-05-23 11:25 UTC, Edmund Laugasson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Edmund Laugasson 2015-05-23 11:09:29 UTC
Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
LibreOffice version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)

Inserting comments the text background will be white regardless of comment box background

Workaround is to select all comment text with CTRL+A and then remove direct formatting with CTRL+M.
Additionally when doing cut-paste then that text has black background and not readable at all. Also here is the workaround like previously described.

Steps to reproduce:
* insert text
* insert comment text - background will be automatically white

Expected result: comment text without background
Comment 1 Edmund Laugasson 2015-05-23 11:11:53 UTC
This bug exist also in LibreOffice 4.4.3.2 on the same platform.
Comment 2 Edmund Laugasson 2015-05-23 11:22:45 UTC
Created attachment 115883 [details]
document created during backtrace as root

Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
LibreOffice version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)
Comment 3 Edmund Laugasson 2015-05-23 11:24:44 UTC
Created attachment 115884 [details]
document created during backtrace as root

previous was log file - this one is the document - problem is that I cannot fix mistakes and have to make new comment...

Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
LibreOffice version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)
Comment 4 Edmund Laugasson 2015-05-23 11:25:27 UTC
Created attachment 115885 [details]
document created during strace as regular user

Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
LibreOffice version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)
Comment 5 Edmund Laugasson 2015-05-23 11:25:59 UTC
Created attachment 115886 [details]
strace log in Linux

Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
LibreOffice version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)
Comment 6 pierre-yves samyn 2015-05-23 11:51:34 UTC
*** Bug 89671 has been marked as a duplicate of this bug. ***
Comment 7 pierre-yves samyn 2015-05-23 11:53:45 UTC
Hi 

I reproduce on windows 7/64 & Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale : fr_FR

Also with Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: fr-FR (fr_FR)

Issue was already reported but you give a workaround.

Regards
Pierre-Yves
Comment 8 Simo Kaupinmäki 2015-05-31 23:09:48 UTC
I can also reproduce this in Libo 4.4.2.2 (from the Debian Jessie backports). However, the bug does not exist in Libo 4.3.3.2 (from the Debian Jessie repository).
Comment 9 Katarina Behrens (CIB) 2015-06-25 08:10:26 UTC
*** Bug 92319 has been marked as a duplicate of this bug. ***
Comment 10 Severo Raz 2015-07-16 19:35:44 UTC
I can reproduce this bug. I am using Arch Linux 64-bit and LibreOffice 4.4.4.3.
Comment 11 Jean-François Fortin Tam 2015-08-16 19:36:39 UTC
FWIW, still present in 5.0
Comment 12 OfficeUser 2015-09-03 14:55:30 UTC
Still present in version 5.0.1.2.

One more bug that is possibly related:

When copy&paste such text with white background from one comment into another comment, the result is black text with black background appearing as an unreadable black bar!

==> Increased Importance, added keyword "regression"
Comment 13 Ulrich Windl 2015-09-08 12:32:57 UTC
I can confirm this bug (maybe new in 4.4.5.2 (Windows 7)): If you add a comment, and then insert text from the clipboard (even for "unformatted text"), then the text is "black on white", even if the rest of the background is yellow as usual.
Comment 14 Simo Kaupinmäki 2015-09-14 17:37:53 UTC
Based on the duplicate bug 89671, this issue was already present in LibO 4.4.0.3, whereas 4.3.6.2 was free of it.

The good news is that it seems fixed in LibO 5.0.2.1 (perhaps related to bug 87922, which has been fixed in that version and will also be fixed in the upcoming LibO 4.4.6).
Comment 15 OfficeUser 2015-10-04 11:43:48 UTC
I can confirm that this issue is completely fixed in LibreOffice 5.0.2.2 Linux and Windows builds.

(No white background anymore and no black background anymore after copy&paste from one comment to an other comment.)

Thanks!
Comment 16 OfficeUser 2015-10-04 11:44:55 UTC
I have set RESOLVED FIXED. I hope this is ok. I don't know which patch has solved this issue.
Comment 17 Simo Kaupinmäki 2015-10-04 12:13:43 UTC
I think WORKSFORME is the correct resolution here, as the exact fix is not known.
Comment 18 Ulrich Windl 2015-10-05 06:16:11 UTC
(In reply to Simo Kaupinmäki from comment #17)
> I think WORKSFORME is the correct resolution here, as the exact fix is not
> known.

I disagree: WORKSFORME implies that it never was an issue, while FIXED says it once was a problem, but now is fixed.
Comment 19 Simo Kaupinmäki 2015-10-05 13:46:28 UTC
(In reply to Ulrich Windl from comment #18)
> (In reply to Simo Kaupinmäki from comment #17)
> > I think WORKSFORME is the correct resolution here, as the exact fix is not
> > known.
> 
> I disagree: WORKSFORME implies that it never was an issue, while FIXED says
> it once was a problem, but now is fixed.

Well, I understand how you can get this impression, but I think you are mistaken. There is another resolution which explicitly states that the bug has never been an issue, and that is INVALID. What WORKSFORME implies is simply that the bug cannot be reproduced in the current version. Granted, it may be an appropriate resolution even when nobody has been able to reproduce the bug, but its use is not restricted to these cases.

After version 5.0 was released a few months ago, the QA Administrators added a comment to several bugs (e.g., bug 80027) that had been quiet for more than a year, asking people to check whether the bug was still present:

"If the bug is NOT present, please set the bug's Status field to
RESOLVED-WORKSFORME and leave a short comment that includes your version of
LibreOffice and Operating System
Please DO NOT [...]
Set the bug's Status field to RESOLVED - FIXED (this status has a particular
meaning that is not appropriate in this case)"

So, according to the QA Administrators, WORKSFORME is the most appropriate resolution when the issue has been fixed but you cannot exactly say how this has happened and by whom.
Comment 20 Edmund Laugasson 2015-10-05 14:21:27 UTC
I can also confirm that at least under 64-bit Linux (DEB-version) with version: 5.0.2.2, ID: 00m0(Build:2), Locale: et-EE (et_EE.UTF-8) commenting works now as expected - no more white or black background. Hopefully all other platforms have same luck. Thank you!
Comment 21 claudio 2015-10-28 09:13:50 UTC
Using Libreoffice 5.0.1.2 locale it-IT (it_IT)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
System: Windows XP Professional SP3

I can confirm this bug and the related workaround.