Bug Hunting Session
Bug 91533 - Tooltips are truncated if OS default font is size 12
Summary: Tooltips are truncated if OS default font is size 12
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: All Linux (All)
: low trivial
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.2.2 target:5.1.6
Keywords: regression
Depends on:
Blocks: Toolbars-Tooltips
  Show dependency treegraph
 
Reported: 2015-05-23 16:15 UTC by Jean-Baptiste Faure
Modified: 2017-10-18 16:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
truncated tooltip (68.68 KB, image/png)
2015-05-23 16:37 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2015-05-23 16:15:03 UTC
Tested under Ubuntu / Unity 15.04 with several different default fonts (Ubuntu, Sans, Linux Biolinum, etc.) at OS level. It is clearer with the tooltips of the status bar.
If I change the size of the default font to 11, there is no problem.

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2015-05-23 16:37:32 UTC
Created attachment 115906 [details]
truncated tooltip
Comment 2 Buovjaga 2015-05-25 14:18:54 UTC
Tools - Options - Fonts & changing the font & size does not seem to have any effect at all on the tooltip fonts (size/family). Is there something I'm missing?

Ubuntu 15.04 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: 7dfe9f14d77f216f43ce22efd6addea6f53aad58
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-05-24_23:17:42
Locale: en-US (en_US.UTF-8)
Comment 3 Jean-Baptiste Faure 2015-05-25 14:27:03 UTC
(In reply to Beluga from comment #2)
> Tools - Options - Fonts & changing the font & size does not seem to have any
> effect at all on the tooltip fonts (size/family). Is there something I'm
> missing?

Yes, the font used to display the tooltips is the default font of the OS, it is not defined in LibreOffice. On my configuration, it is Ubuntu 12. Even if I change the default font, if I choose a size 12, tooltips are truncated, if I choose a smaller size (11 or 10) the tooltips are fully visible.

Best regards. JBF
Comment 4 Jean-Baptiste Faure 2015-05-25 16:06:16 UTC
If I change the scale factor (Menu Tools > Options > LibreOffice > View) to something slightly different from 100% (says 99% or 101%) then the problem disappear in the current session. It comes back if I close and restart LibreOffice.

Best regards. JBF
Comment 5 Buovjaga 2015-05-26 12:13:01 UTC
In dconf-editor I went to org > gnome > desktop > interface and changed font-name to Ubuntu12. It altered the UI font size visibly.
Then went to LibO to test the tooltip, but it doesn't truncate.
The tooltip font size didn't look like it changed, though.

So how should I do this change to reach the same result?
Comment 6 Jean-Baptiste Faure 2015-05-26 12:26:42 UTC
(In reply to Beluga from comment #5)
> [...]
> So how should I do this change to reach the same result?

Install Unity Tweak Tool which is available in the Universe repository.
Then you can change the default font, the font scale and tweak the anti-aliasing.

Note: Today I installed my own build of LO 5.0 beta1+ on another computer with bigger screen. This computer is under Ubuntu 15.04 x86-64 too and I can't reproduce the problem with it. So the problem seems to be related to the screen size. On my laptop with screen 1366x768 I have the problem, on a screen 1920x1080 I do not reproduce it.

Best regards. JBF
Comment 7 Buovjaga 2015-05-26 13:23:46 UTC
Ok, I had Ubuntu regular 12 even in Unity tweak tool.
My resolution 1360x768 and it is a virtual machine.
Comment 8 Jean-Baptiste Faure 2015-06-05 07:37:42 UTC
I have found that I can restore a correct view of the tooltips, even with a system font of size 12, by doing that:
1/ in Tools > Options > LibreOffice > View: change the scale factor from 100% to something else, like 99% or 101%
2/ validate
==> tooltips view is correct
3/ restore the initial value of the scale factor
==> tooltips view remains correct

But: the change is not preserved if I close and restart LibreOffice.
Comment 9 Jean-Baptiste Faure 2015-06-14 19:10:25 UTC
I have found that if I change the minimum pixels number for anti-aliasing the screen font, then the screen is redrawn and the font size of the tooltips becomes correct. As for changing the scale factor, the effect of this change is lost when LibreOffice is restarted.

Note: I do not encounter this problem with the master.

Best regards. JBF
Comment 10 Jean-Baptiste Faure 2015-07-05 09:10:51 UTC
Another find: the problem does not occur with a clean fresh user profile. But it goes back when LO is restarted after a crash (ctrl+C in the terminal from which I launched LO is enough).
In such a case, I found that I can fix the problem by modifying the registrymodifications.xcu file. If I compare the file from a fresh user profile before and after a crash, I found that purging the recovery list fixed the problem.
Before the crash:
	<item oor:path="/org.openoffice.Office.Recovery/RecoveryList">
		<node oor:name="recovery_item_1" oor:op="remove"/>
	</item>
After the crash (here after a test for bug 91574):
	<item oor:path="/org.openoffice.Office.Recovery/RecoveryList">
		<node oor:name="recovery_item_1" oor:op="replace">
			<prop oor:name="Title" oor:op="fuse">
				<value> <...> </value>
			</prop>
			<prop oor:name="Filter" oor:op="fuse">
				<value>impress8</value>
			</prop>
			<prop oor:name="Module" oor:op="fuse">
				<value>com.sun.star.presentation.PresentationDocument</value>
			</prop>
			<prop oor:name="TempURL" oor:op="fuse">
				<value></value>
			</prop>
			<prop oor:name="ViewNames" oor:op="fuse">
				<value></value>
			</prop>
			<prop oor:name="OriginalURL" oor:op="fuse">
				<value>file:///home/...</value>
			</prop>
			<prop oor:name="TemplateURL" oor:op="fuse">
				<value></value>
			</prop>
			<prop oor:name="DocumentState" oor:op="fuse">
				<value>0</value>
			</prop>
		</node>
	</item>

If I restore the state before the crash of the recoverylist item, then the tooltips have the correct font size without having to force a redraw of the UI by changing the scale factor or the minimum pixels number to apply font anti-aliasing.

Best regards. JBF
Comment 11 Aron Budea 2016-08-11 06:31:08 UTC
Confirmed with LibreOffice 5.2.0.4 / Ubuntu 16.04. The bug is very similar, and probably related to bug 94666.
Indeed, no truncation in 4.4.0.3. => regression
Comment 12 Commit Notification 2016-08-18 13:34:32 UTC
rpmbuild committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e527edf06f8befb45b76ee8ebabe62e6dc885e45

Resolves: tdf#91533 (rhbz#1364335) Tooltips are truncated

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2016-08-18 13:36:28 UTC
I could reproduce this at 1368x768 and the above patch made it go away
Comment 14 Commit Notification 2016-09-08 15:34:50 UTC
rpmbuild committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02b6a8ae5a0ad4ebb0c929ebf079e01eb76762f8&h=libreoffice-5-1

Resolves: tdf#91533 (rhbz#1364335) Tooltips are truncated

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.